LH-20A1H and Vista

vbimport

#1

I have Vista Home Premium. I swapped DVD drives adding the LH-20A1H. Vista couldn’t find a driver. This the first CD/DVD I’ve ever installed that didn’t just install!! The drive showed up in Explorer, but properties showed no driver! Then, to make matters worse, I must have clicked Don’t Ask me Again on a reboot, now I can’t figure out how to get the drive even recognized again. Is there a way to reset it so Vista at least tries to install a driver and the drive is recognized?

Is there a driver for this drive somewhere or how do I get it setup?


#2

This sounds pretty odd like maybe some other cable or hardware issue.

I have my LH-20A1H installed on the Premium Home as well but I have mine in an external USB enclosure.

Sorry not sure how to reset but if is like XP for HW discovery it should rediscover if you disconnect then reconnect or run the HW discovery wizard.


#3

Did you set the jumper correctly? My 20A1H works fine on Vista Premium.


#4

OK, I went in control panel and set to show hidden devices and the Lite-on showed up. I uninstalled it and on the next boot it at LEAST shows up again. It still won’t find a driver, and it shows up in Windows Explorer as CD-Rom, not DVD. I haven’t tried burning or anything. It will read a normal CD. On every startup, Vista wants to install a driver and can’t!

As far as cabling/jumper, it shows up in the BIOS as Lite-On LH-20A1H, secondary slave, I have it jumpered CS, it is on an 80 wire premium rounded cable that has worked for the DVD drive I removed to replace with the Lite-on for a long time. I booted the computer into Windows XP from another SATA HD and XP installs it without question as Lite-On LH-20A1H DVD, same computer, same cable, same jumper settings.

This is an OEM drive, no box/manual/CD, but I haven’t had to put a CD into the drive for a CD/DVD drive in YEARS. This has me stumped!

Things I may try. Jumper to Master/Slave, I’ve had other drives that didn’t like CS. Put it on the end of the cable/master, and see if that rectifies it. I have another Vista (Ultimate) computer, I may try it in that one, see if I get the same behavior.

Any other way to get a driver installed?


#5

Wow, I tried jumpering all ways, I tried the Lite-on alone, with my CD, everything, won’t install a driver no matter how I do it. In fact, when I jumpered the Line-on as Master and my TDK CD burner as slave, Vista wouldn’t install a driver for either even though it had seen the TDK forever! I put everything back like it was and everything is fine, no Lite-on installed!!

I’ll try it in my other Vista computer alone and with the CD, and if it doesn’t work then, I’m giving up unless someone here can help. I’ve used Plextors for years and never had a problem like this, so I guess I’ll run back to what works and foist the Lite-On off on someone else.


#6

I have a LH-18A1P that works fine in Vista. When you install an optical drive in Windows, it’s not installing a driver for the specific drive - if you look under drivers, it installs a generic CD-ROM.SYS driver. I assume Windows gets the drive details from the BIOS.

Have you got another DVD burner that you can try? Looks to me like Vista has got very confused.


#7

I put the Lite-on in my other Vista machine and it’s fine. I installed the Plextor 708A out of that machine in this one and Vista won’t see that one as a DVD either. It does generically install the cdrom.sys driver. It shows up in Windows Explorer as CD-Rom, not even CD-RW like the TDK CDRW drive in the same computer, let alone DVD-RW like it showed up in the other Vista computer.

I’ve tried all jumper settings on all the drives, I’ve tried 3 cables, all known to work in other computers. It isn’t a Lite-on problem, it’s some esoteric Vista issue. On the other computer, both the CDRW and the Lite-On have cdrom.sys AND pxhelp20.sys installed, on this one only cdrom.sys for BOTH. On both computers the file pxhelp20.sys in C:\Windows\System32\Drivers is the same size/date. I have no idea why one computer installs both and one installs only cdrom.sys. Off to sleuth some more, I guess.

Any other ideas what to try?


#8

I figured out the pxhelp20 thing. I had edited the registry to remove a key called LowerFilters in an attempt to fix this thing. I put it back, took it out, either way, my drives aren’t recognized. NOW I have it where neither the TDK CDRW drive nor the Plextor 708A are recognized. I installed them in Device Manager and tried to let them reinstall, no joy. Nothing works now!!

I’m really stuck now! Suggestions welcome, short of a reinstall! I’ve never tried any kind of Vista repair install, not sure it that’d work.


#9

I’ll reply to myself one more time, mostly to bump, then wait, hoping someone finds a solution.

This is doubly strange because Nero will recognize and use both the CDRW and the DVDRW, but Windows Explorer only sees the DVD as CDROM. Trying to use, for example, Live One Care Backup, it doesn’t see ANY writeable CD/DVD any more. Nero Backitup is backing up to the DVD as we speak!

I guess the drives are usable as long as I’m using Nero 7, but Vista doesn’t see them and won’t use them for ANY of it’s things.

There HAS to be some sort of fix for this short of reinstalling Vista. There are other threads around the web, so this is common enough. But, alas, I can find no solution that works for me. If that many people are seeing the disappearing DVDRW drive, MS should be able to come up with a fix, or someone here or elsewhere might be able to figure out something. Me? I’m stumped.


#10

I am having much of the same problems as you. This was a build for my older brother…he was a little tight on $$, so we just went with cheaper OS…
Specs:
Vista Home Basic
x2 3800+
EP MF4-Ultra3
2Gb RAM
LiteOn LH-20A1H (OEM)

However, I cannot for the life of me figure out how to even get Vista to (mis?)recognize the drive. Drive is hooked up on IDE1 as master and is recognized in BIOS as well…

(drive doesn’t show up)

(same no-driver issues)

Back when I first set up the system, it seemed to work (didn’t try to burn anything), but the drive was @ least recognized and read cd’s…not now. After letting the older bro take his machine…well, I have no clue what happened.


#11

Have no clue. Works without a problem (20A1H) for me in Vista Ultimate x64 Edition.


#12

That’s most of the problems here. More than one user or the other users don’t realize what they just did to the machine.

It’s hard to trouble shoot problems when this is the situation.


#13

My situation is SLIGHTLY different from yours. In My Computer, mine show up, but my DVD-RW drive, now on this computer a Plextor 708A, show up just as CD-Rom. My CD-RW drive does show up as CD-RW but neither shows up in any Windows Vista places, Live One Care for example, or Backup, as usable for backups or anything.

As I said, there must be a fix for this, a registry entry or something. Let’s keep looking, although this isn’t a Lite-On problem!! Just that swapping in a Lite-On drive started this for me.

An interesting aside, Lite-On email tech support told me sorry, the drive doesn’t work in Vista, but their newest drives shipped with Nero in the box, and it worked with THAT!! No joy for us OEM buyers, no disk, but that’s exactly my problem, only works with NERO, and now, ANY DVD-RW, not just Lite-On. Pretty strange, seems to me. That coupled with the fact that I swapped the Lite-on into another Vista computer and it is working fine!!!


#14

Here are some possible solutions.

  1. Make sure no 3rd party IDE drivers are installed (use only the MS default).
  2. Uninstall both drives in device manager then close the PC down and remove the drives. Re-start the PC and allow it to fully boot. Close the PC down and re-fit the drives.
    3, If the above fails and you’re feeling brave. :slight_smile: Remove the drives again (uninstall as before). Then uninstall the IDE controllers in device manager. Re-start allowing the IDE drivers to be installed. Close down the PC and re-fit the drives.

#15

Wow, now I have no drivers for any IDE devices!!

Step one, no problem, only MS IDE drivers.

Step 2, didn’t work, same thing, only now CDRW shows as CD-ROM, and DVDRW shows as CD-Rom in My Computer. Device Manager shows both drives by their name.

Step 3, now it won’t install any IDE drivers for anything after uninstalling all them and rebooting. When it boots, I have to click thru 8 or 10 driver install failures instead of only 1!!

How do I get the IDE drivers to install? They installed fine when installing Vista Home Premium in the first place!

This is an Asus A8N5X MB. I fell back to having only ONE SATA HD attached, the Windows Vista boot drive, and it still wouldn’t install drivers. I updated the BIOS to the latest after all this with Vista, that didn’t help either. Device Manager shows 3 IDE Controllers, 3 ATA Channel 0, 3 ATA Channel 1 devices, driver provider UNKNOWN on all of 'em.

I see the disk drives, all of 'em, in Device Manager, but they show UNKNOWN for driver there, too, they DO seem to work. Both RW drives show as CDROM, driver unknown.


#16

Something is very screwed up with your Vista install :slight_smile:


#17

I’d say SO!! And all this started the instant I replaced an older DVD-ROM drive with the Lite-On!!

I tried a restore point, then the computer wouldn’t boot. It told me to put the Vista DVD in, boot, do a Computer Repair. Did that. Now it boots again, but still the same problem with the drives, although I now have two IDE controllers called Standard Dual Channel PCI IDEController and just one called IDE Controller with no driver installed. The two mentioned above have MS driver installed. Not sure it they’re the SATA controllers, or the normal IDE.


#18

Well, I got MINE fixed, finally!

After a neither a System Restore nor a Repair fixed it, I was poking around in Device Manager trying to apply logic to which IDE devices had drivers and which didn’t. I couldn’t figure anything out, so I tried clicking Update Driver, picking Browse my computer for driver, and manually pointing it at C:\Windows\System32 and it’s subdirectories. That worked on one, so I did it to all devices and I have them all back. My Computer shows the RW drives, both CDRW and DVDRW, as RW drives, all the hard drives are back with drivers, all IDE channels have drivers. All seems well.

Only strange thing with this was a couple drive letters got hosed and I had to go into Drive Management and put them back like I wanted them (color me old fashioned!) It’s been a long 3 or 4 days of wonderment.

This is how we get to be “experts.” Heck with them Mac’s, they just work and we never get to learn all this “valuable” information.


#19

I’m glad to hear you got it working and thanks for sharing the “fix”. :iagree:


#20

One more addition to this thread. I had a USB Bluetooth dongle that wouldn’t install a driver. In searches for solutions, I found some info on a file in C:\Windows\inf called INFCACHE.1 that I deleted and it fixed the problem of drivers not installing. It’s tricky to delete, you have to take ownership and change properties, maybe there are other ways. There is also a registry key, HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion, key DevicePath, wants to be ONLY %SystemRoot%\inf, nothing more!!

Wondering if this wasn’t the problem with my RW drives not being able to install drivers. Not sure how this file gets hosed, but a quick Google on INFCACHE.1 will yield some info if you’re looking! Just sticking this here so if anyone finds this looking for the same problem they’ll have another path to check!!