LG WH14NS40 won't recognize bluray or DVD disks

vbimport

#1

Hello. This is my first bluray drive and things aren’t going well. I just got it today and installed it a few minutes ago. Windows shows the drive and identifies it correctly. The drivers say it’s a CD/DVD drive. Inserted two blurays (Walle and ratatouille) and neither showed up. Not in Windows computer section. Not in makemkv or DVDFab. It just says insert disc. Tried a DVD and the same think except it seems to be trying to read the disc endlessly. Updated the firmware and no change.

Is this just bad luck and I got a DOA? Or should I check anything in the BIOS or another Sata cable? Getting to the PC to swap the cable is a bit of a pain.


#2

Do you have a bootable disc available? A Windows operating disc, a Linux live cd, or even something like the Ultimate Boot CD would work. You would need to go into the bios and make sure that the optical drive is the first choice for booting the computer.

If the drive will read a bootable disc, outside of Windows, you know that the hardware is in good shape. This would leave you with some sort of error in the operating system.

If you are running XP, Vista or Win 7, you could try the Microsoft Fix-it tool: http://support.microsoft.com/mats/cd_dvd_drive_problems It rarely seems to work well however.

You can also try deleting the upper and lower filters and see if that helps. http://support.microsoft.com/kb/929461 These instructions are for Vista, but apply to Win 7 and XP as well.


#3

Thanks. I’ll give that a try when I get home.

Last night I yanked the PC out again and swapped the SATA port and cable. No difference. Also tried reading a CD and that doesn’t work either. Something is happening though because it causes the software in Windows to freeze (WMP, VLC, etc).

The PC is running Win7 x64.


#4

Just wanted to say thanks. Very strange but the problem is fixed.

I plugged the drive back into the PC last night and had the same problems in Win7. So I pulled out an old install disk, changed the boot priority, and what do you know it worked! So I figure it must be something strange with my Win7 install on that PC which I admit is a bit of an unorthodox installation (OS on SSD, Users/Program Data moved to HDD RAID1 drive using unattended install, OS customized and trimmed of many features I didn’t need at the time like WMC). So I hooked it up to a different PC with a standard Win7 installation and everything worked. So I figure, it must be a Win7 installation issue, I’ll try those links you posted to see if it solves it. So I plug it back in, boot into Win7, getting ready to install the fixes, but then I notice that the disk I had in the drive was magically working! I was able to rip bluray disks in like <25 minutes and was very impressed.

So again I just wanted to thanks for the test idea. Saved me a bunch of time trying to RMA something I didn’t have to. I’m going to keep an eye and try to use it a lot this weekend to make sure it doesn’t act up or anything.