LG GSA-H55N -CD DVD drive doesn't recognize certain cds and DVDS

vbimport

#1

Hi,

I’m sorry if this question was already asked and answered. I treied to search for a similar problem But I didn’t find anything as specific as mine. If there is, sorry.

My OS is Vista Home Premium 32 bits.

My cd/dvd drive is HL-DT-ST DVD-RAM LG GSA-H55N SCSI.

I have one strange problem with my cd/dvd drive since a couple of days.

—My cd/dvd drive doesn’t recognize Maxell CD-R discs and certain movie dvds and doesn’t read any music cds (manufacturized albums). When I insert the disk, there’s this message ‘‘Insert the disk on Drive E:’’.

But it doesn’t have any problems with other CD-R and DVD-R like Memorex and Sony.

Last week, October 26, I played a DVD movies (like Broadway melody) without any problems. I tried to play it again today it gives me the ‘‘insert the disc message’’.

Thanks


#2

Is there a way to figure out what’s wrong?


#3

I just went through a similar thing with my GSA-55N.
You will find many things to try doing a Google search for “DVD-ROM troubleshooting”.

One of many checks: run MSINFO32.EXE. When it opens click on “System Drivers” under "Software Environment"
Check if both cdfs and udfs are Running. These are the CD and DVD file system drivers. If not:
Open Regedit aꏀnd go to:HKLM\System\CurrentControlSet\Services.
Scroll down to Cdfs and in right panel open “Start” and change to 2.
Then do the same for Udfs. REBOOT

Second you may have installed something that filters the use of some disks. Back up your registry and go here to learn how to remove filters: “http://www.theeldergeek.com/restore_missing_cd_or_dvd_drive.htm” .

Yet, the thing that worked for me was DVD internal cleaning and oiling.

Shutdown and remove the DVD drive. Remove the 4 Phillips head screws from the bottom and remove the bottom plate. Use a large paperclip to push into the small hole in the front to release the tray, and extend the tray all the way out.

Now take a flat screw driver to push in the three tabs that hold the face plate, and remove ( the tray will hold it ).

Remove the top cover. Inspect the inside. Take a can of air and gently (from a distance) blow out and dust, etc. Be careful not to damage the laser lens.

Look at the rails and worm screw that control the laser position. Clean these. I used WD-40 on a cotton cloth.

Time to lube. Silicone spray lube is good, yet my favorite is Dupont Teflon Multi-Use Lubricant. If using this follow instructions to shake well and let the Teflon dry after application.

You want to lube both rails and the worm screw.

Gently, yet firmly, move the laser sled back and forth the full extent of the rails until it moves very easily.

Now you gently clean the laser lens (90% isopropyl will do) and reassemble the DVD. Re-install.


#4

Thanks. I’ve tried the two fist solutions but nothing has changed. I’ll try the cleaning and oiling

I the Problem History on my Windows there were some related to my drive which said:

[B]Windows was able to successfully install device driver software, but the device encountred a problem during execution (code 38)[/B].
Support.microsoft is absolutely no help. Not only do they keep talking about a Troubleshooting device I don’t have, they say that those who have Vista should call the Technical Support. What the Technical Support do? They tell you they can’t take care of it .

On google I couldn’t find a good soltuin either.

When i saw my event Viewer it says there were an Error from the CDRom device having [B]bad blocks with the ID of the event being: 7[/B]

I’ guessing a good cleaning is in order.