LG GSA-H54L Can\'t read Sony DVD-R 1.4GB

vbimport

#1

[qanda]This thread is about the LG GSA-H54L. Click here to see full specs[/qanda]This disc compatibility shit has gotten ridiculous.

Here’s my situation: I have the above mentioned DVD drive. My dad just got a camcorder that used mini dvd’s and we took some video and finalized the disc. It worked in his laptop. I get home with the disc (700 miles away) ready to pull the video off and do some touch up before posting to my family website. My drive won’t recognize the disc. It recognizes something is there. But it will not read the disc. I’ve tried the disc in no less than 4 different, albeit older, dvd drives. No luck.

I’ve been through disc compatibility issues before which was the whole reason I bought the H54L last year. So I’ve spent the last 2.5 hours reading the forum to find a work around.

I’ve read about and downloaded mediacodespeededit as it is my understanding that it can be used to add newer media codes. I read about and downloaded dvd-identifier. I’ve been through the process of identifying and teaching mediacodespeededit the codes for this Sony 1.4GB DVD-R mini disc. No joy.

Any help is appreciated because I have no idea what to do here.

RANT WTF is up with manufacturers lately. Surely, for the love of God there is a standard out there upon which all DVD discs should be readable by any DVD drive that is remotely modern. Why have DVD drives turned into a perpetual planned obsolescence device where every new disc to come out requires a new fucking drive. Jesus fucking Christ I’ve read about one guy that has no less that 6 DVD drives to accommodate just about any situation and he’s still got disc compatibility issues. If this is what can be expected from future developments in disc technology I say to hell with it. Screw blu-ray and just give me 50TB of hard drive space. It’s cheap enough these days.


#2

The problem is the “standard”. The “problem” is that whenever a new media is created, that disc gets a media id. For a drive to recognize that media, the firmware has to be updated to include that media id. So you simply have to update the firmware in your drive (assuming the manufacturer still updates the firmware for your “older” drive) or get a new drive.