LG GSA-H22N and CRC error reading discs

After much testing, I now believe that my LG GSA-H22N is incompatible with my motherboard’s IDE controller. I am using a Dell XPS Gen 3 PC. I am getting the “LOGICAL UNIT COMMUNICATION CRC ERROR…” reading certain discs in Nero CD/DVD speed on this drive. These same discs also produce an I/O error if I try to read them in Windows Explorer, so it’s not an issue with Nero CD/DVD speed. The drive burns discs perfectly, at least with the all the media I have tried. Here is what I have tried:

  1. Initially, the problem occurred when trying to read any disc. At that time, I had the drive as Master on the Primary IDE channel with a Slave drive also on the channel (a Liteon LTR-52327S). I removed the Liteon drive from the channel, so the LG drive was Master by itself on the channel. That helped the problem, but the problem still occurs on certain DVD-RAM and DVD+RW discs.

  2. The first cable (Dell supplied) was an 80 conductor cable. I swapped it with another 80 conductor cable (the one supplied with the LG drive). The second 80 conductor IDE cable did not help the problem. The problem occurred with both cables. The drive was Master by itself on the Primary IDE channel when either of these cables was attached.

  3. Media: the problem occurs on DVD-RAM discs written by the LG drive, and DVD+RW discs that were written on my set top DVD recorder and one that was written on my Plextor 716SA drive. My Plextor 716SA drive has no trouble reading the DVD+RW discs that the LG gets the CRC error on.

The only thing it could be is a bad drive, or an incompatible drive. I suspect that the drive is incompatible with the motherboard’s IDE controller. The motherboard is an Intel 925X with the ICH6R controller (82801FB Ultra ATA controller). I read after getting the drive (from a review on Newegg) that somebody else with a Dell Dimension 4700 could not read or write discs with this drive. The 4700’s motherboard is a 915G, with the same IDE controller (if I am not mistaken), so this incompatibility in a similar Intel based system also strongly indicates that the issue is compatibility. Is there anything else I should try? My motherboard only has one IDE controller, and 4 SATA ports, so I can’t try a different onboard IDE channel. I have 3 options (other than returning/selling the drive):

  1. Use a PCI Ultra ATA controller–I am in the process of doing this. I bought the controller, but I need to purchase a longer cable, as the cables I have don’t reach.

  2. Purchase an IDE to SATA converter, and use one of my onboard SATA ports. I am concerned about the compatibility of these converters, hence I am reluctant to go this route.

  3. Use an external enclosure–I don’t wish to do this, because of performance degradation and the inconvenience of using an external enclosure. I will consider this route as a last resort.

Is there anything else I need to try/consider??

Hello tlotz,

If I’m not mistaken, with Dell systems, you need to set the drive to cable select (CS).

What brand were those DVD+RW discs?

The DVD+RW discs where Verbatim 4X DVD+RW (MKM A02) and FujiFilm (RICOHJPNW11).  Your Cable Select suggestion was a good one, however, it did not solve the problem.  The drive set to Cable Select by itself with no other drives on the cable on the primary IDE channel does not work--the same CRC read problem persists.  Thank you for your reply.

Have you considered using write-once (±R) media, they are more reliable. DVD+RW are much more error-prone, especially when used more than once, but they are not great even pn the first write.

You are doing all the right things, hardware-wise, and a test with the new, separate IDE controller will answer your question about the motherboard/controller incompatibility.

Yes, actually I have many more DVD +/- R discs than DVD+RW. I just use DVD+RW for non-critical stuff and for my set top DVD recorder. I plan to use DVD-RAM for certain applications that I use DVD+RW discs for now.

I had similar problem as you mentioned on item 1)
It helps when I moved the slave Liteon LTN-301 CD-ROM drive to be Primary slave. My LG GSA-H22N (firmware 1.01) remained as Secondary Master. Now the reading and the writing of the drive are find on the any CD/DVD-R/DVD+RW etc.

This problem did not happened on my previous BenQ DVD bruner. I’m using MSI KMM400 Mobo with AMD Athlon XP1800+.

So, either its the Mobo IDE compatibility issue or the LG don’t like Liteon.

Are we sure that these are Communications CRC Errors on a read, or Media CRC Errors? Comms CRC errors are typically only seen on the outbound traffic (ie Writes), as inbound traffic problems would typically be noted by the IDE controller, not the device sending the data. Media CRC errors mean the drive can’t read the disc correctly.

As noted in our previous posts, Comms CRC errors are mostly cable related, but could also be attributed to the drive or the controller. It would be interesting to isolate which IDE controllers or motherboards were most problematic, then perhaps LG could investigate.

Brother Vlad

I’m having the same problem with this drive and motherboard Gigabyte ga-7dpxdwp AMD dual MP2000+. During verification, ImgBurn always reports “Logical Unit Communication CRC Error (ULTRA-DMA/32)”.

The drive works perfect on my Asus/Intel computer.

Actually, I was getting ready to revive this thread and post what happened with the LG GSA-H22N in my PC.  As I guessed, it *was* an incompatibility problem.  The drive works perfectly connected to an Ultra/133 PCI controller card.  I live in the U.S., so I went to Best Buy and bought and Adaptec Ultra/133 PCI controller card.  This card has a Silicon Image SiI 0680 chipset.  I was very relectuant to do this, because I had to free up an available PCI slot, because of air flow issues, and because I didn't have an IDE cable long enough to make the reach from the freed PCI slot, to the closest drive bay that I could use for the LG drive.  The controller was $36 + $9 for the 24" 80 conductor flat ribbon cable that was a pain to get quickly (had to wait for it).  The total was $45 + tax or about $46.80 .  That $46.80 was more than was spent for the drive that I got as a Christmas gift.  I had to go for a longer non-standard length IDE cable, because my 18" cables would not reach.  Anyway, my only other option would have been to try a different drive, or use an external enclosure.  I did try an IDE to SATA converter, which didn't work (no surprise, and I wasn't going to try another one of these dongles).  I really like this drive a lot, which is why I spent more than the drive was worth to get it working in my PC.  This LG drive combines super fast speed, with quiet operation, excellent writing quality, good build quality, and the best DVD-RAM support available.  Unfortuantely, I just couldn't pass that up, and am happy now that I got it working.

One last thing: having this drive on a PCI controller card presents one problem. Since it is on the PCI bus with my SB Audigy 2 PCI audio card, it sometimes interferes with the audio, and I can here little bits of “audio interference” while the drive is operating at high speed. This doesn’t affect DVD playback, since that doesn’t occur at high speed. Once I find something as good or better than this drive that is SATA (preferably from LG), I will replace this drive. I already have a SATA Plextor DVD burner (PX-716SA), so I know my motherboard supports SATA DVD burners. I am just really looking forward to getting back that PCI slot and extra air flow in my case, not to mention the fact that a SATA drive wouldn’t interfere with my sound card!

I’m having this problem too now. Here’s some detail:

Windows Vista Ultimate
Nero 7.7.5.1

I just got the drive about 20 minutes ago and I already wasted two MCC004 Verbatim 16x DVD+R

Any idea how to fix?

It reads DVD’s perfectly. Copied an entire disc to hard drive.