LG GSA-H22L, conflict with Win XP or there's something wrong with the drive?

Hi, I’m new here. And I’m writing because I’m having problem with my brand new drive… Well actually it ain’t much of a problem because I can go and change it for another unit on Monday, but until then I can’t find any peace until I find out what’s wrong with it.

So here goes. I bought a brand new LG GSA-H22L, firmware is 1.0 manifactured in September 2006. I hooked it up on my rig at the place of an old SANYO 24x CD-ROM, and it is sharing one IDE ribbon cable with a LG GCE-8526B CDRW drive.
So I started the PC, windows loaded, everything seemed fine, no problems in the device manager etc. Well I put in a DVD movie from my collection… And the drive couldn’t read it (my movie disks aren’t backups, they’re bought from a store). I put in several other movies - same result. I put in few DVD-Rs with games, same thing, same thing with CD-Rs also. Actually it didn’t run any disk. So I assumed I have a flawed unit and went on with the rest of my days agenda.

At a later hour, out of boredom, I decided to try to boot up the PC with a XP install CD on the DVD drive… Aaand you guessed it, it worked. This same CD couldn’t be red under windows. So I continued experimenting, and booted the PC with a Win98 Startup Disk, enabling Cd support, and all those disks that it couldn’t read under WinXP were perfectly readable under DOS?!!
So I assumed there was something wrong with my Windows… Well it was about 8 months since the last format/fresh install I did, so I assumed that’s normal.
Backed up everything on other partitions. Booted the WinXP setup CD in the LG H22L, format/installed windows without any problems, and it was quite fast… But when the new installation was ready, and I opened My Computer and tried to access the drive… Same thing it just couldn’t read the CD… The same CD that it installed Windows from, just a few minutes ago… So I decided There was something wrong with this particular build (It’s fan made, called SP3). So I erased everything on my C: once again, booted from an official Windows XP SP2 CD, installed windows once more from the H22L… And the problem was still the same.

Well it just doesn’t seem logic to me. It can read perfectly fine under DOS or under the fan made XP Live CD2. But in Windows XP can’t read any disk.
I should also note that after instalation I apply the September 2006 update for windows XP, also NET Framework 2.0 (offcourse I’ve tried the drive before installing those).
As for the media I’m using… well it’s various. TDK, SONY, Verbatim, PRINCO, SKY, RICOH… But the H22L just doesn’t care. It doesn’t want to read any of them.

Now I don’t want to sound like a show-off, but I have a lot of expirience with hardware, let’s say well above average, and I’ve never seen such a thing. True that optical drives ain’t my thing (I’m more into CPUs, mobos and memmory modules) but a good couple a dozen drives have been in my possesion, and I’ve never seen a drive that works fine in every other enviroment except windowsXP (tried Linux also… Damn Small Linux boot CD).
Well by “working fine” i mean reading, cause I never got to the writing part :slight_smile:

All I can think of is that it’s some kind of a firmware issue, but I couldn’t find any downloadable firmwares. And as far as I understood there are currently only two firmwares 1.0 (mine) and 1.01. I’ve been reading forum posts by people with the same drive fw 1.0 and noone mentioned a similar problem…

Don’t know what to think of… Does any of you guys here have an idea on this one?

Also if this thing doesn’t work out (and it probably wouldn’t) I’m going to change it, but a friend of mine here is persuading me not to take the same drive, cause it was “junk” (as he called it) and he is strongly reccomending me the Lite ON 6S160P. What’s your oppinion on this matter? I really don’t care much about LightScribe, though it’s a nice feature, and I would indeed use it, if only there were any LightScribe media available around here, which is not the case for now. The other difference I noted is the DVD-RAM capability of this drive, which is of absolutely no use to me.

Sorry for the long post, and my not so good english. I hope someone could help me on this.

P.S. I forgot to metion that I also tried to leave the drive alone on the IDE cable, no result here either.

Edit: I forgot to mention my system specs… It’s kind of an old PC
MB: Gigabyte GA-7VTXE+ (VIA KT266A chipset)
CPU: AMD Athlon XP 2000+ (Thoroughbred core)
RAM: 512 MB DDR 266Mhz CAS 2,5
PSU: Fortron (FSP Group) ATX-300PNF
… and the rest I think it’s not important for this matter.
As for drivers, I always use the latest available: mobo chipset drivers (IDE, AGP and stuff), video, sound… Everything is installed properly (except one old v.90 Motorola dial-up modem, but I seriously doubt that it has something to do with this, it’s been there for ages… and since I haven’t used it for more than 4 years now I never made the effort to look for XP drivers for it, since I was using it back with Windows 98.)

Thank Goodness for your post! I thought I was going crazy with my H22L. The damn thing burns like a witch on meth but it won’t read anything it burns or anything else i feed it. I switched controller positions, same problem. Cleaned it, same problem. Burn but won’t read. Made it Master, slave, cable select, same problem.

Finally, I got pissed, took the drive back to Best Buy and traded it in for the H10L unit. That’s the 16x burner and after installation, problem solved. I didn’t go thru the formatting and such because my machine was working fine before I installed the drive and if I have to go thru that much trouble, the drive goes back to the store period.

LG needs to look at this issue unless one of our esteemed subscribers can come up with a fix. I still have a H22L I’m keeping boxed just in case LG comes up with a firmware fix.

Well after you mentioned that your unit is capable of burning disks despite not being able to read them, I tried to burn one DVD-RW, but to no succes. Here’s what Nero reports.

Mmm, this “communication failure” doesn’t seem as a nice thing to me.

Edit: I’m going to sleep now. I’ve been messing with this darn thing all night. It’s 6:20 AM Sunday here, and I’m really pissed off. Be back online in 8 to 10 hours… goodnight :cool:

Well I looked up the pricelist of the the shop where I got my drive, and they seem to have the H10L in stock, so I probably will go for this one. I really wanted a NEC 4550A, but it’s nowhere to be found, only 4570A which as far as I understand isn’t even half as good as the 4550A.
It’s a shame really, this drive is everything that I need on paper, but…

What about the Optiarc 7173? It’s an excellent drive too.

I am sure you are joking.
I have had this drive for some time and everything I wrote was almost unplayable. 22L is a better drive.

I am not sure if this has anything to do with your specific issue, but just in case, then here goes…

The atapi.sys(v5.1.2600.2180) driver included in SP2 for Windows XP is found to be buggy on many systems, including mine, so you could try to see if this solves it :

Download KB842520, install it and reboot.
http://www.mdgx.com/files/XP842520.EXE

This will install atapi.sys v5.1.2600.2505, but this atapi.sys isn’t perfect either, and instead we need the atapi.sys v5.1.2600.1581, so after you have installed the KB842520 hotfix and rebooted, then copy the atapi.sys(v5.1.2600.1581) file from the ‘KB842520\SP1QFE’ folder to the following folders:

C:\windows\driver cache\i386
C:\windows\system32\dllcache
C:\windows\system32\drivers

Afterwards then reboot again.

Btw, the reason we couldn’t just overwrite the bad atapi.sys file with the good one, is because of XP’s ‘windows File Protection’ feature, since the new atapi.sys file isn’t digitally signed yet, untill after we have installed the hotfix, which registers two new atapi.sys versions(v5.1.2600.2505 + 5.1.2600.1581) into the system.

With my system, then right after i had reformated and reinstalled Windows XP Pro. SP2, then i suddently couldn’t read or burn any discs anymore, untill after i had applied this fix.

More info about this problem here :
http://erpman1.tripod.com/current/atapi-xp.html

Martin.

Well, problem is clear now, there’s some kind of problem between my DMA controller and this drive, disabling DMA for the H22L fixes the problem (drive runs in PIO)… But I don’t think I want a DVD burner in PIO mode…
So I’ll defenetely exchange it with something else.

NO, I have had the exactly same problem untill I changed the IDE cable.
Now runs great as it was desgined. And rips fast enough.
Give it a try.

My 7173 burn great everything i throw in the drive.

sverkalo, yeah you were right. I changed the IDE cable and everything is OK now. Although the old cable was also 80pin, but probably had some flaw which didn’t affect the CDRW that is also on that cable but runs in UDMA mode2…
To think I would’ve changed that great drive… Burns a Verbatim 4x DVD-RW for 12 minutes, nice (including the lead-out).

I should look for +R and +RW media, I understand it burns them much faster. I also want to find any LightScribe media, just want to try the feature :slight_smile:

Well, I don’t know what this tests show, but I see you guys here refer to them quite often. So here are a couple of screenshots.

Here’s a Movie DVD-ROM

Here’s a PRINCO 56x CD-R

SONY DVD-R 8x

TDK CD-R 52x

Verbatim CD-R 48x

Verbatim DVD-R 8x

Verbatim DVD-RW 4x

Yes I tried everything and this was the solution.
My cable was a very expensive one but it seems that it has to be changed.
It seems those new drives are very sensitive in terms of cables and media.
They need very good media otherwise they don’t like them.
But you know I like this attitude.

I just bought a new h22L . Unfortunately it is bulk. Do u guys have the retail one or do u own some software related to this unit (such as firmware update etc). LG support site doesn’t even list this unit

I have the retail LG H22L drive which came with some software to install Power DVD, Power Producer, Nero Express Lightscribe support, InCD, Adobe Acrobat reader. There is no firmware update yet for this drive.

so i guess no lg software such benq’s qsuite

There aren’t any special tools for tweaking the functions of the drive if that is what you mean. This model is also too new and there are no firmware updates for it yet. If you really want to, you can get LG’s firmware auto-update program from one of their service websites (e.g. http://ca.lgservice.com). It’s supposed to fetch new firmware updates for your drive when they arrive but I’m not sure how well it works. I used a much older version of the update tool which was quite buggy; by the time they released new versions to deal with the bugs, there were not more firmware updates for my drive.

yeah that is what am I looking for but the link ain’t workin’ . Thanks anyway

http://ca.lgservice.com/ Try it now…

thanks a lot
One question though. I see you have both Benq and LG . Which one would u chose to burn very important data?