LG GSA-5120D and DL recordings

After a lot of searching through the net and many wasted DL discs , it seems that the firmware of the GSA-5120D dvd recorder (A104) isn’t any good for DVD+R DL recordings…

I’ve tried to record VERBATIM DVD+R DL media (I’ve wasted 6 discs = 60 euro) with any possible way (dvd decrypter , nero, images, files , remove layer breaks etc etc etc ) and with all the discs that I’ve burned I experienced problems in various dvd players and roms……

So I e-mailed LG and their response was “Go to the shop you bought it from in order to check the drive”……

PPPPPPPPPPLeaaaaaaase……. There is nothing wrong with MY drive……but something wrong with THE model’s firmware…….

Is somebody experiencing the same prob? Should I update my drive with the new firmware of GSA-4120 (which is the same drive but internal and with the new firmware the DL problems are gone ) or this could destroy my drive?

Thank you all

Anybody?

Anybody who owns LG GSA-5120D???
Anybody who owns LG GSA-5120D and burned DL with it???

Hi… I ve bought the same LG 5120
same the your problems… By InstantCopy cd/dvd with last version NOTHING :frowning: with CLONEDVD2 NOTING :frowning: :frowning: :frowning:

We ve problem with the firmware perhaps ? ? ? But I tried one afert A104 but nothing :frowning:

You have any idea ???

See Ya
Wassy

I posted the problem here http://forum.rpc1.org/viewtopic.php?t=30722 and the Dangerous Brothers took the A112 firmware from 4120 and made it for 5120.

So upgrading the drive (like i did) with the firmware found here http://forum.rpc1.org/dl_file.php?site=tdb1&file=5120A112.ZIP you shouldn’t have any problem (i haven’t tried to burn DL cause i ran out of discs.)

BTW i bought a nec 3500 and the my last 3 DL’s can play EVERYWHERE!!!

Too Bad… I upgrading the drive… with firmware A112… But Nothing Nothing My Panasonic don t read the dvd… I ve used CLONE DVD2 last version by DL option but NOTTTTTHING… why don t work now ??? :frowning: :frowning: :frowning:

Now i don t know… Sell all ??? Ahhh… i try to search… anyway still to burn only DVD 8.5… TOOoOOOOoooo Baddd… i ve burned 8 DVD… no happy time 4 me… :frowning: :frowning: :frowning:
See ya

  1. Download Dvd decrypter from www.dvddecrypter.com
  2. Rip the movie in ISO - READ mode
  3. Burn the ISO-MDS with dvd decrypter in ISO - WRITE mode

Now you have a perfect clone of the original (forget about dvdclone, shrink etc etc)

Just use dvd decrypter… easy … fast and compatible !!!

wow… more late… i ll try…
Thanx u :iagree: :iagree: :iagree:

:bigsmile: :bigsmile: :bigsmile: :eek:

Hey Brother too cool… gh gh gh LoL

wow my 1st Dvd Movie Troy by standalone… All Good…
Well… now i must learn to use Dvd decrypter over the top… eh eh eh…
Well well well :bow:
See ya
Wassy :stuck_out_tongue: :smiley:

Did you use dvddecrypter to rip and burn the iso and everything went ok?

:iagree: Now Only i ve burned a *.pdi “instantcopy File” TroyMovie LoL :bigsmile:

i ll try to rip soon soon…
Good Week End ! ! ! :cool: