LG GSA-4167B disc tray won't open

vbimport

#1

Hey guys, I’m new to the forum here and I’m pretty sure that this isn’t the place to ask this question, but this is a big problem and I haven’t found anything on the net. Anyway, I just installed this drive into my computer, hooking it up on it’s own IDE cable and sending that to the secondary IDE port on the motherboard. So I turn on the power to the comp, everything runs fine, and then I try to open the disc tray. The LED on the DVD drive flashes a decent amount of times, then the disc tray doesn’t open. I’ve tried fooling around with all the jumper settings, changing the IDE cable to the slave port, so on and so forth, and yet the tray still won’t open. Even when trying the manual eject with a paper clip I can’t get the tray out…anyway, andybody got any advice for me? Thanks in advance.

Skipee


#2

RMA the drive, its faulty


#3

Yup, I agree with Puma.

PumaUK : btw, greetings and welcome! :slight_smile:


#4

Had the same problem some time ago, disconnected the power and ide cable from the drive, started the computer, then turned of the computer and reconnected the drive … it has worked since … funny issue.


#5

I can explain this one : it’s a loose or ill fitting power cable. When you disconnected and re-plugged the power cable in, it fixed it.

I’ve had something similar to this happen with a DVD-ROM drive. It turns out the metal ring contacts which were part of the female power connector were loose. A quick crimping with a pair of pliers did the trick.

Good suggestion, btw. This might be something the original poster might want to check too :slight_smile:


#6

its worth a try for him, but with him able to power the drive up, i still feel its a hardware failure issue, who knows
:slight_smile:


#7

Thanx for clearing that up Karangguni :slight_smile:


#8

Hi! I have the same problem that Skipee has/had …
same burner, same led turning on, same disc tray won’t open…

so, witch solution did you come with? was it the power suggestions? or I have to go to the computer shop and change it…?

thanks!!!
sorry my english :wink:


#9

Hi and Welcome!

if the things suggested here (dis- and reconnecting the drive, checking cables and jumper settings) do not help, then it’s time to return the drive to the vendor.

Michael


#10

or try on another pc


#11

The first thing I would try is to turn off the system and use the manual release with a paper clip. If you can get the drive tray open that way (Skipee couldn’t), start the system (yes, with the tray open). It should shut the tray on its own during bootup. After that try the eject button and see if it now works.

If you can’t even get the tray open with the paper clip method, the drive needs to be RMAd.