LG GSA-4120B 102-115 Firmware Failed

vbimport

#1

Hi all,

NooB here directed from ABX Labs… greets!

Anyways, I tried to flash an LG GSA-4120B 102 to the 115 firmware from LG’s website… and it failed during flash :frowning: :sad: !

I rebooted, and now the drive bay won’t open, and won’t read anything (if I force open the bay, and stick a CD in). However it still detects in BIOS and Windows XP… but flash utility shows current firmware as COR1…

Is there any way I can make it back to working status?

Thanks all!


#2

Welcome :slight_smile:
The drive is in save mode. Try to flash it again.


#3

Did try to for firmware versions 102, 104, 111, 115… but it hangs (light keeps blinking, or doesn’t blink at all while flash utility does nothing)… or gives a weird 70 ** ** 00 00 00 ** ** (asterisks are numbers i don’t recall) error if it actually doesn’t hang.

Thanks for the welcome ala42!

Cheers M8s


#4

Which IDE driver do you use ? How is the drive connected ? Any other drives on the same bus ?


#5

I am using the intel inf driver (i845), with intel Application Accelerator.

Drive is Master, on Sec. IDE channel.


#6

Roll back to standard microsoft IDE drives. Instructions are here.


#7

Did that… no luck though…

I tried flashing 102, 104, 111, 115… no help… all couldn’t properly complete.

Error Code 00 00 00 00 00 … (all “00”)

The drive detects, but still won’t flash…


#8

Connect it to another PC


#9

Try disabling DMA as well, I have had 4120B’s that would not flash with DMA enabled.


#10

Uhhh… connecting to another PC doesn’t do anything… I’ve already tried two of them…

anyways, I’ll try it without DMA and get back with the results…


#11

Try MTK Winflash in IDE mode.


#12

LG DVD burner do not use MediaTek chipsets, so MTK tools do not work in this case.
NEVER use MTK Winflash on any DVD burner, not even on drives using MTK chipsets. MTK Winflash only supports CDRom drives. DVD drives will be dead after flashing.


#13

Thanks ala42 for the save from MTK Winflash… I was thinking about that earlier, but was sure there was something that wasn’t right about it…

Disabled DMA… tried again in PIO Mode 4… still doesn’t want to flash. Same 00… 00 error. The light blinks during flash and continues to blink even after it says it failed, at which point the drive doesn’t show up in “My Computer” and I need to force a restart/shutdown in order for Windows to see it again.


#14

After my insistant flash utility running A102 to the drive, it finally decided to replace the COR1 status.

I tried reading discs with the A102, but it wouldn’t…
I then upgraded to A104… still same problem.

Thanks for the help so far though… slowly reviving this drive :clap: !

Should I re-enable DMA, and re-install Intel drivers? or is that not necessary?


#15

So your drive displays the correct drive name now ?
Enable DMA again, do not use the Intel IAA, but I doubt this will fix your reading problem.
How was the status of your drive before your first flash ? Did it already had the reading problems then ?
Btw, MTK winflash will probably only set DVD drives with MTK chipsets out of order, which can be fixed with the DOS mtkflash.


#16

It’s the correct name now… at version A116 (I tried 102,104,111,115,116)…

Cannot read from any discs though… before the corruption, the drive was perfectly fine.


#17

Went back to A115 (since that is the latest North America firmware for 4120B) , and changed Region Code to 1.

Still not reading :frowning:


#18

BUMP? I’m probably going to give away my current working 4120B for now… :(… and wait to see if there’s a way to (still!) fix this one.

Thanks!