LG GSA-2164D - Firmware?

Hi Guys, sorry if this has already been asked but I recently purchased the external usb gsa-2164d drive and everytime that I run the autofirmware update (ODD) or something I get a runtime error 7.

I just wanted to know:

  1. Is there a firmware update available for the said model
  2. Anyone else experiencing problems when recording an ISO Image where watching the playback of the recorded image the playback pauses 3 times in one spot and then moves on by skipping the chapter.

Also I did contact LG Support (or the lack thereof) they told me to uninstall the software and re-install which I did but it made no difference.

Anyone able to help? :slight_smile:

Alot of people have problems using the “auto update” route. You are best to download the firmware file itself from lge.com. (The software section seems to be down at the moment though!)

thanks, tried LG numerous times and either i’m completely stupid :stuck_out_tongue: or there’s no GSA-2164D driver / software to download. :slight_smile:

Ummm, see what you mean! I could not find anything for the a 2164D drive either. Maybe someone else could suggest on this?

it is really strange, it took me ages to go through all their products on their site and found a micro site for Optical drives but in fact it only has the GSA-2166D and even then it doesn’t have any info on firmware drivers even with a section dedicated to downloads (there’s no link on the firmware section).

If I had known this was the case with this particular drive I wouldn’t have bothered. It’s such a pity and all of this just to update the firmware.

Thanks for your help in anycase. :wink:

There is NO firmware for this drive yet.

thanks Chef…glad to know that at least.

I too have bought (at Christmas) the LG GSA 2164 and the update software also reports error 7 - out of memory.

I got the same reply (to reinstall the software) and it made no difference. I have reported this to LG again but have not had a reply (two weeks).

If they know that there is not a firmware update available yet, why don’t they just say so and how will we get to know when one is available?

how many of you are running xp service pack 2 (sp2) because you may find this interesting I recently reformated my machine with xp sp 1 and odd auto update ran fine and was updating when I installed sp2 I was getting the error 7 code and It wont run this leads me to believe that it is a xp sp2 confilct with the program. and thoughs. and by the way hi to you all from oz

Dear Fellow LG users,

What a merry-go-round this firmware business appears to be…

I just brought one of these LG-2164D drives which boasted X16 for DVD+/-R and a DVD-RAM increase with a firmware update…

Well guess what it only does DVD-R at 4X which is not what it says on the box…

Installed the auto-update program which claims there is no updates availible…

Eventully tracked down a firmware update to version 1.01 on the LG website…However it says its for people who are using Firmware below 1.0 and does not claim to fix the speed issue…

Is anyone else having this problem…Is the 1.01 update okay for a 1.0 drive and if so wil it fix the speed problems…

or is my drive faulty and should take it back…(It does clearly say 16X for DVD-R not 4X - have not tested DVD-RAM and DVD+R worked at 16X as stated)

Yours in confusion

Damon

Hello Damon and welcome to the forum.

Your problem sounds like the media you are using is not supported by the firmware of your drive. When this happens, your writer uses a default write strategy, which writes at only 4x.

The silly thing about this is that the auto-update program is buggy. On certain systems, it just won’t find any updated firmware. On others, it crashes witha cryptic error message. If you really want to use it, go to one of LG’s service websites and get the updated version, which should be better : http://ca.lgservice.com (click on Device Driver->DVD-ROM(Writer)) and search for the auto update program. It should be fairly near the top of the list.

However, for now , just go with the firmware file you downloaded and use that first.

That message is caused by a mis-translation from Korean. Apparently the words for “below 1.0” and “1.0 and below” are the same. This idiotic message appears on almost every LG firmware update and has been confusing people for years. If the firmware update matches your writer model, go ahead and use it.

If the new firmware adds support for the media you bought, then it will burn those discs at 16x after the flash. This is something that firmware releases never mention. They assume you already know.

Thanks for your help and advice…I will try it and let you know what happens…

Cheers

PLEASE I HAD APROBLEM WITH A BUNER LG GSA-2164D IT DOES NOT READ ANY CD. PLEASE HELP ME

Please If Any Body Can Help Me With Settings Of Lg Gsa-2164d 101. When I Insert A Cd It Does Not Read It, But When I Query The Device It Responds Positively, And When I Eject It It Ejects It Self But It Does Not Read Any Format. I Thaught It Was A Problem Of Software And I Went To The Lge.com But I Fund Only The Update Driver Only Is It Poossible To Find The Software???

It seems LG GSA-2164D has firmware problem ? .
My GSA-2164D suddenly can not read any [B]original[/B] DVD movie but it can read any burnt, copied DVD and burn movie on blank DVD. I do not think it’s firmware problem because it worked before that.
Any idea, suggestion or help is appreciated.
TIA.

The drive doesn’t need a driver - drivers come with the OS!
Please contact LG about this problem, t sounds like a damage which cannot be solved with a firmware update…