LG GH22LP20 wont burn dvds past 1.5x

I just bought it from newegg and have burned 3 perfect disc, 2 dvds and 1 cd-r the problem is with the dvds it wont got past 1.5x and i have the write speed to 8x the cd however burned at 16x fine what could be the problem?

A bad ide cable or the drive is in Pio-Mode, you can run a simple test with nero cd/dvd speed, insert a dvd (not empty) and run the brust rate test, and post the result.

3MB/s elapsed time 2sec

[09:48:14] Drive: HL-DT-STDVD-RAM GH22LP20 1.03
[09:49:09] Disc: DVD+R, 3.85 GB, MCC 004
[09:49:31] Starting burst rate test
[09:49:33] Interface burst rate: 3 MB/sec (3206 KB/sec)
[09:49:33] Elapsed Time: 0:02

1.you can change the setting in the device manager in IDE/ATA controlers
2.check your ide cables

primary and secondary are both using dma if available

the last thing that i can say is try to unistall every software that add virtual cd/dvd drives, sometimes they cause more problems, and as i said you can try another ide cable.

Adapter 1

Description : Primary IDE Channel

Driver
Description : System32\DRIVERS\atapi.sys
Company : Microsoft Corporation
Version : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
Description : IDE/ATAPI Port Driver

Attached Devices
Description : Master: SAMSUNG CD-ROM SC-148A
Type : CD-Rom Drive
DMA : On
Autorun : On
Description : Slave: HL-DT-ST DVD-RAM GH22LP20
Type : CD-Rom Drive
DMA : Off
Autorun : On

Adapter 2

Description : Secondary IDE Channel

Driver
Description : System32\DRIVERS\atapi.sys
Company : Microsoft Corporation
Version : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)
Description : IDE/ATAPI Port Driver

Attached Devices
Description : Master: ST3120026AS
Type : Disk Drive
DMA : On

Software Information

Operating System : Windows XP Home Edition (5.01.2600 Service Pack 2)
ASPI : Win32 Nero Aspi Library 2.0.1.59 Ahead Software AG

Description : Nero Burning ROM
Version : 6, 0, 0, 19
Company : Ahead Software AG
Version Check : Ok

problem is that i dont know how to go inside and do that stuff my dad had to pay $35 for some guy to put it in. can someone give me a tutorial or something?

and im pretty sure the guy put a new 1 in i still have the old 1 though

Read this on how to check DMA

Description : Slave: HL-DT-ST DVD-RAM GH22LP20
Type : CD-Rom Drive
[B]DMA : Off[/B]

how do i post a image i used print screen but dont know how to post it but its set to dma if available in both ide channels however in the secondary ide channel transfer mode is set to pio mode on DEVICE 1 NOT 0 0 is set to ultra dma mode 2

See this post

it says image must be 760x0 but it wont let me edit it to that size

heres the pic


You can unistall that ide drive, reboot, and them windows will see a new hardware, and probably it will be in udma mode/

how do i do that?

I dont remember how it’s done in windows XP but if you right click in secondary IDE controller you should have the option tou unistall, after that you need to reboot the pc so that in the next start windows will see and install the new controller, and hopefully it should be in DMA.

now the secondary ide is PIO only and pio mode