LG CRD-8480C dead drive -Need HELP

Hi guys. I have worked on this problem for about 12 - 15 hours now and need help. I know it’s only a 20 dollar drive but it’s also a good learning process …right :slight_smile:

I killed my LG CRD-8480C drive with Linux Mandrake 9.2.

To fix this I have tried the firmware programs from the LG site: us.lgservice.com (Product Support, Device Driver, CD-ROM, CRD-8480C) …but that needs to SEE the drive and my bios does not see my drive at the moment. I also tried the Dead.gif directions that they give for putting your jumper sideways on the Master/Slave, but that does not work either. It does make the light come on though when I use that sideways jumper and eject button as I apply power to the drive.

So anyway. I tried the LG firmware update and I tried the DELL firmware update (my drive is in my DELL computer). Neither worked because they need to SEE the drive on the bios and my bios is NOT picking the drive up at the moment.

I downloaded MTKFLASH 1.80.1 but that does not work either …is there something else I should use for my drive?

I have only tried MTKFLASH with the 2 firmwares that I got from the LG and DELL sites, I can NOT find the CRD-8480C binary anywhere… if someone has the binary for the CRD-8480C could you please send it to me? The link here on CDFREAKS is broken for it.

Anyway, in reading your forum it sounds like MTKFLASH may not be compatible with the 2 firmwares that I have (V3D48105.LGE & V3PLGX48.LGE) so maybe I need the real BINARY for it to work.

If that does not work, what other flash program do you recommend? Anyone have this exact drive that they could help me out? I would greatly appreciate it!

Thanks,
-Chris

i’m in the same exact situation as the topic author; and i dont want to see this old drive die to such a foolish problem.

the firmware is killed by mandrake, and no tools ive found can apply the new firmware without the drive being recognized in bios. please help us!

if anyone anywhere can help us its here.

I’m in the same situation, but with CRD-8482B CDROM drive.

Hy,
I’ve seen your post at Club CD freaks, cdfreaks.com forum that is, about a CRD-8480C dead drive from a mandrake 9.x install.

Alltho’ it’s an old post, i hope u still have the unit, and want to “CPR” it :slight_smile:
here’s my assistance:

following the guide from LG (lg support page-> CDROM units -> MandrakeFirmware download) u

have to put the drive with upper Master - Slave pins connected by a jumper.
In a proper working enviroment make a DOS boot floppy. (i’m using w2003 server, so format -> Create a MS-DOS startup disk)

Copy the LGUP.bat, V3PLGX48.LGE, XFERLG.EXE files from the downloaded and extracted zip archive (MandrakeFirmware.zip from LG support)
my floppy dir listing looks like this:

A:>dir /b
EGA2.CPI
EGA3.CPI
EGA.CPI


KEYBOARD.SYS
KEYBRD2.SYS
KEYBRD3.SYS
KEYBRD4.SYS
MODE.COM
COMMAND.COM
DISPLAY.SYS
AUTOEXEC.BAT
CONFIG.SYS
LGUP.bat
V3PLGX48.LGE
XFERLG.EXE

Attach the drive to the computer only by data cable.
HERE IS THE TRICKY PART:::::::::!!!
attach it ONLY AND ONLY to SECONDARY IDE. PRIMARY IDE didn’t work for me using several

mainboards (Epox, Asus, Matsonic [crap])

Remove any other unit (disconnect - hdd, other cdrom/rw drives)

Power up, enter BIOS settings and put Primary/Secondary Master/Slave (all 4) into AUTO mode.
Put Floppy as the first item in boot sequence.

save bios settings, the pc will soft-reboot, and sequently enter MS-DOS booting sequence from floppy. Autoexec.bat/Config.sys SHUOULD NOT contain any MSCDEX loading commands.

Ok so u’re now in a DOS enviroment, no power to the drive, BIOS doesn’t see it attached.
Push the EJECT button keep it pushed and attach power cables to the cdrom. The led should blink firmly for some miliseconds to 1 second and after that should stay up lit.
Release the eject button.

NO BLINKING after. if it blinks restart the procedure. (e.g shutdown pc/power-up/ms dos boot/keep pushed the eject while attaching the power connector)

u should be into A:> enviroment. type LGUP , the flashing sequence should begin. after re-flashing, XFERLG.EXE exits all by itself throwing u into A:> again. Flashing duration: 3 seconds to 5 seconds.

powerdown the pc. move the jumper to it’s wanted to be position. (master/slave). power-up the drive should be functioning normally. (e.g. BIOS detects it, it can boot a bootable cd… )

the caveats:

  • SECONDARY IDE only. Primary won’t work.
  • floppy should be bad-blocks free. (e.g. new one/or checked for errors/bblocks)
  • AUTO into BIOS settings.

All this was done finally, after several atempts,
(XFERLG.EXE -screaming that it can’t find an cd-rom unit - because it wasn’t connected as Secondary IDE)(Bad-Blocks floppy disk)(Matsonic ms8380EP crap mainboard even with BIOS update could not hot-detect the “reseting in process - eject button kept pushed while powering the cdrom” drive),

on a Epox 8k9AI. the rest doens’t matter. (ah, with all extension boards on-board - forgot that to mention - vga/modem/2 network cards - so no prob from this)

NightInTheCity