LG BH16NS55 won't play Blu-Ray Discs after upgrading to 1.03 firmware!


#1

Hi guys!
I updated my LG 16NS55 to firmware 1.03 After that the drive refuses to playback any commercial Blu-Ray disc! I suspect the problem is that it can not by-pass their protection since when I enable AnyDVD it plays them back with no problem. Also I used one backup copy of a BD-R I own and it was playable. So I think that I am stuck and can not watch new and old Blu-Ray titles since my AnyDVD is Slysoft version (not RedFox) which excludes all the new releases and more! Am I stuck? Is anyone else facing the same problem? Any thoughts would be more than welcome!
PS. As far as I know I can’t, officially, downgrade the firmware back to 1.02, so are there are any solutions you might know or my drive is somehow useless? Many thanks in advance!


#2

Google is a good friend and you can always downgrade your BH16NS55 to 1.02 and restore the UHD Friendly reading capabilities.


#3

Thanks TwinParadox for your help. I don’t want really to downgrade my driver back to 1.02 since I am not that interested in UHD Blu-Ray discs at the moment. I am just trying to see if there’s a way to solve my problem without having to downgrade. Thanks!


#4

You will never solve your problem without downgrading. 1.03 fw avoid UHD discs to be read. That’s all.


#5

Bit confused, do you mean you formerly could decrypt them using AnyDVD but can’t now? Or that it can’t decrypt only newer titles?

Not sure about that version of the firmware other than I know it disabled UHD support, but since you only insert regular Blu-Ray discs perhaps you inserted a newer release and the disc wrote to the drive a newer version of the certificate revocation list?

It’s my limited understanding that when that revocation list is written to the drive that unless the software used to decrypt has updated certificates it renders the software incapable of bypassing the decryption.

As a test you could try the latest version of MakeMKV instead and see if it decrypts the disc.


#6

Yes I understand, but now my drive refuses to play any Blu-Ray disc I throw in, UHD or not, it doesn’t matter, it doesn’t paly them as long as they are commercial.


#7

A good reason to downgrade your unit. I’m still wondering the need to update it to 1.03.


#8

Hi Pans,
When the drive was carrying f/w 1.02 I could playback any commercial Blu-Ray disc. Haven’t tried UHD discs. After upgrading to f/w 1.03 the drive stopped playing back the commercial Blu-Ray discs (and I am not talking about the UHD ones). I tried uninstalling and installing again the drive but with no luck! Then I tried to enable my old version of AnyDVD HD, version 7.6.9.5. (Slysoft version, not the RedFox one). Then I placed an old commercial Blu-Ray disc (Transformers), and suddenly I was able to watch it on my computer! Turning off the AnyDVD and the playback is gone, couldn’t watch it anymore. So it has to do with the protection they carry by default and that the stupid 1.03 f/w prohibits then to play back!
I also tried to playback the commercial Blu-ray of “Geostorm” with no luck since I got the message on VSO player that the disc carries protection and I need to decrypt it in order to watch it!!! I repeat Watch It and not ripping it! Unfortunately my old version of AnyDVD does not decrypt it. So I am stuck and trying to find a solution since I am not that expert to try to downgrade it to f/w 1.02 with the methods available on the web. The other thing that worries me is that there’s no one else facing such a problem from what it seems!


#9

What was the software you used to play the Blu-Rays prior to this?

As it sounds like potentially a certificate revocation list was hard written to the drive’s internal memory either by a new(er) disc you inserted or perhaps even the firmware update itself which is causing the playback software you once used (for example, PowerDVD, which requires its own decryption certificate) to fail to work, since the drive with its newly updated certificate revocation blacklist is telling it to ignore such old certs. These certs are periodically ‘retired’ by design in an attempt to curb ripping from what I gather.

Someone more knowledgeable can clarify if I’m getting any details incorrect here or if there’s another potential reason. That’s just my hunch.

If this is indeed the reason the practical solution would be to either update the playback software so it can obtain a newer AACS certificate or use one of the standalone decryption programs to decrypt the discs for playback.


#10

Can anyone please supply me with a link so I can download the 1.02 f/w?


#11

I was using Media Player Classic and rarely VSO player. I think it’s the firmware to blame. I downloaded DVDFab’s player and I am getting the same results. No playback! Anyway thanks for your time Pans!


#13

The drive’s host certificate may have been revoked as noted by Pans. AnyDVD uses its own certificate hence why things might work when AnyDVD is running. Pans’ idea to test using MakeMKV is a good idea.

Sidenote: AnyDVD required an update in January 2018 due to a host certificate revocation, as well.


#14

Thank you all for your kind help. I decided to make a back-up copy of a Blu-ray disc that I own. I did so and then tried to play it back. No problem. Then I inserted the same, original, commercial disc to see what happens…and all of a sudden DVDFab player started the playback without any problem!! I tried VSO player with no luck and the same happened with Media Player Classic which could not render the files. I tried other commercial Blu-ray discs that I have and only DVDFab Player 5 could play them back with no problem. So for the time being I think I am covered. I don’t know what’s wrong with my drive but as long as I can play the movies with DVDFab player I am Okay. Hopefully this problematic firmware upgrade didn’t affect the recording and reading capabilities which were very good.!

Capture

Capture2


#15

It is the firmware if this happened right after the update, and it was working before. I am afraid you might have to go back to 1.02. See if it works, then try your upgrade again if you must. EDIT:
You sound as if you have it working. Thats great news. Come back if you have any issues.


#16

MPC-HC can’t play protected BD, you need AnyDVD running for using the proggie to play your original discs