LG BH16NS40 (SVC Code: NS40) - Not Reading Discs After Flash


#1

Hi

I have an LG BH16NS40 (Service Code NS40 according to the label) which I was hoping to flash to be able to read UHD discs as it didn’t out of the box. It had version 1.03 originally. I can’t be 100% sure but after I flashed it with a firmware I thought would give it the UHD capability, I seem to have flashed it as the SVC NS50 version instead. As a result, the drive will eject and close but that’s about it. Windows reports the drive to be working but it doesn’t spin up when I put a disc in the drive.

I have tried reflashing as NS40 but when I try, I am advised that there is a checksum mismatch. I’m normally fairly tech savvy but it seems I’ve managed to utterly fail at getting this fixed and I’m not that sure what I can do to fix this. Can anyone offer a suggestion where I can start?

Thanks!


#2

I am not sure how you managed to flash a NS40 drive with a NS50 firmware. Each time I tried that I would get a checksum mismatch error and the update would fail. Did you use the firmware update tool from LG or a modified firmware installer? I did find this link where someone seems to have done the same thing. Here is the link to the conversation. https://www.makemkv.com/forum/viewtopic.php?t=18933&start=15#p71264 Perhaps this will help you out.


#3

Yeah, I used what appeared to be a modified version of the LG flash software and the first time it worked it somehow flashed my drive as an incompatible model and I can’t get it back to the state it was. Sadly that forum post refers to the WH16NS40 rather than the BH16NS40 which I have.

I’ve pretty much considered the drive as bricked now and have ordered a BH16NS55 to replace it with. I understand you can flash those to be UHD compatible but after my experience, I may just leave it as it is!

Many thanks for your reply however!


#4

Always the same situation. People wont read what has been written x times already!!

Your drive got “professionally” wrecked.