LG BH16NS40 Crossflashed now its Dead

vbimport

#21

According to second screen it detects an ATAPI device. You have to press 0 and then select the firmware file (copy over usb of course) you want to write on your LG drive.


#22

Hi,
happy new year 2018 for you.
on the second screen is the Problem after i press 0 he says Unknown Flash chip like on the second Picture.
It is under DOSFLASH 2.0 a newer version.
Picture one is dosflash from you i downloaded.
Sata Pri and sec none.
I dont know why because i have 4 sata devices on the computer 2ssd 1hdd and 1optical blu ray.
But the BluRay dont work at the moment.


#23

Try to use the version I linked to you. And try to power on the device when you’re in the command prompt.
Type dosflash several times if it does not recognize your device on first try. DOSFLASH 2.0 see your device but it doesn’t know which eeprom is (that’s the reason it says flash chip 0 bytes big size).


#24

Hi,
okay it worked i habe now BH16NS40 and i can flash with the Patched Flasher.
But now i have a New Problem.
My Device read no CD/DVD/BluRay.
I have no idea why.Its now the Original FW Version and he dont read nothing.
Do you have an idea why?
Thx for Helping me and a Happy new year 2018


#25

Did you try a backup firmare of your device ? Some firmwares don’t properly work due to different laser calibrations.


#26

Hi,
no i used a original firmware i downloaded from the internet.
I dont have a backup firmware.


#27

Maybe you should try different crossflash firmwares to find out the one fully working for your device.


#28

Ok i tried alot Firmwares,
but nothing will work.
All what the device do is the led is blinking 2x more not.
He dont start reading or something only the blue led 2x then nothing.


#29

I think you’ve now a NS50 firmware on a device which is NS40 and that could be the reason it can’t read anything.

Try, under DOSFLASH modded version (the one I gave you), one of the following firmwares.

https://drive.google.com/file/d/1swXcbHb3Yoz9uoQAzPuH0n-AjqLluDI-/view?usp=sharing

Let me know if now it reads again.


#30

Hi,
ok i did it again with your DOSFLASH and your Firmware file.
I Erased the Flash and Wrote it with the 103.BIN file new again.
But still the Problem, that he dont read nothing.
I show you some pictures from the Process in DOSFLASH.
After i Erased the Flash he shom me still BH16NS55???
Here the Fotos:


#31

Yes It is normal It detects as BH16NS55 because the eeprom has been defined in that way in the dosflash.typ file.

Anyway if you already tried any NS40 firmware on your device and it still does not read anything maybe your drive has laser issues and you can’t do anything to take it back to its previous state.


#32

Hi,
okay i have now the Original firmware on the Drive.
I dont understand why he cant read anything.
ALl he did is 2 time blinking LED thats all.
Not turning the disc or try tu start turning only the LED.

Edit: If someone has any idea or an own Firmware Backup or something like that that would be great.
I hope someone has something to help me.
Thanks alot to all of you.


#33

A Friend has the same drive,
is it Possible that we take his Firmware and flash my drive with his firmware?


#34

I’ve found the way for fixing your drive. Tell to your friend to dump his firmware with devilscraw flasher.

You need Devilscraw flasher, which can be found here :

Then, open an elevated command prompt and type :

flasher -D (to display drive and drive ID)

and then

flasher -d [drive id] -l firmware.bin 6 00000000 00200000

and it should dump the current firmware of your friend device.

Then zip it and send it to me (on google drive for example) and I’ll fix it for you.

EDIT:
In the meantime you can try this BH16NS40 on which I’ve added specific calibration data:

https://drive.google.com/file/d/1ELcKWKoUf5i_iaZeVs848jo3OfblOpiv/view?usp=sharing

If it does not work, then you need a dump from your friend.


#35

Hi TwinParadox,
thank you for your help really.
The FIle you added dont work by my device, still the same.
Ok i hope the devilsflasher works on WIndows10 x64.
Then i will try to make a dump by my Friend.


#36

Could you tell me if you’re trying via dosflash or Windows ?

The file I attached you must be flashed only via Dosflash.

Anyway, The dump of your friend can’t be flashed via dosflash, as it need a proper header (which the devilclaw’s flasher can’t write).
If you would flash the dump as it is your device will be dead even in the tray eject and led, so when you will get your friend dump, please send it to me and I’ll add the correct header for flashing.


#37

Hi Twin,
ok i have a 2 MB file from his dump.
We did it 5 minutes ago over teamviewer :slight_smile:

here is the Link for you:
https://drive.google.com/open?id=1NclC7y4wJ4Ya23UbTJ23d3jr6YE96iaZ


#38

Here we go: :wink:

https://drive.google.com/file/d/1zrqpeAleJhTFxyZeylpYDWdqVZKQtq3d/view?usp=sharing

Flash it via DOSFLASH. Now you’ll be able to read again and your drive will be a perfect clone of your friend one.


#39

Hey TwinParadox,
it works my Drive is now Working Fine.
I thank you so much for your Great support i dont know how to Thank you.
You are the Best!!!
Really if i can help you with something let me know.
Greeting and Thanks from Germany.


#40

Glad to hear that. Enjoy your reborn LG. :smiley: