LG 4167B Lagging my PC

hey guys, i recently bought a 2nd LG 4167B and ive noticed whenever i try to copy anything off it from cd to hdd, it lags my system. the same when burning, the same when it is used with anything. its really really annoying. faulty from manufacturer or do others have this problem as well…?

Dale Majid

ohh and pc specs r as follows

PC Specs:
Mobo: ASUS P4S800 Socket 478 800Mhz FSB
CPU: Intel Pentium 4 Prescott 3.00GHz HT enabled
PSU: JSP Sprite 500W
RAM: TwinMOS DDR-400 1GB Dual-Channel
GFX Card: ASUS 6600GT AGP 550MHz Core 1GHz Memory [OC]
Coolers: [1] Zalman LED CPU Fan & Copper Heatsink, [2] Zalman LED GPU Fan & Copper Heatsink
HDD: 1x80GB Seagate IDE, 1x200GB Seagate IDE
Burners: 2x LG 4167B DVD RAM 16x Dual-Layer Support
Monitor: Samsung 913V 19" LCD Monitor 12ms
SFX Card: Creative Sound Blaster Live! 24-Bit
Peripherals: Logitech G-15 Gaming Keyboard, Logitech G5 Gaming Mouse, Logitech X-530 5.1 Speakers
OS: Windows XP SP2 32-Bit

Check the result of the Nero CD-DVD Speed burst transfer test, you need a disk with some data in the drive to run the test. It should display above 23 MB/sec. In your case the value will be alot lower, because DMA is obviously off.
Check the DMA settings of your source and target drive.

thanx for the help ala42, but as you can see it says it is on DMA if available, has this got something to do with the IDE Channels ive put it on, cause at the momment its on Secondary Slave and my 4163B is on Secondary Master. should i change them to Primary Master and Primary Slave and put both my HDD on the Secondary channel…?

here’s a screenshot

ohh and like i said, the trouble drive (4167B) is on Secondary Slave (Device 1) on the pic


Follow these steps.

ok, i will try right now, ill get back on how that goes

ok, i just did it, it installed the secondary ide channel again, and when i checked it, it made Device 1 (probelm 4167B drive) go in PIO Mode, So i changed it to DMA If available… but its still saying that my current transfer mode is in PIO mode… will this change take effect after a restart or something…?

i have no idea if this has fixed my problem or not, but ala42 youve been a great help, any more is much much appreciated

The current transfer mode has to be UDMA2 or higher. If it stays on PIO you could switch master/slave, replace the cable or switch the drives position on the cable (first/second connector).

Suggest you reboot and check if Device 1 is still DMA or if it has changed back to PIO. Sometimes it goes back to PIO after a reboot, so it is worth checking just to be sure.

k ima check, then ill write back

ok, its still stuck in PIO Mode for transfer. should i switch my channels, put my HDD’s on the Secondary IDE Channel and make the DVD Drives Primary. would that help put the 4167B on Ultra DMA Mode 2. and if i do change the channels, wouldnt that make one of my hard drives be in PIO Mode cause atm both of the HDD’s are cranking in Ultra DMA mode 5

Start with disconnecting the 4163 for a test.

what u mean, disconnect the 4163B and swap it with the 4167B…?

Just disconnect it from the IDE cable, without changing anything else.

ok, can i do it without turning off the PC. lol, i hate turning my pc on and off and shit, but ill do it, then get back to ya

ok, ive disconnected the 4163B

and this is what Device Manager is saying


ok, this is what i have pulled from DVD Region + CSS Free

its got something to do with DMA

heres the screeny


help anyone…? ala42…?

ohh and BTW, i just burned Bad Santa on Dual Layer disc on my 4163B, i love CloneDVD and DVD Region + CSS Free. a perfect 1:1 copy. w00t w00t, im definately going to the shops to buy more!

yer any help…? or is it bedtime over there in Germany and America. cause its 1.15PM GMT +10 in Australia

Multi-word DMA is not right. Two things you can check :

  1. BIOS. Go into your BIOS settings and see if there is some option there that enables DMA settings. Can’t quite give you detailed instructions here because every motherboard has a slightly different BIOS system.

  2. Jumpering on the drives. Make sure they are jumpered as master/slave NOT cable select. Someone in this forum had DMA problems when his drive was set to cable select. After changing it, the problems vanished.

If that still fails to get the drives to register as UDMA2, then you might want to look at this :
http://www.michna.com/kb/WxDMA.htm

the 4163B is set to MAster on the Secondary IDE Channel and the 4167B is set to Slave on the Secondary IDE Channel. so thats the jumpers, neither are on Cable Select.

ill have a lookat my BIOS settings.

i still think that DVD Region Free + CSS Free has something to do with this. cause it always says the DMA is NOT enabled!

have a look


ok i enabled DMA mode on DVD Region Free+ CSS Free and after a restart it still told me that DMA is not enabled!

i went into the BIOS and went to booting priorities and changed the Secondary Slave to UDMA mode 2 but that still didnt work, all it did was told the pc that the 4th priority for booting would be a cd-drive thats got UDMA 2…

ill try that link that karangguni gave me, ill report back