Ldw-851s

vbimport

#1

My LiteOn DVD burner(LDW-851S) is dead. It happen right after i was installing a firmware for my LiteOn CD-ROM (LTN-486S). If it can be fixed, can someone tell me the steps i need to take in order to fix it. Thanx

Here’s my computer description:
Dell Dimension 4550
P4 processor @ 2.0GHZ

*My DVD Burner is not OEM, i bought it on a retail store


#2

What do you mean “dead”?
Does the drive power up at all? (LED blinking?)
Is the drive recognized in the BIOS during initial bootup?
Have you opened up the PC and checked the power plug/IDE cable to make sure they are ok? (Unplugging the cables and plugging them back in is another item to try).


#3

Well, the drive does not power up at all. its like if it was turned off.
also, the bios cannot identify the drive.
i opened the pc, but all the cables are fine.


#4

Try using a different power plug.
Try installing the drive in a different PC.

If it is completely dead, and the power components are faulty, you should be able to RMA the drive and get a replacement shipped to you.
You have had it less than 1 year right?


#5

yea, but the retail store where i bought it is no longer there


#6

You flashed your CD ROM firmware onto your DVD writer? You need to use mktflash and reflash the drive from dos. How did you kill it exactly?


#7

That doesn’t matter, you have a 1 year warranty with LiteOn.
If you’re in the US, you can request an RMA here: http://www.liteonamericas.com/us/rma.htm


#8

By any chance, could that CD-ROM firmware have been flashed to your burner? (I don’t think so, since I don’t think that LiteOn CD-ROMs even use the same flashing method, but I’m not 100% sure).

RMA is a messy process. There’s time to wait, there’s shipping costs, etc. So before you try that, let’s assume for a moment that something did go awry in the process (it “dying” right after that flash seems suspect)… in which case… you may want to try this (shouldn’t take that much time)…

1/ Obtain a binary version of a firmware that will work for the 851S (GS0K, patched VS0B, or CG3B will all work)… you can either download a binary version (the GS0K stock on our website should include a binary version) or use XFlash-X to extract one out of one of our flashers.
2/ Go to http://dhc014.rpc1.org/howto.htm#mtkflash to get MtkFlash and to read the instructions for flashing with MtkFlash. And then flash your drive using MtkFlash… MtkFlash works even if BIOS doesn’t detect your drive…


#9

I agree with code65536 and Wesociety. First, try reflashing from DOS with Mtkflash. If that doesn’t work, then call or email Liteon USA to get an rma. There is a date of manufacture on your drive, and if that is less than one year ago, they will warranty the drive. I just did this with an 811S, and I found Liteon USA support to be very responsive, unlike many others I have dealt with.


#10

to HenryNettles:

how long did it took LiteOn to ship your drive?


#11

hey guys…great news
i fixed it with MTKFLASH 1.80

i really appreciate all ur help
i hope i could help you guys in some way or another
thanks a lot.


#12

Why dont you tell us how you screwed it up in the first place. This is not for self flagellation but for future reference so we know. Mr.65536 says cdrom’s might use a different flashing method, I checked my CDRW and LTFN worked with it, although the flash data it read was wrong, but it worked with the eeprom data. But I do not know if it will work with a cdrom since I do not have a cdrom to check. Can you really misflash things so easily?

Everyones experience is important. Especially if they were able to fix it, Just HOW exactly they fixed it.


#13

OK…thats the least i can do.

well, firts of all, i was trying to flash my LiteOn CD-ROM(LTN-486S) with a firmware i got at lite on’s website a few months ago.
the things is, i wasnt sure what it was for or what changes it was going to make.
I did’nt knew about flashing drives until i visited this website…then i learned what firmwares were for.
anyways, my DVD Burner was Secondary 0 CS(Cable select), and my CD-ROM was Secondary 1 CS(also cable select). None of them were either Master or slave, and since i didnt knew what the firmware was for i just felt like installing it.
While the flashing was in progress, i noticed that my CD-ROM’s light was becoming unstable, flashing fater and faster every second until it became steady.
Then the screen just froze, so i decided to turn of my computer(which i think it was a big mistake…but as i told you, i didnt knew well about flashing CD-ROMs)
then when i turned my computer back on, my CD-ROM’s lite was steady and my DVD-Burner didnt boot at all, plus, my BIOS didnt detect none of them. To tell you the truth, i was scared as hell because i payed almost $200 for my DVD Burner when it came out. Then i went to the internet and started looking for help, and finally you guys help me.