LDW-411S turning into a DVD-ROM drive after firmware upgrade?

Hi all,

For nearly a year now I have a Lite-On LDW-411S and I had great fun with it,
without any real problems while using the FS0F firmware.
The only problem was that it wouldn’t burn some DVD-RW’s I have a spindle of
so I decided to do some firmware upgrading to the latest version (FS0K).

So I went to the Lite-On site and downloaded the official FS0K firmware installer
and ran it; no problems here: it gave me a fine message everything was okay
and I should reboot.
After a while the system was up and running again and I tried to burn a DVD-RW
(one that previously didn’t work) and found out it still wouldn’t burn.
Well hey, no big problem: it’s only a small spindle and they were cheap, so nothing’s
really lost, maybe something for my next DVD-ReWriter…

Until… only a few days ago I wanted to burn a DVD-Video from an image I
authored (which upto now always worked fine) using a DVD+R I always use.
But it came out as a nice little frisbee (there’s no real other use for it now).

This was the first coaster I’ve ever had using this drive!

Well, these things do happen, so I tried another one: same thing! @%#@$%
Another one, from another brand, also didn’t give me a DVD my player could
chew on…

I’ve de-installed Nero and re-installed it again, but hey! Nero didn’t even see
the drive anymore!

So I swapped my DVD-Rewriter (which does still work as a normal DVD-ROM drive)
with a CD-Rewriter I have in my other (Windows 98SE) computer.

Now the problem was on my Win98 PC, so it’s really the drive that faulty!
My CD-ReWriter was normally seen by my first PC (with Win2k on it).

Now I went experimenting, because I didn’t buy a DVD-ReWriter to just use it
as a normal DVD-ROM drive.
I flashed it back to the original FS0F firmware (with help of some nice tools :slight_smile:
but it still wouldn’t be seen as a DVD-Writer.

Tried the ZebraMod-thing and turned it into a LDW-811S, but it just doesn’t
work anymore. Period.

I’m affraid something went wrong while upgrading the firmware the first time
with my EEPROM, using the official Lite-On upgrader!, so I don’t have a backup
copy (with laser-alignment data in it, I know) of my DVD-Rewriter’s EEPROM.

Does anyone have a clue, how to turn my DVD-ROM drive back to a ReWriter
again, or maybe have some samples of EEPROM-dumps so I can go compare
EEPROM-values and work out the neccesairy bytes that are responsible for
letting my PC see the drive as a ReWriter again and not a Read-only drive?

Any help would really be appreciated.

Greetz,

Peter.

Welcome :slight_smile:

Restore your drive to a 411S FS0F using the firmware on my site (see my signature). Try a few more burns of the same media with FS0F and see if the burn quality comes right again…

Hi,

First: thanks for replying.

I already tried your patched version of the official firmware, but to be certain
I just tried it again (and re-installing Nero).

There’s no difference, apart from the fact that it’s now a 411 again; the drive
still isn’t seen as a rewriter, but only a read-only drive.
It does read discs without a hitch, but writing is not possible :frowning:

I’ve tried all kinds of possible firmware “upgrades” I found using Google, but
my drive keeps telling my OS it’s a read-only drive.
Some tools I’ve tried, like Nero’s “InfoTool”, do report a re-writer, but
Nero itself only sees my CD-Writer, which is also in my Win2k system now.

I’ve put the result of InfoTool here

Greetz,

Peter.

remove the drive from device-manager and reflash with original firmware after a restart.

Swap the drive from master to slave or slave to master depending on your configuration. This usually clears the problem in Win2K. :wink:

Again: thanks guys for trying to help me out.

But… Unfortunatly I’ve already tried your suggestions and to be sure I tried
them again in all possible combinations, without any luck :confused:
Swapping master/slave didn’t fix the problem, just like removing (all) the drives
from device manager didn’t work either.

It seems like the drive is not responding correctly when queried by a (any) burning
program (not just Nero).
From the Nero-log I see numerous errors like KEY_MEDIUM_ERROR and KEY_ILLEGAL_REQUEST
when an application is trying to query the device.

Seems like I’m forced to buy a new drive in a few days… :eek:

Greetz,

Peter.