Laptop vista hard-drive no boot

hi guys,

my toshiba laptop wont boot to vista anymore. It sees the drive in the bios but when i goto reinstall windows it says no hard-drive found. I tried another drive but still the same thing. any ideas guys? appreciated…


In the BIOS, could you try changing the SATA mode to “Legacy IDE” mode. If this option is not present, see if there is an AHCI option, which you can try disabling. What this will do is make the SATA controllers appear like legacy IDE controllers to the OS. If the installation disc still cannot see the HDD, then there is likely a problem with your laptop’s onboard SATA controller or connection to the hard disk.

If the hard disk becomes visible when you change the SATA mode to legacy mode (or disable AHCI), this means that the drivers the Vista disc carries is not compatible with your controller. In this case, you’ll need to get hold of the SATA drivers and place them on a USB pen drive to supply at the start of the Vista installation. Be sure to enable the SATA native mode again and as the Vista installation disc boots, press the requested key when it asks if you want to supply an additional driver. While it is possible to install an OS with the legacy (IDE) SATA mode enabled, it can be tricky switching back to the native SATA mode later.

If you still have the Toshiba recovery CD that came with your laptop, that is another option, as it will have all the necessary drivers and factory included software. If this disc doesn’t detect the hard disk, then it is likely you’ll need to get the laptop serviced by Toshiba.

hi sean, thx for ur reply.

unfortuntaly the bios options are very bloody basic unless theres another bios menu cos i dont see any legacy support or ahci options at all. infact cant even get sub menus on hard-drives etc. just tells me the make and model, no size etc etc.

no its trying to boot from network. driving me nutz lol

is there 2 bios menus on a laptop. its a new one aswell, well just over a year.


I have a Toshiba satellite laptop which is also just over a year old, but someone’s using it at present, so I’ll have a check in a few hours.

One thing I do know is that it’s quite difficult to get in the main BIOS menu on some of the newer Toshiba’s. The first thing worth trying is pressing F12 after switching on. From what I recall, this brings up the boot menu on the model I have. Going by what I read around, holding down the ESC button while powering on will bring up a message saying press F1 for setup. Pressing F1 should then enter the main BIOS screen.

If I see the settings on mine, I’ll take a photo and post it here along with how I got to the screen.

hi sean, thx for the reply.
No that didnt bring up extra main menu. i know thats what i need to get into.
laptop is toshiba satellite p200-1fc
model: pspb6e

its driving me nutz lol never came across this kinda problem before. if i can get into the main bios then i know id have a better chance.

It did kinda boot b4, got to the scroling bar when starting but now it goes straight to boot from network lan and cant turn it off lol

hope u can get me into the main bios. :wink:

thanks alot buddie

The laptop I have is quite a different model, so the BIOS may be different on mines than what you have.

Anyway, if you’d like to try, this is how I managed to get in the various BIOS screens:

My model is: Toshiba Satellite Pro A120

If I press, F12 after turning on the the power, the initial screen stays with the following icons shown:

On this screen, I can press left/right to select an icon and if the item is present, it will boot from it. E.g. I plugged in a bootable USB, selected the pen drive icon and it booted from the USB drive.

The main BIOS screen is a little more tricky and here’s how I get into it on mine:

With the laptop off, press and hold down the ‘ESC’ key and with the key held down, press the power button to turn the computer on. Keep the ‘ESC’ key pressed until it beeps. If you’ve a BIOS password set, enter this.

The following message then appears on mine:

Finally when I press ‘F1’, I get the BIOS setup:

“Page Down” gives the 2nd screen:

Unfortunately on this one, I don’t see an option for disabling native SATA mode or ACHI. However, on the first screen, I can change the boot priority.

hi sean, what the problem was, was i didnt have the right SATA drivers sliptreamed into XP. Once i did get the right one i found out that the hard-drive was knackered. New hard-drive and new sata driver fixed the problem. thx for ur help.


my internal dvd drive is defective so i used an external optical drive but unfortunately, i can’t find the configuration of USB in the BIOS… i can’t reformat my laptop… please help me…