Killed my 40x-12x-48x Lite-on

vbimport

#1

Hello lads,
I’ve been a silly boy, can anyone get me out of this mess, :bow: i’ve resisted flashing my Bios for ages now, but i must have read one to many threads and i flashed my 40-12-48, 40126s (or something like that) with a 52246s bios, trying to be greedy, now you guessed, it wont show up, well it does show in device manager under disk drives as TER-R-24 ?.
shall i bin it or is there hope Thanks


#2

MTK WinFlash in Direct IDE Port Mode + Binary Firmware = SUCCESS!


#3

Thanks for your help but all i get is an error message…ERR: Fail to identify the flash type, is it me or…


#4

Try mtkflash in DOS. Try different versions from 1.38 up to 1.62


#5

First of all, which exact model do you have before you flashed it? I don’t remember Lite-On having a 40126S model. There is a LTR-40125S though, which can be flashed to LTR-48125W.

I never liked the idea of flashing one’s f/w in windows, it’s so J6P. Anyway, read the mtkflash guide, then get the appropriate f/w from Dyzan’s Lite-On firmware page, and flash it to either LTR-40125S or LTR-48125W. And next time, read the Big Lite-On FAQ thread first.


#6

There is a 40125W too.


#7

Hello all,
I replied to this again the other day but it’s not here where’s it gone? anyway… My model cdrw is 40125s…i tried the window thingy and all i got was this error message ERR: Fail to identify the flash type so i tried the dos one and i typed in at the prompt A:/mtkflash 3 w /b zsop.bin and all i got was a flashing bar under the authers name, i left it for a good half hour, should it take longer or wasn’t it doing anything?

thanks


#8

which version of mtkflash did you use?

as dhc014 said, try different versions


#9

Hello its me again…the latest,… i’ve tried mtkflash versions 1.48, 1.55 with bios’s zsop and vs08 it all does the same thing and sits there with a blinking cursor, i tried mtkwinflash and i get and ERR: input file format mismatched. i even disconected the hard drive and put it on primary master to make sure i was getting right port.
took the drive out to see proper model number etc it just says…LTR-40125s june 2002, s/n 202223000241 no indication of bios or 3 or 5 chip so it looks like i did kill it :frowning:


#10

i just got an idea for you to try. If you can flash it with the firmware 6S02 for the 52246s and then try to reflash to the original drive.


#11

I don’t htink you can flash 40125S to a 52246S. It was probably a mistake to begin with…


#12

Can you use Nero InfoTool to save the drive information and send me the text file or post it here? I need to know exactly how the drive is detected.

edit
Actually, try this. It is worth a shot since your drive is already dead. I don’t know what will happen :wink:


#13

I did this aswell with my 40x flashed to 48x i was the crazy tester and flashed my 40x with 52x firemware and i to had a dead drive
speaking of dead drives i have had a lot LOL

but i managed to ressurect them all.

this is no diffrent to a dos flash.

go into your bios and disable your drive put it at disable or none ignore auto.

then go into dos flash it and it should work im 100% shure not 99% / 100% :slight_smile:

then go back into dos and enable your drive.


#14

Hello boys, i can’t disable it in bios Virus2k because if it aint there i cant disable it, likewise Dhc014 when i run your little program it doesn’t show, i only see my dvd and a temporary scsi writer i’ve installed, the only sign of it i see is in Device Manager under Disk Drives ( it thinks it’s a disk drive) and it calls it TER-R-24 could it be a virus?, anyway i’m gratefull for your help one an all. if it appears i’m taking my time answering it’s because i’m having other probs, my HD packed up on here and i had to fit an 160GB HD which i’ve bought to go with my new mobo A7N8X Del) to a mobo that dont like it(Asus A7V) and it keeps messing my Registry up so had to reformat 4 times;) but thats another story, Oh and by the way it doesn’t show in that Nero thingy either.

                 Thanks skes

#15

Originally posted by skes
I’ve been a silly boy, can anyone get me out of this mess…

…but i must have read one to many threads and i flashed my 40-12-48, 40126s (or something like that) with a 52246s bios, trying to be greedy, now you guessed, it wont show up
Sure, you have.

You should have found one but the right one.
Since the first release of 52x FW there has numerously been warned about
the hazard/impossibility of flashin’ the 5th chipset drives with the 6th chipset FWs.

Look, here’s a tip for you:

  1. Block the pins with jumper as shown here.

Edit I thought I was a wrong place to display here /BoSkin

  1. Then go through the normal flashing procedure as you used to
    ( note > choose any proper .bin FW for the 40125S, e.g. ZSOP ).

  2. When that’s done, take the jumper off before rebooting the PC.

Good luck ! :wink:


#16

Thanks for that BoSkin, but sorry no joy, i put the jumper on disconnected all IDE stuff put it on Prim Master ran program nothing it just shows the authers name and just sits there flashing at me, maybe i should just bury it :frowning:

            Chears all skes.

#17

Originally posted by skes
Thanks for that BoSkin, but sorry no joy…
Well, it used to work just fine…Weird. :confused:


#18

Hi, have u tried to flash ur drive in pure DOS mode and r u sure the IDE port u entered is correct? i get similar response from MTKFlash when put in wrong IDE connection number. the correct numbering should be as follow:

Quote from MTKFlash 1.62 readme.bat:

How’s your DVD drive connected?

  1. MASTER on PRIMARY IDE port
  2. SLAVE on PRIMARY IDE port
  3. MASTER on SECONDARY IDE port
  4. SLAVE on SECONDARY IDE port
  5. Abort ----------------------

btw CD-RW and DVD drive should be flashable with similar way.


#19

Originally posted by blue_array

to flash ur drive in pure DOS mode
That’s what I’m talking about. It’s kinda obvious that I didn’t mean the MtkWinFlash method.


#20

Hello guys, I’ve taken all ide cables out including HD and connected CDRW to HD Prim Master to make sure i got the numbers right, iwas gonna add a screen shot to show what i get but i dont know how:bigsmile: