Kill SecuROM Emulation Detection

vbimport

#1

So you paid for Alcohol 120%, used the A-Ray scanner and got yourself a perfect image of your game on your hard drive. Then you try to run it and get a message that you have emulation software (no duh!), so it won’t run YOUR game, and it wants you to go to securom.com for details!? But no.

Go to m$.com, search for and download a program called “subinacl”.
Then run the .msi to install it. (W2k, XP and 2k3 only).
Cheap Shortcut
Create a new shortcut with this command line:
“C:\Program Files\Windows Resource Kits\Tools\subinacl.exe” /keyreg “\HKEY_LOCAL_MACHINE\HARDWARE\Devicemap\SCSI\SCSI Port 4” /deny=administrators=r

You must change the “4” in the command line to the number of the SCSI Port where all your emulated drives are. Use regedit and then follow the tree down to find out where they are. If this is too much info, don’t try this!!!

This little trick hides your emulated drives from prying little programs that have no business lookin at yer system’s undersides! It is reset at reboot so you will have to run this little command again to rehide your drives. Enjoy. I’m happily playing KOTOR2 from an emulated drive. Look ma, no discs!


#2

interesting…I look forward to trying it out tonight with Dawn Of War!


#3

ICy Mt…

Why dont you just make a little bat file that runs on boot? - Drop it in your StartUP folder and then you can just forget about the LAME SECUROM stuff :wink:

Cheers,

M


#4

muzchap,
Good point. It’s on the agenda, but I wanted to make sure exactly what other utilities might now be denied access to the virtual drives before I made it something that happens every boot.
-ice


#5

i have 4 scsi ports (0,1,2,3) when i only have 3 drives… 2 emulated, one real… does the floppy count as one?


#6

You can have 4 scsi ports and still use 3 scsi drives. It just means that one port isn’t being used.


#7

then how do i know which one my emulated drive (the daemon one) Is on??


#8

You need to use Regedit.

go to start menu then click on “run”

Type “regedt32” and press enter

then go to the “\HKEY_LOCAL_MACHINE\HARDWARE\Devicemap\SCSI”

Then look at the different “ports” and see which one daemon tools is using.

PS

Daemon tools uses scsi port 0 on my machine. it might be different on yours


#9

eh i’ll just try them all… haha


#10

okay i tried all 4 ports. didn’t work. maybe its my machine.


#11

d347prt belongs to D-Tools
a347scsi to Alcohol (if you havent changed names during installation) You can also try thisby hand: http://club.cdfreaks.com/showpost.php?p=742302&postcount=7 Edit: Dont try all ports ! Only the one(s) with x347 (if you have the latest versions of Alc and d-tools. Older versions have lower numbers)


#12

Here is a good example.


#13

doesn’t work, my drive is on port 2 and it iddn’t work.


#14

try it tonight! thanks!


#15

I read in the Daemon Tools forum that this no longer works for SecuROM 7.
Hopefully we get an updated DT or A120% soon.


#16

@KitnaIsntHappy
To start that Sec 7-title one has to repeat the deny-procedure at HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices


#17

Yup, after that, everything works perfectly :bow: . Tried Constantine, it’s ok.

I just made another shortcut with the “C:\Program Files\Windows Resource Kits\Tools\subinacl.exe” /keyreg “\HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices” /deny=administrators=r
command, place both of them at your startup folder and no more Se*ROM 7 probs!


#18

i have tryed both procedures shown above with championship manager 5 and it does not seem to work. i get an error message saying “original disc not found or authenticated”


#19

But u have a good image file? I mean that this is a bypass procedure, not a cracking procedure. U have to have a nice image file containing the protection. For example, the constantine I have, I made the first cd that has the protection with Alcohol 120% so the protection should be written well in the image file.


#20

Hi, I have the same problem as the guy you were talking to. I have created a good image file on a cd using blindwrite and followed the procedures in this thread about getting rid of the new securom 7 protection, yet it does not work. I wonder if it’s to do with the fact that the game I’m trying is very new (CM5 - only got it on friday), perhaps this method is already out of date?? Sounds unlikely but I can’t figure out why else this isn’t working, if anyone could let me know I’d be grateful