Keep getting 'Found New Hardware' message with new DVD drive

Hi guys,

First time posting here, hope someone can help. I’m not a newbie when it comes to computers but this issue has me wondering what the heck is going on.

I was refered here by NEC since I purchased a OEM drive from them and it has no warrenty. Well, actually, I got it from Newegg…who cares? :slight_smile:

Oh, I’m not posting this in the NEC sub forum because I’m convienced it’s not a NEC specific problem – I’d probaly have this with ANY DVD drive. I think it’s more of a Windows interacting with the DVD drive problem, and not sure where else to turn for help (since Windows XP and everything else on this computer was bought at NewEgg…)

Allright…I’m running Windows XP and purchased a NEC ND-3520A DVD burner. Installed it just fine, with no problems. Even made sure that the cable connecting it to the motherboard is the ONLY drive hooked up to it and that it’s set to the Master position.

The drive WORKS fine – plays games, burns movies, makes music CD’s, etc…it’s just that EVERY SINGLE TIME I boot Windows up I keep getting that damn annoying ‘Found New Hardware’ screen. If I try to click OK to install it correctly, it says it can’t be done. If I hit cancel, it says the device may not be working properly and there IS a X on it at the Windows Manager.

Not only would I like to fix this so that I stop getting that annoying message every time I boot up, but I’m also convienced it messed up my virtual drive…I bought the GameDrive program last year to make copies of my CD games so they would run faster, and since I installed the drive I’ve ‘lost’ the letter of my virtual drive and can’t use it! So I’d really like to get the NEC drive working ‘correctly’ to see if that fixes the problem.

The people at NEC were not very much since they claimed I did’nt have a warrenty (whatever…I buy something made by a company, you should support it!) but did suggest it was a conflict issue between Windows XP and the DVD drive. Of course, they would’nt say anymore then that and rushed me off the phone.

So I’m hoping someone HERE can help me out, PLEASE. :slight_smile:

Have a look at post #5 in this thread. May be the same issue.:slight_smile:

Well, thanks for the help…I followed the links which took me to the Microsoft site and tried the first option about changing the registry. Did’nt work. The second does’nt apply in my case because NEC has told me there IS no driver for their DVD burners.

What else could be going on here?

What’s easier than checking the NEC support FAQ?

The fact it’s useless? :wink:

Seriously, I tried all of that. There’s no driver for this DVD drive. All I could get out of the NEC rep on the phone today before I was hung up on was that it was a conflict with Windows. (Sigh)

Did you try a clean uninstal / boot/ install and reboot? be sure to unplug it and also go into safeboot mode and device manager and clean out old hardware you do not have!
It may be time for a format! ouch! That hurts!

New to me, the driver comes with the OS!

What I MENT was that in the old days, you’d have a dedicated driver for the CD-ROM/DVD drive. My other drive (a Maxtor) that I got way back in 1998 still works just fine, and that DOES have it own’s driver. (I got that when I was convienced that DVD games were the wave of the future… :o )

Anyway, I tried all the help that has been suggested so far, with no results. Making the change to Windows Registry messed up my computer and I had to revert back to a older save. The NEC FAQ on this did’nt work either. I REALLY don’t want to go through the pain of a new re-install of Windows, since the drive works fine for everything I use it for. I just want to stop that message from coming up every time I reboot and get rid of the ‘!’ that comes up on the drive in Device Manager.

Please, anyone else got any ideas?

We don’t have this old days, because optical drives drivers come with the OS.
Only for REAL DOS there are extra drivers necessary.

Installing your windooze new from scratch is inevitable.

Did you try uninstalling it in device manager and letting it reinstall. Just right click the drive in device manager and click uninstall. Then reboot and it should come up again wanting to install. This time hopefully it will install the right driver. Optical drives use generic windows drivers so maybe the one installed is corupt.

Just wanted to post a update.

After a LOT of searching around online and asking people, I FINALLY tracked down what the problem was.

The needed files for the CD-ROM device – cdsys, etc. – were not in the right place.

They were in Windows, allright, but for some reason the computer did’nt reconize them. Hence, the driver was’nt properly being installed, which always brought up the ‘found new hardware’ message on Windows being booted up.

The problem was also related to my loss of my virtual drive, because the correct files were not being loaded.

I’m not really sure how this happened. The older drives I replaced had their own drives due to the of the drives themselves – perhaps it’s been like this all along since I built the computer and installed Windows XP about four years ago.

I copied the needed CD-ROM files to a few places – the main Windows directory, the Windows/INF directory, and so on, and then uninstalled the drive and installed it again in device manager. Whamoo, problem solved – it now shows a Microsoft driver as installed and no more error message. I’m now working on getting my virtual drive program back up and running again.

In short, even though you guys really did’nt help all that much, I’m still thankfull for it. :slight_smile: And I’ll post this update in case anyone else has similar problems.