Kanguru (Nec 3500AG) stuck on dma mode 1

vbimport

#1

For some reason my machine, windows XP sp2 + Athlon 2400, uses this drive in DMA mode 1 (not 2, which is the maximum). While it’s ok to burn at 8-12x, I’m thinking that it be nice to get it into DMA mode 2 when I try 16x later on.

I used Liggy’s modified 2.18 firmware to get my Ritek G03 disc to burn at 8x (which is great, and finishes at about 9 minutes then followed by Nero verified data to make sure the media took properly). The original firmware was 2.16 (I didn’t check the DMA mode then).

This mode persists in both master and slave configuration. I set the drive to CSEL. The other drive is a Lite-On cd burner that is operating in DMA mode 4 (master/slave, so it rules out the cable).

The previous DVD burner used was I/O Magics IDE1008 (an 8x burner)- and I didn’t check what mode it was operating on (didn’t care at 8x).

Anybody know what to try/fix? Thanks.


#2

Also have the same drive with WXP Pro SP1 and it’s running at DMA mode 2. There is NO WAY a DVD burner will need mode 4 (ATA 66). I’m guessing that you put both burners on the second IDE channel.

I’d go back and put/set the NEC as the master drive. The Lite On should be the slave. Go back to windows in Device Manager and remove the secondary IDE channel. Reboot AND GO INTO THE BIOS. Set the BIOS to AUTO DETECT both IDE CHANNELS. Reboot and let windows reload the secondary IDE channel. This should set the appropriate DMA speed for both devices. Go back to the BIOS and confirm that all items are running in AUTO mode with DMA.


#3

Thanks Furballi. However, I’m still on dma mode 1.

I uninstalled the 2nd ide controller (both Kanguru and Lite-On are on this channel as you guessed). Then I went into bios, and have it re-detect the hard drive- which there are none on these two channels. Then when windows rebooted, the Kanguru is still on dma mode 1 using location 0, and the Lite-On CDRW is now on dma mode 3 (instead of 4) using location 1.

I got both drives on CSEL, and the cable should determine the master/slave relationship.

Wondering if there is something in the bios… I used a Shuttle motherboard. Still it would be nice to get it into the right dma mode (which should be 2). Lastly, I used a round UV cable that is of a medium length- probably didn’t exceed 18". I’ll look around the next time I get into the chassis.

Actually the problem is moot- as I was able to burn 16x on a Sony dvd-r disc (sony-08 media) in about 6-7 minutes. The 12x disc burned at 8-9 minutes. The 8x is burning at about 12-15 minutes… which seems to scale well. I might be ok in any DMA mode. I had thought that the dma mode 1 won’t supply data fast enough to the drive for 16x burning.


#4

Try flashing to FW 2.18. Mine is also a Kanguru (NEC 3500A). Came with 2.07 FW, but it was running at DMA mode 2 from day one. Very strange.


#5

You must have at least dma mode 2 to burn 16x dvd, and dont use cable select, begin of the cable is main board

[----------------------][------------]
mainboard              slave         master

the above drawing is how you must hook you cables up to the devices


#6

actually it doesn’t
8x =10 minutes
12x=6-7
16x=5-6


#7

ok and the nec doenst start at max speed it starts with 16 speed media at 4x until ,5 GB then it goes to 8 until 1GB then goes to 12x and at 3.5GB it goes 16x


#8

nope… it is not z-clv it is cav for 16x… read the review and you will see the graph/times it is a short and curly behind or in front of the benq 16x during 16x burns. it starts at 7x and ends at 16x no steps

in fact here is the graph from the review… looks like 6 minutes for 16x here:


#9

Yup, about right for the NEC 3500A. You can use the made in Japan 8x DVD+R Fuji (on sale at Best Buy this week) to experiment. 50 discs for $20.

Remove the other optical drive and set your NEC jumper to master. Reboot. Remove the secondary IDE channel. Reboot. Still showing DMA mode 1?


#10

I’ll try it this weekend:

  1. uninstall DRIVES; uninstall IDE secondary channel.
  2. reboot into bios- after setting Kanguru as primary (with primary end attached)- check that device is primary; disconnect secondary device for now.
  3. boot into XP sp2. check device settings.

Also I’ll burn another dvd at 16x and write down the exact time it takes in NERO, without data validation.


#11

With only one device on as master on secondary- still stuck on dma mode 1.
Here’s the timing for burns for roughly 4.5GB movie on dvd-r (with nothing else running in the backgroun).
12x 7:30 (Staples Teon media)
16x 5:50 (Sony 08D1 media)
I think I’ll leave it alone for now.

If we keep going with this, I’ll try another floppy cable (UV round cable). Sometime this year, I’ll swap a new mobo in (Shuttle Athlon XP, a cheap board).

Thanks for all the help.