K7 VIA Chipset & 1655 burst rate problem

vbimport

#1

i installed 1655 on my old pc & somehow i can only get up to 13MB/sec on udma ide;

my os is win 2k & using ms ide driver & the device manager indicates that it’s on udma (i don’t see any rise of cpu utilization while doing tranfer rate test)

chipset is kt133a with athlon xp

thanks


#2

try this: http://www.viaarena.com/default.aspx?PageID=420&OSID=3&CatID=1240&SubCatID=148

if something gets borked (e.g. doesn’t help, lose your optical drives in device manager, etc.) you may need to uninstall both IDE channels and/or via chipset (4in1/hyperion) drivers and/or the IDE Accel driver (one linked above) and reinstall them one by one (essentials first)…

i use the IDE Accel on both of my Via based mobos (K8T800 & K8T800Pro) with no issues (but on just one install ocassion out of many, i had to do the uninstall/reinstall thing for winXP to see my ODDs again)


#3

drpino already pointed you to right direction shimman… :iagree:

Also check out this.
Older VIA mobos can be kind’a tricky to run in UDMA-2 on secondary IDE channel.


#4

Hi guys, maybe a little of topic but does anyone know if these burst rates are OK for a MSI K7N2 Delta m/board.

Primary IDE Master - Plextor PX-130a crossflashed to a Benq DVD Rom 1650 (UDMA-5) : 42 MB/Sec

Primary IDE Slave - no drive

Secondary IDE Master - Plextor PX-708a (UDMA-2) : 28 MB/Sec

Secondary IDE Slave - Benq DW1650 (UDMA-2) : 23MB/Sec

Obviously UDMA-5 is faster than 2, but it seemed strange that the PX-708 was faster than the DW1650 :confused:

Was also wondering whether this would affect burn speed as I have been burning Verbatim MCC004 with the Benq and after about 50 burns, with various QSuite settings, have never exceeded 12X.

QSuite says this media is not suitable to be burnt at X16 so I have also tested TY TYG03 and T03 with the same results :confused: :confused:

Thanks


#5

drpino & pinto2, thank you for your kind help.

i tried via latency patch for max raid performance setup (both made by George E. Breese NOT by via), and it did not help. i also tried the via recommended older version & the latest version of 4-in-1 & installed via bus master ide driver; not much difference.

i will try to swap the ide channels & try with nec 3500a

again, thanks for your support :wink:

@keyap,
what qsuite reported is that your medias are not good enough for 16x burning on your drive. try nero-cd/dvd-drive speed to make a data disk to see how the writing goes


#6

what qsuite reported is that your medias are not good enough for 16x burning on your drive. try nero-cd/dvd-drive speed to make a data disk to see how the writing goes

Thought the same myself therefore have already tried this. The results were generally not great.

Most discs reached 12X but about 2/3rds through dropped to 8X ish then back to 12X. Some discs did not go past 8X.

None reached 16X :sad: :sad:

Doesn’t it seem a little strange that 3 different 16X rated media are not good enough, especially when they are MCC004, TYG03 and T03 :confused:

I have noticed that with OS and SB activated if learned media is cleared the first few 12X burns generally do not exceed X4, the next X8 and eventually all burn at 12X. If I try a few at 16X is it likely that eventually they will reach X16?


#7

UPDATE: i installed via ide accel or whatever ide driver instead of 4 in 1 or ms; i could not even boot to windows (i had to disable the udma in bios); i searched via forum & it seems like via drivers are buggy as hell.

once i booted with multidma mode, i retested the burst rate, and i was getting only 11 to 12MB/sec which is slower than what i used to get 13 to 14MB/sec; it seems like udma-2 was correctly engaged, yet i could only get upto 13 to 14MB/sec.

will try with nec & other ide drivers in dma/udma modes

@keyap,
if you have not installed via latency patch, you may want to do so.
http://www.georgebreese.com/net/software/
it is a must for my system; without it, windows crashes way too often
if you installed games with starforce copy protection, try to remove them.

best solution is to avoid via chips


#8

4in1 drivers (now called hyperion) are essential. You should not uninstall them. Also you should’t install some IDE miniport drivers.
You have read that this accelerator driver is a Beta version? So, use at your own risk.

i searched via forum & it seems like via drivers are buggy as hell.

Can’t confirm that. Old 694X and KT800Pro running well.

best solution is to avoid via chips

You cannot conclude from your ancient KT133a to any other chipset made by that company.
Today, VIA boards often run stabler than Nvidia systems, especially if Nforce IDE drivers are installed …

Michael


#9

michael,
did not realize there are via fans :wink:

i thought via wasn’t recommending 4 in 1 unless there are problems without it; accel driver in intentionally in beta because via does not know how to fix bugs imho.

my recommendation to avoid via chip is based below

my iwill kk266a is big old board, but my sister’s kt800pro isn’t doing well without via latency patch; there are still major problems with usb as well.

both kt133a, kt800pro boards & my usb2 pci card i bought two weeks ago have serious problems not to mention slow.

i cannot speak for nvidia as i haven’t used any, but i know that nvidia ide is at least considerably faster in benchmark testing than via in general.

i don’t think everyone is having problems with via, but many are.

i was fan of amd because of the price, but i think i would go for intel next time because of mobo chips & amd has gotten more expensive than before


#10

There is a problem with the KT133a chipset as already posted. Generally any optical device on the secondary channel will not actually get UDMA-2 but instead Multi-Word DMA which gives approximately half the burst rate of UDMA-2.

One solution is HD’s on the secondary & opticals on the primary. Works for me.

I also tried the IDE accelerator with a very similar result - unable to boot.


#11

UPDATE:nec 3500a pulled 17MB/sec under udma-2 (ata-33); i knew that via ide performance was bit low but this is way too low (hopefully via fixed the issue on newer chipsets)

the problems of via i observed in general is that not only the burst rate is low, via’s ide controller (perhaps pci controller) cannot maintain the full bandwidth.

it seems like 12x writing is the max on my old system with nec & 8x on 1655.

on my system, connecting burners on ide has almost same performance as to connect them via prolific 3507 bridge chip.

i read it, but that wasn’t the issue for me. some mobo have problems to enable udma on 2nd channel, but not mine. on my system, there wasn’t any effect.

UPDATE: switched the channel 1 & 2; well, the burst rate was improved almost by 1MB/sec (i was getting 17MB/sec for 5 times on 2nd channel, but i got 18MB/sec twice out of five on 1st channel); somehow, the transfer rate curve looked slightly better; however, hdd seems sluggish.


#12

i think i am going to re-image hdd to see whether anything i installed is affecting the performance

this is what i got from hd tune 2.5; the transfer rate curve looks like a fast ieee1394a hdd not a hdd connected directly to the system’s ide channel.

from the smart status, the wd1200jb’s dma mode is udma-5 (ata-100) & i am getting 30MB/sec burst rate…i really hope this is not the result from the gt legend’s starforce



#13

Eh, the Via KT133/133A chipset was a steaming pile of you know what. 8x burning isn’t so bad anyways. The BenQ burners still burn some of the highest quality burns out of any burners.

You should be happy that any device on IDE channel 2 even maintains UDMA mode. Those chipsets were notorious for having devices switch to PIO mode mid-transfer.


#14

i haven’t had any of the common VIA issues or those you stated above with either of my Via based mobos (and don’t use any of those 3rd party drivers/patches)…and though i’m sure they exist for many, i think Via (and many other manufacturers in general) get bad raps…

that being said, i’m sorry to hear the standard fixes haven’t helped much…


#15

thanks all for your helps; i will keep trying and if i find any solutions, i will update.

and yes, 1655 is doing well for single layer write once disks in general than most of other drives; that’s why i sold my dvr110xlb & 716a & keeping only 1655 + my boss’s 3500 which is used for dl/rw disk burning

i guess via has solved many problems, but i still feel bad about via as i am having more problems with via than intel chipset. maybe it’s because of lack of supports from ms.


#16

i think i found the major cause of the problem. it was an usb network card & a keyboard attached on the via southbridge chip’s usb port. (credit goes to storagereview.com’s AforceII)

both removed the burst rate jumped by 15MB/sec; however, it seems like there are other things that prevent from getting the max performance. i have not tried with my dvd burners, but hdd performance has been improved.

i wonder this has been fixed on newer chipsets as i had tons of problems with via usb2 pci card that i bought about 20 days ago.

the network adaptor & the keyboard are on nec pci usb2 card which is far superior to via