Just bought a Samsung BD-P1590 XAC player....can't update firmware

vbimport

#1

So, I just picked up an $8. Samsung BD-P1590 XAC blu ray player. It works perfectly, but doesn’t have NetFlix, and is, as far as I can tell, still on the original firmware.

I’ve tried updating the firmware a few times, in several ways, with no luck. What happens is it gets to the point where it “checks” the firmware, then the screen blanks out like there’s a screen saver being activated, but never actually comes back.

I never get the option to “Yes” update firmware, nor do I get any notification that the firmware file is bad or wrong, it just seems to time out…

Any advice to complete a firmware update to add Netflix would be appreciated.

Please don’t bother to post if all you’re going to say to me is to give up, or buy another product or some other non helpful advice. I am ONLY interested in updating the firmware of THIS device. I’m sure it can be done, I just don’t know how

Thanks for looking !


#2

What firmware are you currently on, what are you trying to update to, and how are you trying to update it?


#3

I am on, what I believe is the original firmware, it is BEv-1.00_090312A-XAC.

I would like to update to the latest, which, according to the Samsung Canada website is 2.21, so I can get Netflix.

I’ve tried using the CD, and USB methods, both result with the player Verifying Firmware, then after a while the screen goes black, but the input doesn’t go off, so there’s still a signal, but its a blank signal. I never get the option to update it.

I’ve also tried doing it with a direct ethernet link to the internet, verified the connection first, and it immediately tells me my internet connection failed, even though the “check” routine comes up all good.

I’ve also downloaded the newest XAA version, which is 2.2, and used a hex editor to change the first instance of XAA to XAC, as well as rename the file with XAC instead of XAA. It does the same as all other attempts, basically stops at Verifying Firmware, and never gives me the option to hit “Yes” to update.

The player works, it plays Blu Ray’s and DVD’s, but I really would like to add the NetFlix option. I’ve tried a half dozen “hard” reset’s by holding the front panel FF button, then choosing 1 for English. However, when I do this, none of the settings I’d input change, ie. it stays on 24p output, which was a setting I changed. I would have thought, had it been reset to defaults, that would have been changed to “OFF” ?

I’m pretty much out of options, I’ve Googled and read a LOT about this player, and there was a time when lot of people were loading Singapore and Brazil firmware to get region free, etc., but I don’t want to even risk trying that if I end up stuck with a different firmware, AND still no NetFlix…

I had thought maybe I needed to install an interim firmware, perhaps the first firmware that introduced NetFlix, but there doesn’t seem to be anywhere that firmware was/is posted. Samsung ONLY hosts the newest file.