JMicron Issue Solved

Hi Everyone,

If you are using a motherboard that has JMicron RAID or PCI-E to IDE for your CD or DVD drives connection then you probably be suffering from the fact that, your Windows XP does not recgnise your drive properly i.e DVD RW drive is shown as CD ROM device or the Recording tab is missing from the Drives Property even though it is a Writable Device.

To fix the problem I have found this hack. This requires you to modify the registry settings, therefore you should backup your registries first. I take no responsibilties if you comupter is damaged. You modify these setting on your own risks.

Ok,Lets get down to the business:

  1. Click “Start” and Select “RUN
  2. Type in “Regedit” (this will open up your Registry Editor Window)
  3. Select The following Key or Keys if you have more than on Drive:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CD Burning\Drives{YOUR DRIVE VOLUME ID}

++ Please note {YOUR DRIVE VOLUME ID} is series of letter and numbers that windows uses to identify your Drive. Becaraful not to select the wrong drive as they are not maked with a drive letter like D: or E: etc … SO BE SURE TO EDIT THE RIGHT ONE. See the handy tip below on how to identify the troubled drive.

  1. Click on the Drive you want to modify.
  2. On the Right Panel look for following Entry:
    Drive Type=dword:00000003

HANDY TIP: If you have the entry like one above (with value of 3) that means, windows is not detecting your drive correctly.

  1. Doulble Click on “Drive Type” enrty

  2. Change the “Value Data” to one of the following:
    1 If your device is CD R only
    2 If your devices is CD RW

  3. Click “OK

  4. Reboot Your PC

  5. After Reboot Go to My Computer and Check the CD/DVD Writer’s Property. If you have done it correctly you should have “RECORDING” tab showing.

I hope you understand what I have written so far. If you need further help please do not hesitate to e-mail me noor.alam@tradesquare.co.uk

Or you could remove the Jmicron drivers and use the Microsoft standard dual channel IDE drivers. I know Jmicron has a new set of drivers on their FTP site but I have not bothered trying them.

Yes you can use Microsoft standard dual channel IDE drivers, however you will have problem with DVD palyback and DVD Burning. I have found that If you use you Microsoft standard dual channel IDE drivers, burning speed never gets beyond 2X using NERO or ROXIO and even using Microsoft built in CD burner. On DVD playback all DVDs seems to be running on slow motion.

So the scnario is, Microsoft standard dual channel IDE drivers will make your CD/DVD Drive recognisable to Windows OS but NOT Function properly, but with Jmicron Drivers your drive will do what is supposed to do but Windows OS will not see as Writable Drive.

In that case, it is a good idea to check if DMA mode is enabled.

Michael

I have no such problems with the Microsoft drivers. DMA is the key… make sure you turn it on like mciahel suggests.

I have no desire to try the Jmicron drivers but I hope your solution works with those that do.