JMicron Goes PIO

vbimport

#1

OK i know this information have been posted already in a various places but i couldnt find any normal solution to this.

I got a new computer about a month ago and since i assembled and installed everything i had some nasty hangup problems from time to time. It took me really long time and effort to finally come to the conclusion that this all was cause by the drivers of the opticaldd.
At first when you install the windows the odd shows as one of the primary ide controllers and have UDMA4 enabled for them but after that when i install all the drivers that are needed they drop to the PIO mode.
I have tried various drivers versions, lots of ways of their installation (prior os and after) and they all failed. I even tried this DMA unlocking thing for the registry but it totally ruined everything and they still dropped to PIO. JMicron for some reason has two options of connecting the ide devices the first is the regular ide and the second is the scsi controller. (i have a suspition that scsi actually works better but nowhere close to UDMA4. While in the scsi it is impossible to understand what kind of trasfer the ide has.

So now i am really lost of clues. I left the latest drivers for now and the JM36x at the scsi setting. I am really not happy about all this but now i really dont know what to do.

This is part of the pc spect that is usefull to this post
cpu - Intel 6400
mb - Abit ab9pro
hdd - wd ys 250gb (single hdd on sata1)
odd - sony dvd, lg gsa-h22n (both on jmicron ide1)

here are some posts that i made in other forums that could be useful that atleast made me do lots of wipes of my computer and didnt help at all
http://forum.abit-usa.com/showthread.php?t=119307 that sent me to an evil post that made me format lots of times
http://forum.pcmech.com/showthread.php?t=173877 that helped me understand what was actually my problem

As for simple solutions for this case i would like to ask if

  1. I should just get another new motherboard?
  2. maybe i can get a pci-ide device and this will help solving that problem for me?

#2

I just got through trying to help someone on the forums with a similar problem. See: http://club.cdfreaks.com/showthread.php?t=207605

His solution to this was getting a SATA optical drive. Cheaper than a new motherboard, and saves tearing your hair out trying to get that IDE controller to work.


#3

oh yeah i didnt mention it earlier but for some reason there is no store selling SATA optical !!! AT ALL !!! I tried like 6 stores by now and no one has them!


#4

Yoiu can buy SATA drives on the internet. NewEgg has them, but they are usually out of stock. They will notify you when they are in stock and you have a few hours to nab one.

When using a Microsoft driver, Microsoft calls it IDE. When using someone else’s driver, Microsoft calls it SCSI. But it’s not SCSI.

If you can use the Microsoft driver, then do that, and don’t install any third party (OEM) driver. If Microsoft’s driver won’t install then make sure to get the latest driver from JMicron or wherever.

Make sure you are using an ATA 100/133 ribbon cable. It has 80 wires as opposed to the older 40 wire cable. Both use the same connectors.


#5

i will consider just buying the new drives

is this usual that when the drives are connected through SCSI i cannot see their transfer type (if its DMA or PIO)?

as i said i probably can use the regular windows IDE drivers and they will work in DMA mode but then i can not install the motherboard chipset drivers (intel p965ex in think is the chipset and the latest drivers are 8.1.1something) because then the connectors recognized as PIO only. Now i probably can leave both intel and jmicron drivers uninstalled but i am not sure that without the intel drivers the windows will work propely (most of the controllers and root ports in the pci bus are excamation marked without the drivers installed and it is written in the intel website that they are needed to properly work all the usb, pci, pciex and so on)
what would you suggest on this matter?

i am pretty sure that the cable is the 80 wires and i tired couple of other cables also. (it is thinner than the older gray ones and doesnt have 1 pin hole in the middle of the bottom set of holes) Is that correct?

Anyway i will add again that basic windows installation without any other drives that should work for any motherboard chipset that i have indicates that the ODD is in fact UDMA4 and only after that the problem begins.(both Intel and JMicron drivers separetly except for the SCSI setting that i cant see what kind of trasfer type it uses make it fall back to pio [i dont remember for sure if the Jmicron set to ide configuration does that or not or after reboot but intel does that for sure when Jmicron is set to ide {as i understood the ide setting for jmicron uses the usual windows ide driver}])

I think maybe i will try one last thing which i forgot if i did or not and it is basic os install then (already in widows when my ODD are showed in UDMA4 ide) then JMicron to set it at SCSI and only when it is already in SCSI i will install the intel drivers that adjust its root port. Do you think this will even matter?

I am seriously considering purchasing and additional card which is PCI-IDE connected to pci slot and offering an additional ide port. Do you think that this may help me and through this controller the ODDs will work in the normal ide mode or there is a possibility that i will still have the same problem?