JLMS XJ-HD166S DVD ROM READS CD but NOT DVD

Hi
I read a lot and tried a lot but my DVD-rom JLMS hd166s
still cant read DVDs but only reads CDs
Error: Pls inser a disk into drive E:
(Tried DVD discs(Movie) that used to play them normaly before problem region1,2,3,&all)

Triger:
it started when i used DVD Region +CSS Free and clicked enable DMA

I tried:
1-installing & unistalling software(sp2,codecs,players,DVDregion,…)
2-uninstalling drivers for DVD and IDE normal/safemode
3-formatting HD
4-reseting BIOS
4-flashing drive 2 new firmware then old then new again
5-Changing the IDE postion (Master/Slave)
6-used it in another computer(also didnt work)

But i heared ppl having such problem
and found asolutions, isnt there asolution 4 this one.

Settings:
WinXP
DVD drivefirmware: DS1E
Primary IDE : (Master) HD ST340016A UDMA 5
Primary IDE : (Slave) None
Secondary IDE : (Master) JLMS XJ-HD166S UDMA2
Secondary IDE : (Slave) HL-DT-ST CD-RW GCE-8523B UDMA2
Motherboard: FUJITSU D1321
BIOS: FUJITSU Phoenix Technologies Ltd 4.06 Rev. 1.06.1321 07/02/2002
MOB Chip: INTEL 485

Thanx

I had this problem with my optorite dd045, it worked ok-ish for about 3 burns then stopped reading/writing to dvds. It still read/wrote to cd-r. I tried everything i could think of, no luck:( i took it back to place of purchase and got another drive (didnt pick an optorite again ;))
If u tried it on a another machine and upgraded firmware etc, thats got to be the drive is knackered :frowning: take it back for a replacement or RMA it if not less than a year old…sasarchiver

(If you already tried this, disregard)

I would power down the system, unhook all drives except the HDD, power up, go into bios, make sure the only IDE device(s) is your HDD(s)

Save Settings-> Exit Bios-> Start Windows

Shut Down

Reconnect Drive(s) power up, go into bios and see that you drives are all showing, if not autodetect them.

Save Settings-> Exit Bios -> Start Windows

Maybe that will work.