Jedi Academy protection?

vbimport

#1

I’ve just bought the recently released game in the UK and find that the protection is Safedisc 2.9 according to Clony xxl. I’d been led to believe that this game was Securom 4x protected and even the online manual refers to its “Securom advisors”. My Clony is up to date and I have scanned the discs several times.
Anyone any ideas before I create a pile of coasters?
:confused:


#2

According to here:

http://www.petemoore.pwp.blueyonder.co.uk/ (Star Wars…)

That game is Securom 4.84.84.0020 protected.

Another way to tell if it has Securom protection is read the disk with the .bwa builder (Physical CD characteristic dumper) in Blindwrite, and see if you get the characteristic curve interrupted by sections of small peaks. (Difficult to explain if you haven’t seen it before but see here: http://www.petemoore.pwp.blueyonder.co.uk/bwamdsfiles/graphs/GTA_VICECITY_BWA.gif).

HTH

Lazer.

(Links courtesy of Bulk)


#3

Thanks Lazer was coming to that conclusion as even Alcohol shows it as Securom 4x. Unfortunatelly I had to give up on Blindwrite a while ago as it messed my system up so will look to see if anyone can let me have a BWA or MDS for this game.
Thanks again;)
Johnboy183


#4

Hey, I’ve got this game and it’s SecuROM 4.84 blah blah blah. I can make a bwa if you want.


#5

That would be great if you could. Just let me know if you need my email address and will reply back. Hope I can return the favour at some time.
Johnboy183


#6

Beautiful BWA if I ever saw one. Sorry I don’t have time to test today but it looks like it should work.


Submitted by: BadReligionPR
09-22-2003
Title: Star Wars Jedi Knight Jedi Academy
Drive: Lite-On LTR-48125W
Software: Alcohol 1.4.6.711, 1x.
Size: 23.5KB
Graph Enclosed: Yes

Download It!


#7

Forgot - in case you hadn’t figured it out, the BWA is for CD1 (Play). Also, mds was actually made at 4x, not 1x.


#8

It’s obvious that different protections are being used in different countries. USA release is securom 4.8x; UK release is safedisc 2.9.


#9

I’m sorry, I’ve been away from all this BWA files, I see that you used a Lite-On device to make the BWA, it’s OK to use it with my Asus 5424A?

Thanks


#10

Should be ok. Just compare your graph to the one posted once you are finished.


#11

Thanks BadReligionPR. Hope this protection is Securom and not SD 2.9 (see Philamber)
I actually managed to come up with an MDS yesterday that works in Virtual Drive but as it loads it says “please insert CD1 in Cd Rom” - or similar. I found to make it work all you need to do is put one of the previously burned Jedi Academy coasters in the Burner and then click on the Virtual Drive icon mounted with the Image. Take out the coaster as the game loads and off you go! It works every time ( I used a ccd and an mds coaster and both worked!). I assume the disc is acting as a Boot disc as the manual says the disc is only required to load the game and does nothing beyond that. This appears true as leaving the disc out after it has fired up leaves the game running problem free! You learn something every day!
Will try the BWA and report back.
Johnboy:bigsmile:


#12

@poopeyhed2: Please take note I used Alcohol to make this, followed by converting MDS=>BWA. The graphs made by BWA builder were quite horrible.

johnboy183: Go into regedit and find Jedi Academy’s entry under Local Machine/Lucas Arts/Jedi Academy (or something like that). There are two entries regarding the path from which it was installed and where it looks for it (for instance E:\ and E: on mine). Change these to your virtual drive’s letter.


#13

johnboy183

i just got the Australian version today

and it’s safedisc 2.90.040
aswell as your uk version

and I just backed it up just fine
without bwa files


#14

BRPR - Unfortunatelly the game wont load or run with the Twinpeaked BWA and ccd mix and changing the drives in Regedit does nothing! - so am seriuosly thinking that Philamber and Clonny are right and that what I have is a SD2.9 protection (given it is a UK version)!
Chokito - I hope as the “man who doesn’t need to remember” you certainly can remember and give us the lowdown on what software and settings you used as SD2.9 is supposed to outwit all current methodologies according to other threads - you may just have the answer!
Thanks
Johnboy183:confused:


#15

@johnboy183: If it is safedisc, you will see errors from sector 100-11000. Also, if it’s safedisc, i doubt you could make a very good bwa. If it is securom, your bwa graph will look like the one from badreligionpr.


#16

Just managed to get a reading from another protection detector and its definatelly SD2.9!!! So its back to the drawing board but it proves that SD2.9 will run on an Alcohol Virtual Drive as my earlier post using an otherwise useless Jedi “coaster” still works well. This was mounted using an mds created in Alcohol

So for those out there want a way to run an Sd2.9 game in virtual Drive this appears to be one way.
thanks to all for the help - any more would be gratefully received!
Johnboy183 :confused:


#17

ok Johnboy183

i copied it with Alcohol 120%
do you have that to use ?
if so what version ?
it’s just that the wording is slightly different with different versions


#18

Chokito,
Not having a good day today! Hit the wrong button in the earlier post and then my connection dropped out as I pressed to send a proper reply!
Yes I do use Alcohol. It is Alcohol120% Version1.4.3.410 and works fine usually. I have mainly used it to prepare mds files to mount on virtual drive which it does excellently but have tended to use CloneCD for most of my CD burns.
My burner is a Sony CRX 140E which according to all the pundits shouldnt be able to burn anything with decent protection!! However it has burned just about every game I have asked of it with a bit of ingenuity - including Securom 4.8 and SD 2.8
Hope this helps::confused:
Johnboy183


#19

ok mine is a new burner
this is what worked with my burner

but i don’t know if this will work for you then
so yours is a 32x8x4 is it, i would think it would work

anyway here’s the options i used
hope the wording is the same, may slightly differ in your version

Under Emulation options:

I have checked that “Ignore media Type” : Ticked
Launch CD/DVD Manager : Ticked
RMPS : : Ticked

Under the Image Wizard:
Reading :

Device: LG GCE-8520B (Burner)
Read Speed: 4 (or slower)

Fast Reading Errors: Ticked (enabled)
Fast Error Skip Blocks: Ticked
Advanced Sector Scanning (factor 100): Unticked
Read Subchannel Data from Current Disc: Unticked
Data Posistion Measurement (Precision:Normal): Unticked
(Datatype: Customize)

Under the Image Burning Wizard:
Writing :

Device: LG GCE-8520B
Write Speed: 8 (slow as possible)
Write Method: Raw DAO

Enable Buffer Underrun Technology: Ticked
Don’t Close the Last Session of Current Disc: Unticked
Bypass EMF Error: Unticked
Rectify Sub-Channel Data: Unticked
(Datatype: Customize)

So give it a go anyway
the game works for me on another computer that has NO Emulation


#20

Would someone please be kind enough to tell me what program and settings I should use to copy a U.S. Jedi Academy (Securom 4.8x) disc? The Alcohol forum says their program can’t copy it because of something called “Blacklist” and will address the issue in their next version.