I've an idea. Where is ATIP data physically stored?

vbimport

#1

Ok, I’ve come up with an idea. This might just be a waste of time (hopefully some of you more knowledgable people can tell me for sure) but who knows. It seems to me that our biggest problem these days is the fact that the latest copy protections read ATIP data. You have to block this check by running software (which doesn’t always work, especially since all the software designers decided to disable this in the US) but this is kind of a pain, especially if you want a more universal solution like maybe something that works in linux or a really old computer (like my crappy laptop.) It seems to me that the only difference between a CD-ROM and a CDR as far as reading this would be concerned is that a CDR has that small section with data in it versus a CD-ROM having nothing there. So, I had an idea. Why not just make this section unreadable? If it can’t sucessfully read any ATIP data, won’t it just assume that you have a CD-ROM? Well, the tricky part of this is, I’m not sure exactly where this data is. I’m currently wasting CDRs and making a lot of coasters trying to just guess at this. I’ve managed to cover up a surprising amount of the CD and still get it to read somewhat, but so far it still doesn’t work when I try to start the game. I might get it on my own, but I only have a few CDRs that I can truly afford to spare, so I have to give up until I get more data since it will surely take a few tries.


#2

Check this: http://sirdavidguy.coolfreepages.com/ATIP_Wobble_Info.html. You can’t remove atip data. The best (and probably only) solution is to use atip blocking software tools.

As for linux, it can be just as easily implemented. But what games run in linux or an old pc and check protection/atip?


#3

I don’t quite understand why that proves you can’t remove it… I mean, you don’t think I intend to remove it BEFORE burning, right? After burning it’s no longer needed anyway. (Too bad the drive can’t just burn over it. Makes me wonder if you concentrated the laser on an area long enough if you could at least damage it even if it isn’t part of the burnable area…)

Well, originally, my idea was to locate where the data is, then carefully scratch as much as possible from the area. However, I’ve come up with a better safer idea. I’m not sticking the disc in my PSX and spinning it while carefully holding a permanent marker to the area I want to block out. Problem is, it’s pretty hard to guess which area that should be…

Oh, and Linux, well, I believe that SecuROM checks that doesn’t it? I know Neverwinter Nights uses SecuROM and I understand that it runs in linux (at least, I’ve read indirect mentions of this, and it does have a shell script on the installation CD.)

Anyway, I’m trying ATIP blocking tools as well. Problem is, it’s hard even to find them. I tried CloneCD, but, the patch that is supposedly just supposed to add some registry info refuses to run with the claim I don’t have CloneCD installed. Guess it only works with one version. (I will never understand why with things like that they have to do it the hardest possible way… Why not just a .reg file?) Besides, like I said, I want a more universal permanent solution. I don’t want to have to run some stupid software that will just get blacklisted and updated every other day each time I want to run the game from my backup. It’s easier to use the original, even if I am afraid of the sheer volume of scratches piling up on my original…


#4

you could always use the backup in a cdrom, then atip blocking software isnt neccesary


#5

I don’t have the money or will to waste in buying a CD-ROM when I have a DVDRW drive! It’s no longer a very viable option for everyone to have a CD-ROM just to defeat copy protections that look for ATIP.


#6

I don’t think that the protections check the wooble itself, i don’t know if a drive can even report wether there is a wooble or not. They check for the data stored at the very beginning of the CD-R track, ie disk size, dye manufacturer, needed laser power, etc… So the idea is that if someone could find the exact location of the beginning of the ATIP on the CD-R, he/she could erase it with either the laser of a burner or a marker pen.
Still it’s very close to the lead-in, which, if damaged, could make the CD-R unreadable.

You could try to see where the laser seeks when you instruct an opened-up burner to read a CD-R/RW’s ATIP.


#7

Well, I’ve tried my best on it all. You think it is near the lead-in? I never QUITE got it. I would get to one point with no troubles except the fact that it still knew it was a backup, but, when I went too far I end up with one heck of a screwed up disc that gives me gibberish when I try to start the game. Luckily, permanent marker can be easily wiped off with the help of just a dab of alcohol. Unluckily, it gets harder to apply the marker each time. This at least means I’m not producing coasters by the dozen. Still, it sounds like it might be possible through enough trial and error (and maybe a fine tip marker instead) to eventually get it right even if by accident…

Personally, I’m not about to open up my burner. Lol, I spent about $100 for it, which, for me, is a lot (never mind the fact that stinking NEC now offers a dual layer burner for less than $80, darn them,) so until something goes wrong, it stays in one peice.

When doing my best to compare the original CD to the copy, I have definitely noticed the original CD has a larger area before the real data appears to begin. I have noted with curiosity a TINY paper thin line in the middle of that first part before any data begins an area that has the same reflective nature as the data part of the CD.

Does SecuROM check for this data? I assumed it does, but I admit I’m not 100% sure. Right now I don’t have exactly a ton of games with copy protections. My best test subject is my Neverwinter Nights discs. They just recently added some kind of update to the protection software (immediately noticable by the icon it suddenly now uses when checking and the influx of complaints in the forums at the exact same time this patch was release.) d-: Right now it’s pretty sensitive and I haven’t even gotten it to work correctly in Daemon Tools even though it doesn’t actually recognize Daemon Tools as emulation software (latest version, plus I change the name of the bus and scsi from the default to something the software is less likely to recognize when I installed it.) Normally when it recognizes it says conflict with emulation software and exits, but, instead it just says that it can’t verify the protection within the time allotted or something along those lines. (I’m going to try making the image again later, maybe I messed up something. Either way, I did a direct 1:1 copy following instructions when I made the CDR, so I know it’s ok.) The only other thing I could say for certain was heavily copy protected is Aquanox 2, but, from what I hear, it’s so ultra-sensitive that you can’t use normal methods to copy it. I haven’t tried. Unlike NWN, I don’t care enough about it to have to have a backup.

EDIT: Oh, btw, I saw my burner listed among the “two sheep” burners in someplace. I can’t say for sure if it’s true, I don’t know how to test myself, but LiteOn seems to have a reputation for burners that will basically do what is needed generally.