iTunes 5.01 not recognizing PX-716A?

Hi everyone,
I have a PX-716A (TLA 0308) connected as master on IDE port 2 on its own. It’s been working fine and is recognized in Win XP SP2. Both Plextools (V 2.25) and Nero (6.6.0.5) are installed and I’ve burned many CDs and DVDs without a problem. I have no disk emulation software on my system and have not installed the InCD packetwriting software. The drive’s DMA mode is UltraDMA mode 4, if that matters and under plextools the “hide cd-r media” is not checked.

I installed iTunes 5.01 2 days ago and bought some music. I wanted to burn it to a CD but then was given the message that I either don’t have the right software or a supported burner. Under iTunes “Edit->Preferences->Advanced->Burning” tab, under CD burner, there is no supported drive detected.

I did a search here, on google and looked through iTunes site but can’t find a way to get the drive to be detected. I uninstalled and re-installed itunes without any effect. I used Nero info tool and it said no system ASPI was detected (though I thought iTunes had its own). Anyway, I found a program that installs ASPI v 2.60 and I did so. Now infotools shows both a system and nero ASPI detected and working. Still iTunes doesn’t show the drive.

What is odd is that when I insert an audio CD into the drive, iTunes recognizes it and plays the music. Also, when I insert a blank CD-R, iTunes also recognizes I did so and suggests I make a playlist for burning. I made a playlist with my purchased music and one with my old MP3s. In neither case will it burn as I immediately get the error that my drive isn’t supported or I don’t have the right software. Does anyone have any suggestion?

Thanks,
Louie.
P.S. I just installed iTunes on my laptop with a Matshita DVD-RAM drive and iTunes does recognize the drive and allows me to burn music on that. My laptop also has Nero 6.6.0.5 installed (without InCD).

System:
Athlon X2 4400, Abit AN8-Ultra (BIOS 17), 2x1 GB (stock settings, no overclocking)
WinXP SP2 (updated)
Seagate 7200.7 IDE drive as master on IDE 1.
PX716A installed as master on IDE 2.
I have installed the Nvidia mother board drivers V6.66 but I had some corruption on my drive. So I reinstalled Win XP (new system with fresh XP so I had nothing to lose) with the drivers but this time I did not install the nVidia sw ide drivers or my firewall drivers. I’m using the MS default IDE drivers.

I don’t use iTunes at all, so I can’t help. :sad:
But there is also another thread about it, maybe you could find it useful. :slight_smile:

Oh, and welcome to the forums! :smiley:

Regards,

ET

Eltranquil,
Thanks for the response :slight_smile: . That is one of the links I found on this forum. His problem had to do with ripping. Mine seems to recognize CDs fine but when it comes to burning, just says I have unsupported hardware. I’ve emailed iTunes about this too but I’m not sure they’ll be able to help.

For now, I guess I have 3 possible solutions:

  1. I’ve installed iTunes on my work laptop and it does burn with the Matshita drive built in. I could transfer my purchased music to the laptop and burn from there. But it is a “work” laptop and I shouldn’t be using it for this purpose and eventually I’ll likely have to give it back.

  2. Get a 2nd burner. I do have an old toshiba burner laying around. It’s just that with this system (my previous system which had a PX-716A as well and Plexwriter 24/10/40 was stolen last month :a ) I was trying to keep fairly simple and minimal.

  3. During my search for a solution I came across some software called iOpener (or something like that). I was able to strip the DRM and I found I could then burn the songs on my home machine on the PX-716A using Nero. That isn’t my favourite solution and I would rather not have to resort to that.

Thanks for the response though.

Louie.

You’re welcome, sorry that I wasn’t able to help you.

ET

Here is a drive by advice as I don’t use iTunes either.

You are mentioning an old ASPI version. Try the latest one: http://www.adaptec.com/worldwide/support/driverdetail.jsp?cat=/Product/ASPI-4.70&filekey=aspi_471a2.exe&sess=no

Good luck

Met one person that had problems with Itunes. He managed to fix that by going into iTunes %.x config files and corrected the problem.

The problem is that they had no entries for the 716-A drive in their latest version 5.x config files – why they dropped or lost this entry from their version 4.x files is unknown. All he did was copy the entries for the 712-A drive, replaced “712-A” with “716-A”, and the software now works.

hack into iTunes %.x config files. <gcdrmmc.dll>

The problem is that they have no entries for the 716-A drive in their latest version 5.x config files – why they dropped or lost this entry from their version 4.x files is unknown.

Copy the entries for the 712-A drive, replace “712” with “716”, and the software works. Probably need to change the DVD write speeds to add 16x also. Didn’t do that yet.

installed itunes 6

It works and burns
New drop down menu on burning tab lists my old burner that is not in machine and it lists my new Benq burner

All is well…

my burner is benq 1640 but same problem

I also have a px716 and was wondering were you found itunes 6. Where is it?

EDIT, Duh, itunes.com, I tried using the update in itunes and it kept saying 5.1 was the latest. went to itunes.com and it was there.

http://www.apple.com/itunes/download/

just released today…

edit: your edit beat me to it…

Hey,
Phantzy and bob11879, you guys were totally right. I changed the “gcdroem.cfg” and “gcdrtype.cfg” under “\iTunes\CD Configuration” folder and now the 716A is recognized just fine. I haven’t tried an actual burn yet but at least it shows up. Thanks a lot for both your help! I’ll probably try iTunes 6 later, but at least now I know where the burner info is.

EricJH thanks for the response too. I didn’t think the ASPI was the problem since I checked out the laptop and it has no system ASPI either only Nero yet it worked. I wonder if I can get rid of that older ASPI 2.60 version now completely. I don’t think that I need it.

Thanks everyone,
Louie. :bow:

I too had the same iTunes problem with Plextor PX-716A not being recognized, which I corrected by changing the gcdroem.cfg & gcdrtype.cfg files as recommeded above. It will now burn Audio CD’s but will not burn MP3 / Data CDs. It gives me the following message when I try: “The attempt to burn a disc failed. An unknown error occurred (261).”

Have any of you who got their PX-716A / PX-716SA working in iTunes been able to burn MP3 or Data discs?

I suspect that there are slight differences between the 712A and 716A drives and just copying over the exact settings in the gcdrtype.cfg is not enough and that there are a couple settings that may need to be changed.

Here is what I have in the gcdroem.cfg file:

[PLEXTOR IDE PX-716]{RecorderType:IDE/ATAPI}<gcdrmmc.dll>
FAMILY = DEVFAM_CDR_IDE_ATAPI
GENERALFLAGS = TESTWRITE | DVDWRDAO | DVDWRVPW | DVDWRFPW | DISCATONCE | TRACKATONCE | WRITECDR | WRITEDVDR | WRITEDVD_RW | WRITEDVD_PRW | WRITEDVD_P_R | READCD | READDVD | ERASING | VARPACKETS
MEDIACAPFLAGS = CDR_74M | DVDR_3GB9 | DVDR_4GB7 | DVDGENERAL
READFLAGS = READCDDATA | READCDMODE2FORM2 | READCDAUDIO | READDVDDATA | READDVDROM | READDVDRW | READDVDPRW | READDVDP_R | READC2ERRORS | READSUBQ16AUDIO | SUBQ16BCD | SUBQ16INVERTEDCRC | READPOSTGAP | READSUBQ96AUDIO
WRITETAOFLAGS = FIXEDPREGAP | FIXATION
WRITEDAOFLAGS = MULTISES_DVDR | MULTISES_AUDIO | MULTISES_DATA | SCRAMBLED | DVDBURNPROOF | CUESUBCDTEXT
DRVGENERALFLAGS = 0
ERASEFLAGS = CDRW_DISC_TOTAL | CDRW_DISC_MINIMAL | CDRW_SES_TOTAL | CDRW_SES_UNCLOSE | DVDRW_DISC_TOTAL | DVDRW_DISC_MINIMAL
DRVDISCINFOFLAGS + DVDINFO
DRVWRITETAOFLAGS + WRBUSY_020408
DRVWRITEDAOFLAGS + CUELILOMODE | WRBUSY_020408 | SENDDVDMANUFACTINFO | WRDVDBUSY_020408
CDWRITESPEEDS = 4,8,10,16,24,32,48
CDWRITERWSPEEDS = 4,10,16,24
CDREADSPEEDS = 48
CDREADRWSPEEDS = 48
DVDWRITESPEEDS = 1,2,4,8
DVDWRITERWSPEEDS = 1,2,4
DVDREADSPEEDS = 16
DVDREADRWSPEEDS = 16

Hi i have a plextor 716sa drive and was wondering if this would work for my itunes in 7.02.16.How would I set that up .
also wondering if the above is soposed to be in “gcdrtype.cfg” or was it different in lower versions of itunes??
Thanks