It's dead. Yes. DW-56A Firmware

vbimport

#1

So I, being the genius that I am, decide that I will run the update and allow my DVD±RW drive to be “compatible with more typed of Blank DVD media”. This is an official “Dell sanctioned” update oh-by-the-way thank you.

I’m running an Inspiron 9300 on SVC pack 2 with a Sony DW-56A drive. Originally the drive was flashed with PDS3 firmware (or whatever the name is…) The update brings it to PDS7 and all of a sudden I find out that it will no longer recognize blank media of any kind, it just sits there spinning.

I found the older firmwares on this site:

http://codeguys.rpc1.org/firmwares.html

Downloaded and re-flashed to PDS6. No luck. Re-flashed to PDS3. Still no luck.

So what I want to know here is what the heck do I do? This darn thing worked only 48 hours ago and since I ignored the “If it ain’t broke don’t fix it” mantra, I’m screwed.

Any good suggestions here?

Thanks!


#2

Flash it back to pds7 from dell, then get a replacement drive. I have a 700m and it burns good media (TY) like crap. Cheap media will burn but can’t be read. I called Dell up and they are sending me another drive. Same results with PDS3 and PDS7 for me.


#3

What happened? The original ROM was PDS3 so why did this screw the drive over?

And why is it that I can’t reflash it with what was originally on there?

My best friend has this exact same computer and drive - can I extract the ROM he has and flash it onto my machine?


#4

Update:

Seems as though it won’t reflash to PDS3 no matter what I do. I extracted the ROM file from my friends 9300 using LtnFw and have tried flashing it on and using the “Update boot code” option.

Please please please do not tell me that I have to use MTKFlash to figure this out. Heck, I can’t even burn CDs to make a boot disk anymore.