Issues with Optiarc AD-7170S in Vista 32

First off my burner is recognized in Vista.
I have this burner, NEC Optiarc SuperMulti (SATA AD-7170A)
When I put a disc in from a clean boot it does recognize the disc.
When I try to access the disc it does pull up the table of contents.
However when I try and copy from the disc to my hard drive this is when it locks and does nothing.

Strange thing is if I put in a blank DVD and run Clone DVD I can do a copy as long as I do nothing else.

I tried the following and it is still not working

http://support.microsoft.com/kb/929461/en-us

My system specs are as follows,

ABIT AN52
AMD X2 6000
EVGA 8800 GTS 320
Creative audigy
WD 500 GB Sata II
WD 300 GB Sata I
Nec 3550 DVD IDE burner (set to master)
NEC Optiarc SuperMulti (SATA AD-7170A)

OS Vista Home Premium 32 bit

Any thoughts on what I need to try to get this drive to work ?
Or should I go back to an IDE burner?

Later,

X

Welcome to the forum.
Check your BIOS settings (IDE SATA section) and make sure RAID is set to off and the controller is set to standard rather than any enhanced mode.

Dee -

That was one of the first things I checked.
I did change it initially and Vista didn’t like that.
Changed it back to the IDE mode and Vista still hates this drive.
I tried different drivers too.
Vista insists on using it’s own drivers and not the nForce platform drivers.

Thanks,

X

any other general thoughts as to what I should do with this drive?
Any information needed that is missing?

I’m running out of ideas as to what to do with this drive.
Does it work better under windows XP?

I just got this and I’m running low on time to decide if I should send it back and ask for a new one.

Any help is greatly appreciated.

Thanks,

X

It could just be that the SATA controller on your motherboard (nVidia) just doesn’t like SATA optical drives.

Well I think I kinda figured that Dee.
I’m sending it in for an RMA to the Egg.
Any quick thoughts on a IDE burner?
I have a NEC 3550 and has performed flawlessly.
I was going to try a Lite On Sata drive.
But this issue makes me a little learly .

Thanks for all your input!

X

I forgot to mention,
I also tried atleast 3 different firmwares for this drive.
Some worked a little better but I still ended up with the same types of issues.
I was able to finally copy something to the hard drive.
It went something like this,

I put the disc in and it was read
I was able to navigate the TOC
I was then able to select a file and try to copy
upon doing this it still gave the same result.
the process timed out and eventually asked me to try again.
upon trying again it copied instantly and very quickly I might add.

So the drive does eventually work.
But it is to much of a hassle to work with.

Thanks,

X

P.S. Firmwares used 1.M 1.02 1.82 and 1.00
Drive shipped with 1.00

Ok the issue is closed!!!

I have had issues with Optiarc AD-7170S drive in Vista.
Basically it didn’t want to read correctly if at all.
So since it was a new drive and I exhausted all my options, I was going to return it.
Well I didn’t exhaust all my options.
I tried the drive in another computer that had 2 things.

  1. It had a SATA controller.
  2. It had Windows XP on it.

Guess what? The darned thing just worked!
So I pondered for a minute and pondered some more.
I then said why not and I deleted Vista and put Windows XP back on my system.

And with proper drivers and the usual tweaks (aspi) the drive just worked.

Same hardware just different software.
So this is definitely proof that Vista is the EVIL.

I should have known to stick with XP.

So I’m back and it makes me happy!

Just thought I’d share it’s NOT always the hardwares fault!
It might just be the software your using, especially if it’s Vista!

Thanks,

X

Dee and all members -

I have an update!!!

I tried Vista again on the same hardware as listed above.
Still the same.
I tried Vista with SP1.
Still the same.
I was about to give up again.
That was until I found this;

http://www.msfn.org/board/Integration-of-NVIDIA-nForce-Raid-and-SATA-drivers-t51140.html

To make a long story short it points to this set of drivers!

http://support.fujitsu-siemens.com/Download/ShowDescription.asp?SoftwareGUID=22CBB88D-44D7-4F4D-9455-84AEEC7AD91F

I don’t know if this has been posted here or not but these drivers do work!
It might not say MCP 520 but it works for them.

Thanks again,

XndeX