Issues Burning with LiteOn SOHW-1633S

vbimport

#1

Hey, all. Here’s to hoping I can get some help. :slight_smile:

I have a LiteOn SOHW-1633S DVD-RW burner. I’ve had the computer packed away for a few months; just got it out of storage today and went to burn some DVD’s. Had no problem using any media before; I purchased some Sony DVD-R’s and popped open Nero to burn a DVD that I’d backed up before I packed away the computer. I continuously got the infamous “Illegal Disc” error.

I figured it may have been the DVD’s, so I tried a Fuji DVD; same result. I tried to update the firmware using the flasher found here, but it told me that there was no SOHW-1633S found, even though it gave me a list of my optical drives and showed it.

Hoping someone can help. I haven’t gotten that computer online yet so I can’t post a burn log, but I’ll be able to if needed within a few hours.

Any help would be greatly appreciated.


#2

Probably your 1633 has oem firmware aboard right now, that’s why original firmware is not accepted. You need to use a flashfixed version of BS0Y. Then again, maybe the newest media will not be supported.
I suggest you crossflash your drive with the latest firmware for the 1653, CS0T.
This firmware supports most modern mediacodes. I’m using it for a year now with fine results.

:cool: Leo