Issue with USB DVD burner

vbimport

#1

Ok. I have chatted several times with HP thinking that it might be a problem with my PC. My problem started this morning when the power strip was kicked off. I started up again and now my MadDog external USB DVD burner is not detected in My Computer as a DVD drive. It is detected, but (in Device Manager) under disk drives as USB 2.0 Storage Device and also under USB Controller as USB Mass Storage Device. I have tried to update the drivers, but will no success. I uninstalled all USB devices, restarted and let the them re-install. Still same problem. When I turn power on/off or plug/unplug I get that beep when new devices are connect.

Everything was fine last night as I burned a few DVD’s. I have also tried switching to different USB ports, but still the same issues.

Any ideas??

I’m desparate.


#2

I would open up the enclosure and connect the drive to an IDE cable in the computer. This should tell you if the drive was hosed or just the chipset in the box. From there you can just replace the enclosure.


#3

Don’y know if you are still following this thread, but . . . I had exactly the same problem. Drove me nuts. I just called Mad Dog. (Only 4 minutes on hold.) Nice man told me to take disc out of drive, turn off drive, unplug USB cable, wait 10 seconds, plug cable back in, turn drive back on. And IT WORKED! Simple as that. (I suspect you really do not have to disconnect USB cable.)

He hinted that the drive has problems when turned on with certain discs in drive, but he would not elaborate. Anyway, works for me. I suspect you have solved problem by now.


#4

That did the trick. One of our users was having the same problem. I had removed the CD burner from the user’s desk and plugged into my computer. I did not use the power switch on the back of the burner. I still had the same problem.

With your advice, I turned off the power switch first and disconnected the USB cable. When I plugged everything back up and turned it on with the power switch, it worked fine. Thanks!

:smiley: