ISO options missing, interface different compared to Windows version

I have tried to burn a bootable “El Torito” data CDROM with NeroLinux 2.0.0.4. Following instructions for Nero provided on WWW was impossible. I could not set the ISO options:

  • ISO Level 2
  • Format: Mode 1
  • ISO charset
  • path depth > 8
  • path length > 255 chars
  • do not append ;1 to filenames

The dialogs are different compared to the Windows version, why? I assume that Windows and Linux versions are generated from one source base, are they not?
The ISO relaxation options are vital for me, so it does not work for me, and I cannot spend any money on it yet.

Another issue which is important as well: The fonts of the Linux version are not antialiased, which leads to suspicion about product support. Running ‘ldd’, I see that GTK+ 1.2 is used. I run GIMP 2 regularly without problems on Windows and Linux, and it uses GTK+ 2.x. With GTK-WIMP the applications have a native look and feel. It really is no problem to develop portably. Please do it, it costs you less in the long term. Some developers prefer wxWidgets for C++ development, for C++ there is a great GTK+ mapping available too: gtkmm. Yes, both run on Windows and on Linux. Ethereal uses GTK+ 2, it looks great on Linux and Windows!

I try xcdroast this time. But, I do not like the user interface of xcdroast at all. Usability and aesthetics are not valued in some parts of this universe.
Or I fiddle with mkisofs directly, not really a time saver…

But I will look for a review of a newer major version of Nero, and pay for it if it is comparable to the Windows version at least in options setting.