Is this a dead drive?

vbimport

#1

My LTR-32123S has never writen a bad disk… till now. Now when I try burning with Nero, it won’t finish. When I try with Alcohol 120%, it finshes, but disk either shows up as empty, or with 1 track that shows up as a .cda track, even if I’m writing data disc.
I never tried OC the drive, and had updated to the XSOZ firmware when it was first released. It worked with the XSOZ for a long time now. I read on this forum where the XSOZ gave faster reads with more errors. I already tried reflashing with the XSOZ, but it still writes bad disc. I tried flashing back to the more reliable XSOX, but the flash program won’t allow me to downgrade. However the drive reads disc ok.
Does this seem like a dead drive, and a waste of time?
Is there a way to downgrade to thye XSOX firmware?


#2

Sounds pretty dead to me. But you might as well see if it works with XSOX. To flash it use this guide:

http://dhc014.rpc1.org/howto.htm

and get the XSOX binary file from:

http://dhc014.rpc1.org/indexOEM.htm


#3

Thanks. It downgraded to the XSOX without problem, but it still won’t write disc. Oh well. I guess it reads disc ok. I made a image of Ghost Recon that seems to work. I’m gona get the LTR-52327S since they’re so cheap now.


#4

If you can wait a while you could get the SOHR-5238S.