Is there ANY new firmware for the Buslink 40x12x48?

Is there ANY new firmware for the Buslink 40x12x48?
The Windows Device Panel says the name is just plain old “CD-RW 48x12x48”!
My computer’s BIOS says it has firmware v1.05 and Windows says the same thing…
Is there ANY newer firmware I can upgrade to?
I can tell THIS IS NOT A BUSLINK Lite-ON drive since it doesnt have a lite-on model number(i wanted a liteon when I bought this cdrw and was tricked)… :frowning:
Anyone know where I can download new firmware for this crappy cdrw drive? Thanks!

That’s an interesting Device ID. Would you try backing up your firmware with mtkflash just to see if it works. If it does, send me the binary file and I’ll take a look. Did you really buy a 40x12x48 drive and receive a 48x12x48 version?

hi all;

*** RE-awakening an older thread - same issue ***

I have the exact same drive (i think) - Not working

– Specs (as best as i can determine)

  • Buslink USB 2.0 CD-RW Drive 40x12x48 (CompUSA/BestBuy crud - given as a gift to moi)
  • Made: in China
  • D41039 on Barcode on paper sticker stamp on drive
  • Model: (only says -> 40x12x48)
  • Manu: May 2002 J
  • AOpen Inc. ?? just found this on sticker, printed in very, very, tiny bolded letters, then chinese/taiwan address below ??

– History;

  • Came in External Case (USB 2.0 Drive) - has External Power Source, etc
  • Worked fine INSIDE External Case for over 1 yr, but s-l-o-w- (USB 1.1 mobo Intel 440bx, PII 350/FSB100, Win98)
  • Yanked it out of Case (for SPEED :)), installed it as Secondary Master – Worked Fine for months (burns at 32x)
  • Tried Rearranging every possible IDE config PM,PS,SM,SL
  • It pooped out on me after leaving a linux Boot .IMG only file burned CD (5MB) in the drive…made/used Nero 5.5.10.x CDROM Boot

Image File = C:\mini-knoppix-iso.img (or somesuch)
“CD-ROM(Boot)”
No Emulation
Load Segment Of Sectors = 0000
Number of loaded sectors = 1
(? - don’t recall atm)

…well

  • It booted to a nothing screen, then no workey no more
  • It even came with a USB 2.0 Driver CD, which i had hoped would help - just re-installed it now, but n-o-o-o-

and since it’s not in the external case, i guess not too well – the install CD installed drivers fine (.PDR, .INFs, \IOSUBSYS and \SYSTEM), but the “components” themselves that I recall being listed in DM like “TPP Storage Bridge Adapter Module” that was previously listed in Device Mangler, before being made Internal drive, under Intel 82371AB/EB IDE Busmaster Controllers (beneath Secondary Controller) is not showing up.

Here’s a PCWorld link about the drive (may be slightly diff drive, since I do NOT see “Buslink RW4048” anywhere at all). I have the Orig. Box, Manual, Driver CD, Case, everything. BTW, the Driver CD Readme.TXT says to install for 98SE only, XP has it’s own (i know that - and it WORKED fine previously but at 1.1 speeds b/c of Mobo limitation - no USB2.0/PCI Cards installed)

Attached is the Nero Info tool

I hear the drive spin up - it seeks weakly, (LED blinks a few quick times, then stops) - then seeks (same thing again, then stops) THEN, the LED finally just constantly FLASHES at me - taunting me :stuck_out_tongue:

(when it worked, it sounded like a freakin Helicopter and Airplane both taking off at the same time :eek:) - but nothing like that now. I’ve tried Win98 OEM Boot CDs, all combos of Burned CDs and Boot CDs - nada, zippo. Explorer gives the usual error “Device not accessible, device not ready” (usual crap). I tried CDSpeed(3.61) DriveSpeed, BurningROM (all Nero 5.5.10.56? stuff, except CDSpeed), just to see if it could read Any data on a CD - only thing

FIRMWARE fix ??

thanks for your time in advance :clap:


Looks dead to me…

:bigsmile:

oh - yeah - forgot to mention; all IDEs (1 HDD, 2 ODD) have DMA=On - including this POS.

just for kicks - i’m going to throw it back into that Enclosure and use the external Power and see what up (old lowly PSU i have atm in that box) - I would’ve done it before, but 2 things - i don’t want 1.1 speeds :Z - and it’s a PITA to put back into dumpy enclosure.

The ONLy reason i think there’s hope is my 1998 Toshiba DVDROM III exibited somewhat similar and varying odd behavior over the last few months (wouldn’t do anything, then played only CDs, no DVDs , tray stuck in Open position, etc), but I re-Frankensteined it :bigsmile:, by 1st, Opening it to expose it’s guts and checking under the hood, 2nd by Spanking it’s bottom (literally) – but now 3rd, via flipping it over everytime i pop in a CD/DVD (it’s hanging precariously off the side of the case, and rests on some makeshift donnage :eek:) - and it works fine – talk about your “interactive DVD-ROM”

man am i thick-headed, and i know new ones are s-o-o-o-o cheap

…and :Z

still constant dang “Blinking green LED” - no real “spinup” (no airplanes)

.But atleast all the stuff i said about the “Storage Bridge Adapter Module” now appears in DM (as well as “USB 2.0 Mass Storage Device”) - system still functions nicely :wink:
(pics posted in case some other poor sap finds this thread)

i may have to Sledgehammer this pos - perhpas take pics :wink:

BTW - at this point I’m willing to try ANY freaking “firmware” - any ideas at all about which one/s? – atleast i can brush up on my flashing abilities
(note “In-Design” in the driver files propertie’s dialog - but as i stated “AOpen” way above)



decided to follow up on http://dhc014.rpc1.org/howto.htm
posted earlier - and
FWIW - now i took it totally apart - and it has RICOH chips (and others), not MediaTek though