Is NCQ an issue? HDD problems

vbimport

#1

My friend gave me his HDD to test it before I can buy it. It’s WD2500KS SATA.

I plugged it into SATA with no jumper, so it is in slave position. I assume this HDD has NCQ support. The U-DMA setting keeps going low till it drops to PIO mode. I googled the thing and I ran across this: http://www.ntcompatible.com/SATA_Hard_Disk_going_PIO_Mode_t31322.html

I wanted to defragment the disk since it is 15 % fragmented on both partitions but the operation slows down in a matter of second, sometimes even my computer crashes.

Is there anything to avoid NCQ so I can use it properly? He’s selling it really cheap and I need extra capacity asap. :wink:

Thanks!


#2

The IDE portion of your device manager should have a checkbox for NCQ in it, mine does for the Nvidia drivers I use, turn it off and see if the drive works OK after that.
My controller picked NCQ mode for a OLD 80 gig IBM I have and it would lock up the whole machine the minute I tried to access it.
Is fine and stable now that I figured that out and unchecked the box.


#3

WD without jumper is master without slave present!


#4

I’ve found the jumper setting for SATA 150 only but the problem remains the same.

After reboot, both drives are Ultra DMA 5 but when I write to WD2500 it keeps going down till it drops to PIO or my computer freezes.


#5

Sata and pio mode??


#6

Aha … Well, I discovered something - I turned the jumper around and it works in SATA 150 mode.


#7

You mentioned the drive being slave, which helped me to forget that you also said that it’s a SATA drive before. :doh: Sorry for that. :slight_smile:

No master/slave with SATA! :disagree:

I bet your drive is built in in a way that you can’t read the top of the drive. So here it is, the WD SATA jumpers:

No column jumpered:

  • Spread Spectrum Clocking disabled
  • SATA300

First column from the power connector jumpered:

  • Spread Spectrum Clocking enabled
  • SATA300

Third column from the power connector jumpered:

  • Spread Spectrum Clocking disabled
  • SATA150

First and Third columns from the power connector jumpered:

  • Spread Spectrum Clocking enabled
  • SATA150

:slight_smile:


#8

I know that SATA devices do not require master and slave setting but two HDD’s are plugged into different SATA connectors, right? Well, in POST screen you can always see master or slave even though it’s virtual.

Well I jumpered the disk as the diagram on it shows - pins 5 and 6 joined for SATA 150 only. That’s the only choice in my case.

It works fine now. Is there any tool besides Sandra to benchmark HDD? Everest maybe?


#9

I’ve also 2 SATA drives connected, but they never showed anything regarding master or slave. It just doesnt existwith SATA.
Must be your BIOS.


#10

No, you both are correct. Some BIOS show “virtual”, like Sodom said, master and slave lines, some don’t!

I’m not exactly sure about it right now, but it also could be dependent of the “AHCI”-“RAID”-“IDE” or the “Ports 0-3 Native SATA Mode” diasabled/enabled BIOS settings (as I have learned here, the Ports 0-3 setting is, that no IRQs are given to the drives on ports 0-3).


#11

Hard drive benchmarks are almost universally worthless. That said, if you want a file-based benchmark, ATTO disc benchmark is good. Most of the others are just sustained transfer measurements over the entire drive. HDTach is another popular one.

Any of them are adequate if you just want to check that the drive is close to specs.