Is my GWA-4162b drive dead?

vbimport

#1

Hey everyone, I couldn’t stand the lack of PCI-express port on my HP PC anymore, so I got a new Case, Motherboard, and Video Card. Transferred over all the components to the new case (CPU, Memory, Drives, Etc…). Well now the HP DVD 640b (GWA-4162b) drive doesn’t work.

It is detected in Windows, and it is assigned a drive letter, there’s no exclamation points next to it. However when I put a CD or DVD in, it just blinks stops, and shows no DISC. Does this with all the discs I’ve tried, there’s also a samsung cdrom in the computer which works fine. I tried everything, changing the IDE cables, the IDE position, Master, Slave, Cable Select…Used Nero Info Tool to see if it detected the drive which it does.

I did bang it a little bit (not a lot when installing it into the new case… (took a while to figure out my antec case). I’ll toss it in another PC in the house tomorrow, I can’t put it back in the HP because I already took the processor out.

Thanks Everyone!

p.s: i’m the one that took pictures of the 640b a while back
http://club.cdfreaks.com/showthread.php?t=126777&page=2&pp=25