Is my EEPROM toast?

vbimport

#1

Greetings. When I say EEPROM here I am referring to the actually chip that takes programming.

I have flashed my drive about 10 times. It is currently a 401s @ 811s HS0Q.

Never one to leave a good thing be, I thought I would try the readspeed hack.

It looks like I can no longer flash this drive !?! :frowning: I tried previous firmware using ltnflash 1.24 and liteon’s exe’s. It says programming, gets to the end and locks up completely, requiring reboot. Fortunately nothing changes and I am still with a fully functional unit! I tried dropping to PIO. I am using SIS chipset not VIA. Both flashers just freeze up regardless of the BIN I am trying to use.

Thanks for any help!


#2

This has nothing to do with your EEPROM.

If firmware isn’t even getting changed, then there’s an interface problem here. Probably ASPI-related. I don’t have much experience with ASPI-troubleshooting, so I’m just going to recommend that you book into real DOS mode and use MtkFlash.


#3

Agreed

If your eprom was toast then your drive would not work


#4

Thanks guys. I started with “When I say EEPROM …”

This is because technically when you write firmware you are writing to the eeprom are you not (electrically erasable programmable read-only memory) ???

I will try a clean ASPI tonight.


#5

If the drive is recognized in Windows, it should be flashable in Windows, but DOS is a sure thing.Try setting boot code.


#6

Try LtnFW. It seems to work better than LtnFlash…


#7

@buttlik
No, You are NOT. EEPROM (code) is stored in EEPROM (electrically erasable programmable read-only memory)
Firmware (that modified piece of code you patched with readspeedhack) is stored in Flash ROM. Upgrading 1MB of EEPROM would take a week!:slight_smile: