Is ASPI LAYER required

Hi everyone,

Apologies for the probable inanity of this question, but what do ASPI layers do? I keep seeing this as a solution to CD Audio problems, but when I run Aspichk I get a red box on the left, N/A marked on all items, and a note saying that I need to instal newer version.
ForceAspi, which also seems to be promoted, doesn’t change this at all, and all the files seem to be 1999 vintage.

I’m running XP on an Athlon 1900, 512 ddr, with Nero 5.5.9.14 and wmp9. SB Audigy with Creative. Asus A7V333 ACPI

Reason I’m trying is non recognition of CD-R as CD-R but rather as CD-RW (also with a couple of PC supplier Support disks). Recognition will normally take place after several eject/load. Also dual layer SACD (Sony Audio) will not load at all. Additionally up to 100 Buffer underruns on each burn.

Same happens on both CD-RW and DVD-ROM drive (Generic BP1700/Toshiba SD-M1612), so I assume, in my non technical fashion, that it must be a software/driver problem. (I’ve tried uninstalling Drivers and reloading but no difference)

Any help on the above also gratefully received

Thanks:)

ASPI stands for Advanced SCSI Programming Interface. Originally developed by Adaptec. It is a software layer that enables programs to communicate with SCSI (and ATAPI) devices.

Generally istalling an ASPI layer is not necessary unless you wanna use a program that requires it. If so i would recommend v4.60 which seems to create the least of problems.

if Aspichck reports back in red background, this means that your ASPI layer is not properly installed and you need to reinstall it. If it was 4.60 previously installed, a simple reinstall over the old one will do the trick just fine (worls for me)

Thanks for this.

Where is the best place to get a download of 4.60.? I’ve tried forceaspi, but this seems to make no difference. A large number of sites also appear to have forceaspi blocked.

Might this aid my CD problem?

Thanks again

Force ASPI 4.60 (As Far As I Know the most used/reccommended/stable version) is available here

Thanks for your help. Ive tried Force Aspi 4.60 as suggested, but it makes no difference on the Aspichk. It states ’ one or more components have been replaced by older versions of the software’, although it does now show WNAspi32.DLL.

One thing a bit puzzling - the WNAspi32.dll loaded by ForceAspi is dated 1999, and is 44KB. I have another WNAspi32.dll on my system, under Nero, which is dated June 2002 and is 128KB.
What’s going on? Is my Nero version corrupted, or is it actually an update to that on ForceAspi?

Thanks

(Still have the CD problem! Am going to run XP Service Pack 1/1a soon to see if that cures it)

Nero come with its own aspi (and yes it is 128kb) - there’s no need for adaptecs aspi. If you dont have any specific reason for having it, just uninstall it.

If you wanna stick to Adaptec’s ASPIs though, try downloading the ASPI’s from the page from my sig, execute it and do a reboot. Check with aspichck afterwards to see if it is all “green” :wink:

Thanks for your help - if not needed maybe I’ll leave for now

Just hoping that XP Service pack cures my CD-R problem!

:slight_smile:

I know this is an old thread but it is kinda relevant to a question I have been trying to find an aswer to for some time.

Everywhere I look recommends loading ASPI 4.60 which I have done. But when I try to select ASPI in DVD Decrypter no devices are found. Why doesn’t it work?

Also, does ASPI create better rips than the default SPTI? If not, why is it recommended so much?

Thanks in advance for clearing this up.

Nope. SPTI is just the standard coming with the OS and ASPI uses “advanced commands” to give you better overall results.

I’d recommend FORCEAspi 4.60.

Post #16 from [I]spath[/I] in this thread is very informative on this topic IMO.

Regards, :slight_smile:

ET

Yes, ET. I also learnt something new today which is always a good thing. :wink: