IOMEGA Screenplay Director: DVD Sutitles

vbimport

#1

Hello,
This is my first post in this forum to clear couple of doubts related to my IOMEGA Screenplay Director 1TB which I recently bought.

First Question:
Can we play DVD movie file (.vob) along with the SUBTITLES (When IOMEGA is connected to TV)?
I copied a DVD onto my IOMEGA (AUDIO_TS and VIDEO_TS folders) and I am ABLE to play the .vob files present in the VIDEO_TS folder. But its NOT showing me the subtitles for the movie. Is it possible to enable subtitles while watching the .vob copied in IOMEGA just like we do on any other DVD player? (I am sure the DVD movie that I copied has subtitles coz when I watch it in my DVD player I am able to enable the subtitles)

Second Question:
I have some .avi video files that were recorded by my Canon Powershot S2 IS digicam. After copying these .avi files onto IOMEGA and tried to play them, it says format not supported :frowning: What could be wrong, afterall its AVI file.!?!

I am eagerly looking forward for your answers.
Thank You

  • Vikas DK

#2

[QUOTE=vikaskulkarni;2486754]Can we play DVD movie file (.vob) along with the SUBTITLES (When IOMEGA is connected to TV)?[/quote] Yes

I copied a DVD onto my IOMEGA (AUDIO_TS and VIDEO_TS folders) and I am ABLE to play the .vob files present in the VIDEO_TS folder. But its NOT showing me the subtitles for the movie. Is it possible to enable subtitles while watching the .vob copied in IOMEGA just like we do on any other DVD player? (I am sure the DVD movie that I copied has subtitles coz when I watch it in my DVD player I am able to enable the subtitles)
See this iomega support page

I have some .avi video files that were recorded by my Canon Powershot S2 IS digicam. After copying these .avi files onto IOMEGA and tried to play them, it says format not supported :frowning: What could be wrong, afterall its AVI file.!?!
This particular .AVI format may not be compatible with your IOMEGA. See this iomega support page… again…

If you want to know what kind of formats your device can handle, check out this iomega support page … yet again…


#3

Thanks a ton Mr. Belvedere. I am sure ur solution is going to help me. The first thing I am going to try is play DVD on my IOMEGA soon after I go home now. Thanks again
:bow::clap::cool:


#4

Hello Mr. Belvedere, I went back home with full enthu to see my dvd is playing with subtitles on my IOMEGA. But :confused: it didnt.
I could see the option in the Menu for subtitles, but when I select subtitles, it gives me two options, OFF and UNKNOWN, I was expecting it to show ENGLISH instead of UNKNOWN. Still I selected UNKNOWN, but subtitles didnt render during the play. I dont know if its the problem with IOMEGA or the DVD files that I copied. I have all the .ifo files and the .vob files in the same VIDEO_TS folder.

Any help is highly appreciated.
Thanks


#5

[QUOTE=vikaskulkarni;2487079]Hello Mr. Belvedere, I went back home with full enthu to see my dvd is playing with subtitles on my IOMEGA. But :confused: it didnt.
I could see the option in the Menu for subtitles, but when I select subtitles, it gives me two options, OFF and UNKNOWN, I was expecting it to show ENGLISH instead of UNKNOWN. Still I selected UNKNOWN, but subtitles didnt render during the play. I dont know if its the problem with IOMEGA or the DVD files that I copied. I have all the .ifo files and the .vob files in the same VIDEO_TS folder.

Any help is highly appreciated.
Thanks[/QUOTE]

UKNOWN is usally present when you have made a backup of a dvd or are using an illegal copy of a dvd video. Unknown usually takes place when someone removes all unapplicable subtitles (for instance, removed subtitles 0, 1 and 2, but kept 3). This will result in errors and not showing the dvd on some devices.

Try an original backupped (so 1 on 1 backup, no removing videos or subtitling) DVD with subtitles. Check if this original DVD video has the same problems.


#6

Hello Mr. Belvedere,
Yesterday I copied ORIGINAL DVD movie to IOMEGA but unfortunately its still NOT playing the movie with subtitles. Its still showing UNKNOWN in the subtitles list.

FYI:The Orinal DVD movie is actually in 5 different languages (I mean the audio language), so my IOMEGA is showing the languages and if I select the languages, its luckily playing the movie in the selected language even though the list of available languages is displayed as UNKNOWN.

But I am wondering why my player is not able to pick the subtitles :confused:


#11

[QUOTE=vikaskulkarni;2487373]Hello Mr. Belvedere,
Yesterday I copied ORIGINAL DVD movie to IOMEGA but unfortunately its still NOT playing the movie with subtitles. Its still showing UNKNOWN in the subtitles list.[/quote]

Hmm, interesting. Do you happen to know if there is a firmware upgrade possible for your Iomega device?

The Orinal DVD movie is actually in 5 different languages (I mean the audio language), so my IOMEGA is showing the languages and if I select the languages, its luckily playing the movie in the selected language even though the list of available languages is displayed as UNKNOWN.
Do in a dvd player the normal language titles appear (Arabic, Dutch, Swahili, Finnish, etc). But in your Iomega device it shows Unknown, Unknown, etc.

But I am wondering why my player is not able to pick the subtitles :confused:
I wonder as well. Perhaps it is time to ask the question to Iomega themselves.