Iomega DVDRW8440E2D-B Firmware?

vbimport

#1

Hi all,
My friend has the above DVD burner. It came with FW US01. Am looking for any updated firmware for the drive coz’ it isn’t recognizing a few good DVD+RW media. I vaguely remember seeing somewhere that the drive is a Lite-On rebadge but am not sure whether it is and if so what model of Lite-On. Any help would be gr8ly appreciated.


#2

Go here:
https://iomega-na-en.custhelp.com/cgi-bin/iomega_na_en.cfg/php/enduser/cci/subproduct.php?p_prod_lvl1=5&p_sid=WPjMB-Mh


#3

Iomega’s website is difficult to navigate, and unfortunately, I have always been unable to get anything useful out of it. The only firmware updates that they list are for LG drives, even though there ARE LiteOn-based Iomegas out there (they just never mention them :doh: ).

Anyway…

The best way to find out if a firmware is a LiteOn or not is to try to back up the firmware with LtnFW. If the backup works, then it’s a Litey. If it doesn’t work, then it’s something else. Please attempt a firmware backup (and please send me a copy of this firmware, if it is successful).

Info about LtnFW can be found here: http://dhc014.rpc1.org/howto.htm#LtnFW


#4

Oh, OK. Thx. for the info, code. Will try the FW backup tomorrow and post it if successful.


#5

Hi code. LtnFW worked !!! Have sent u a PM containing a link to the firmware.


#6

Thank you! I got a copy of the firmware now. :slight_smile:

So the firmware is UOS1 (that’s an O and not a zero)… it’s a SOHW-812S drive, so you can use either 812S or 832S firmwares on it. This is a pretty old firmware (over 18 months old!), so it will probably be a very good idea to update it to something newer, like US0Q or VS0G. Remember that if you choose to use a 832S firmware, you will need to follow crossflashing procedures (not necessary if you decide to go with a 812S firmware).

Drive type             : SOHW-812S/802S
Vendor ID string       : IOMEGA
Product ID string      : DVDRW8440E2D-B
Standard firmware rev. : UOS1
Internal firmware rev. : UOS1
Firmware timestamp     : 2004/02/27 14:23

#7

Thx. m8. Appreciate the info and glad to be of help. :smiley:


#8

Hi code. I did the firmware upgrade to US0Q making the drive a 812S. I’ve a problem. Am posting SS of DVDIdentifier and Nero InfoTool being able to detect the DVD+RW properly but Nero failing to burn the disc.


#9

Hmm… the media that you’re trying to use, MBIPG101-W04 is a media code that was just added in US0Q (all the 812S firmwares before US0Q do not support this media code). As US0Q is the first 812S firmware to support this media code, I wonder how reliable that support is… anyway, here are a few things to try…

1/ First off, have you tried burning this disc using another app, such as DVD Decrypter or CD-DVD Speed? Have you tried erasing the disc?

2/ You might want to try using VS0G (or even CG5G), as these firmwares are about 5 months newer than US0Q, so hopefully, they might have better support for this media type.

3/ If the first two suggestions don’t work, then I would suggest that you use the EEPROM Utility to make a backup of your current EEPROM (so that you can undo this if you want) and then use the “reset learnt media” function to reset the drive’s learned laser calibrations. This has been known to sometimes help with burn issues that occur after upgrading from a very old firmware to a fairly new firmware.


#10

I tried the VS0G and it didn’t recognize the disc at all !!! Will try CG5G and post results tomorrow. Thx. for all the help m8.


#11

Hi code. Also tried the CG5G FW. Still the drive does not recognize the Moser Baer DVD+RW. Also tried resetting Learnt Media using EEPROM after backing up the EEPROM. Still the same. Also, I’ve a disc which is a Vanguard. It’s a DVD-R and the drive fails to recognize that disc too. I’ve already had problems with the Vanguard disc failing to burn in my burner - 1673S. Even trying the 1673S to 1693S didn’t make any difference in my drive. So will try other quality media and post results here.

Sorry to go OT but if u can just go thro’ the following thread where my problem is posted.

http://club.cdfreaks.com/showthread.php?t=144175

Also, since the DRU-720A is a rebadged 1673S, I think that burning the Vanguard disc in my drive should never have been a problem but it was a problem.