Iomega dual format burner -- not detecting DVD media after FW flash

vbimport

#1

I’ve got an IOMega 4216 (dual format, 4x burner based on NEC 1300). I had the modified 1.21 firmware (herrie’s) and all had been working fine, except for the fact that I can not successfully burn one CompUSA (Princo) -R media, so I thought I’d upgrade to the 1.22 firmware. I did the flash in Windows, and all seemed to go well. However, now the DVD Identifier will not detect ANY blanks (’“Unable to initialize disc - not ready - medium not present”), and when I try to burn a DVD in Nero 6.0, the drawer ejects and it asks for blank media. The drive itself is still detected by Nero, though, and it shows up as usual in device manager. Also, I was able to play a commercial audio CD in the drive. I tried flashing the drive back to firmware 1.21, but the problem persists. Rebooting has not helped.

I’ve been able to burn CD-Rs on the drive. This afternoon I flashed it back to 1.21 (hacked) firmware in DOS this time (did it it Windows last time). Still not recognizing DVD-Rs (or RWs) I insert. When I try to burn anything in Nero, it just ejects the disc.

I’m running Win XP Home on a P4 2.2 ghz, with a Lite-on 52x CD-RW as the slave.

Did I ruin my burner? Does anyone know how I might be able to fix this?

Thanks!!