Internet Explorer slow on Windows7

vbimport

#1

Hello,
Recently, I installed Win7 on my friend’s computer. Everything was fine, except that Internet Explorer would not start quickly. i applied all the updates, without any result. Then I upgraded to IE9, but the problem persists. I installed Mozilla Firefox, and there is no problem with that.

Then I found this: If I try to open IE with the modem disconnected, it starts up real fast. But when the modem is turned on, it takes a really long time to start. It won’t even load offline pages. Why so?


#2

Please try this.


#3

[QUOTE=Mr. Belvedere;2598900]Please try this.[/QUOTE]

But isn’t this for Windows XP/


#4

It is actually for Internet Explorer which is a separate program, a lot people forget that.


#5

I tried this solution, but there is no improvement.

I forgot to add one thing: the problem is in getting IE opened. Once it is open, there is no problem in browsing or downloading. But if I start it again, the same problem recurs. As long as I keep it open, there are no problems.


#6

Sounds like it is looking for the modem connection first, you need to tell it not to.

Go to Tools \Internet Options\Connections and click on Never Dial a Connection


#7

[QUOTE=bean55;2598924]Sounds like it is looking for the modem connection first, you need to tell it not to.

Go to Tools \Internet Options\Connections and click on Never Dial a Connection[/QUOTE]

Never dial a connection is already enabled. (But it is greyed out).


#8

Just found this:
Went to LAN Settings under Tools \Internet Options\Connections,
and disabled Automatically detect settings, and it worked! Now it is blazing fast! In fact, it is even faster than Firefox! :cool:
Obviously, it had to do something with the LAN settings. What do you say?


#9

This smells like some forced policy or some strange ip configuration.


#10

[QUOTE=Ayiramala;2598928]Just found this:
Went to LAN Settings under Tools \Internet Options\Connections,
and disabled Automatically detect settings, and it worked! Now it is blazing fast! In fact, it is even faster than Firefox! :cool:
Obviously, it had to do something with the LAN settings. What do you say?[/QUOTE]

That was going to be my next suggestion.

Glad you got it worked out.


#11

[QUOTE=Mr. Belvedere;2598937]This smells like some forced policy or some strange ip configuration.[/QUOTE]

Actually it sounds like whoever installed/reinstalled the OS on that specific
computer didn’t have a NIC cable connected while the windows installer was running and then had to manually set up the network connection and screwed up slightly.

I say “slightly” because it DID work… sorta…

AD