Internal buffer problem, nec 3500

vbimport

#1

Feels like i have tried everything but the internal buffer goes down several times on a burn, it does not matter if i burn at fixed speed 4x or 6x or 8x and so on.
(Havent seen it yet on a cdr burn though)
I have tried several brands but i mainly use Verbatim -r 8x.
My hardware is Amd barton 2500+ on a Abit NF7-S v2 with latest bios (even tried with older bios) and i have tried with and without the nforce ide-drivers and changed ide-cable.
Using Maddog 2.F8 firmware.
Atm im using WinXP Sp2, but i used Sp1 erlier but same problem.
I have several hds and i have tried to burn from them all but still same problem, i even have some scsi hds but same problem, the read buffer is at 100% all the time though.
Wierd thing though is that i had a Lite-On 411S on the same spot before and no problem then.
Hardware error maybe but i have tried a friends Nec 3500 in my system and i got the same result.

Any ideas? :confused:


#2

Search button is your friend… :wink:

Make a search on; 3500 buffer and you will get many answers.

BTW, my buffer is also “jumping”. :cool:


#3

Sorry but i did some search but it feels like everyone is talking about read buffers not device buffer or are very confused about what they are talking about :sad:
How come on my friends computer the internal buffer (device buffer) stays stable and when i use his drive in my computer it goes down.
And another thing, the other threads i have read it seems that ppl is talking about when it changes speed from 4-6-8x and so on, but for me it goes down several times on a fixed 4x burn.


#4

you have buffer underrun issues. Check your DMA settings on your drive and make sure it says UDMA2 and not MULTIWORD DMA. Seems a common issue with this drive and some controllers to recognize it as multi word instead of udma. That would cause slowdowns in burn. My addon sil 0680 ide contoller will not recognize the 3500 in udma mode no matter what I tried. my nvidia mboard ide controller luckly does though.


#5

Hi Jamos,

I have my ND3500A connected to an addon siI 0680 ide controller; so, it’s stuck to Multiword DMA. Reading your comment, I see it’s a normal issue with this model and some ide controllers.

So my questions are:

(a) After 2 months ( :wink: ) … Have you found a way to achieve UDMA2 in this addon Silicon Image IDE controller? I assume the more likely answer is NOT, so you gave up and NEC keeps connected to MB IDE: right?

(b) What is the maximum speed (read & write) you achieve when the ND3500A is connected to the addon SiI 680 ide controller?

My questions arise because I achieve max speed 11x aprox (equal read or write) under these conditions.

In my case, this means burning @12x is not ‘real’ and some kind of fallback is done by the NEC under these conditions; for example, only at the middle of a DVD disc a max write speed of 10x is observed in a narrow band’ (as reported by DVD decrypter), RiTEK G04 with LD V2.18 beta3 (4x -> 12x)

System: AMD Athlon XP 1700+, MB ECS K7S5A, OS Win2k SP4, 512 DDR; 2 HD’s each one connected independently in MB IDE buses.

Note: I have 2 other optical drives (Liteon LDW-811s & combo SOHC-5232K in the same addon SiI ide controller, but I think they don’t make a differece, when trying the multiword DMA of the NEC unit). I achieve perfect 16x reading with the combo, so, there are no limitations considering PCI bus bandwidth, as far as I can understand).

Thank you in advance for any comments regarding this NEC behaviour.


#6

Try connecting the NEC as a slave to the hard drive. It’s not the optimum setup, but it may give you DMA mode 2.


#7

Thanks for the reply…

I already had the NEC connected to MB IDE bus 2 months ago, working finely @ Ultra DMA, achieving full 16x reading, etc, etc. Maybe I change it back, but not now…

Really, my post is just to know a bit more about this specific NEC issue (i.e., enabling DMA connected to addon PCI Silicon Image 680 IDE controller); for example, BIOS update, some kind of configuration utility or so.

I prefer leaving all optical units at the PCI bus, thinking it’s a more practical/efficient configuration:

Hard disk1: master, MB IDE primary, supporting Win OS, temp files/swap
Hard disk2: master, MB IDE secondary, supporting data-to-be-burned :slight_smile:
DVD burner: master, addon PCI-IDE controller (Silicon, of course)

Under no circumstances I would connect HD’s to add-on PCI-IDE controller, despite the fact it is their main purpose :wink: . There are enough devices in the PCI bus just to add a new ‘permanent’ competitor (HD’s) for its bandwidth. On the other hand, optical drives are more ‘sporadic’ users of this bandwidth.

By the way, I want to thank again NEC for this wonderful, and Liggy & Dea for their modified firmware. I show below a transfer rate of a DVD-R Ritek G04 burned @8x with the NEC. The Liteon combo 5232K (NK0E, hacked for 16x) is the reader. Both connected to Silicon Image… :slight_smile:



#8

Just wanted to add a typical transfer rate profile using the NEC unit as the reader, connected to this add-on IDE controller. Pay attention to the bottom right corner: burst rate 14-15MB/s typical, as opposed to Liteon 5232K (31MB/s) in the same controller. Some advantage would have a Litey :slight_smile:

So, 14MB would explain the 11x write/read limit, … right?

One more comment: I highly recommend this NEC unit: it burns anything and it burn it the right way… :bow:

This multiword DMA issue is just a gray dot in a white/shining wall :slight_smile:



#9

Well,

Upon reading several threads about this common issue (Furballi, Inertia, hellbitch among other ones :slight_smile: ) I have decided to change back the NEC 3500 to MB secondary IDE as master, leaving the ‘data’ HD (Western Digital 160GB) as the slave. Of course, UDMA re-appears, as expected.

Transfer rate tests now exhibit a profile very similar to the Liteon 5232K, i.e., upto 16x read speed, 26+ MB/s burst rate, and CPU at similar lower values (directly related to DMA, as we know).

Performance of HD (normal operation) is not degraded, more considering NEC writer/reader is normally off :wink:

Determining (Nero) maximum speed for burning a DVD disc using that slave HD as the data source for the NEC master (same IDE bus), a value of 34x is shown, so NEC could easily burn at 16x, just ‘yawning’. Tested a Ridisc Ritek G04 (top silver / magenta) at 12x writing using V2.18 Liggy-Dea v2 (beta3, yet) and effectively the burning is cleaner (no 10x-11x clamp) and final PI/PIF is cleaner. Transfer rate test (Nero) = 16x, both NEC reader or Liteo 5232K reader.

I assume the master / slave affair is almost negligible, except in the case (not the current one for me) when 2 optical drives are in the same bus, one as a data-source, the other as the writer. In that case (own experience with CD’s / VCD’s, old PII mobo), the data-source CD drive [potentially slow?] should be the… master; the writer (slave), sporadically would use the seamless-link, burn-proof or whatever brand-name is assigned to this function :slight_smile:

By the way, only to add that connecting the master device to the outer connector of the 80-pin cable is a ‘best practice’ because in the case you disconnect the slave unit (e.g, for repair), the master [leaved temporarily ‘alone’] will not suffer electrical signaling problems if connected otherwise :slight_smile:

Bye (& thanks, Furballi)


#10

Have the fucking same problem at the moment with my Nec 3500A with 2.18 firmware :sad: . But my NEC is straight on the primary IDE controller of the Mainboard (Asus K8V SE Deluxe) using a 80 pins ide cable and connected as the only device on the end of the cable (jumper @ master). In Windows XP SP2 using the microsoft drivers I can see that the primary and secondary controller are using Ultra DMA Mode 2. I am using Arita 4 speeds DVD media (Ricoh atip) and burning at 4 speed fixed. Getting 3 or 4 drops of the fucking device buffer. Btw had a Philips DVDRW416K (=Nec 1100A) and had no problem at all burning on 4 speeds, a rock solid internal device buffer.

If someone have any suggestions on how to solve the problem I want to hear it from you :bow:


#11

you can start by cutting out the swearing, then read this http://club.cdfreaks.com/showthread.php?t=120934#features-bufferjump


#12

I still have the same problem, tried everything… Even tried a 3520 with same result and another 3500.
Changed cables and reinstalled windows/drivers and tried several firmwares but nothing helps.

And once again i have to get ppl to understand, its only the internal buffer that goes down to 0% and works its way up again and yes i have tried several brands of media, mostly i use verbatim 8x both +r and -r and some tdk and it does not matter if i burn at 4x or any other speed.

Clearly its a nec problem because i have tried a pioneer and a lite-on and no problem.
Im going to change to a pioneer or a plextor(sata) now, sure the burns is ok but it takes alot longer to burn a dvd this way.


#13

a picture speeks a thousand words, post a snap shot of your buffer problem so no 1 is confused.


#14

@Yawn, I have the same problem man, am also talking about the device buffer that is going to 0% and then goes up again. Going to send an e-mail to Nec Support and lets see what they tell me.


#15

the internal buffer drops to 0 every time the write speed changes.
this is normal for the NEC 3500 and not a fault.


#16

The link of acko is the right answer :slight_smile:
http://club.cdfreaks.com/showthread.php?t=120934#features-bufferjump

Literally:
“Q: When I burn a disc in Nero, the buffer dances wildly, is this a problem?
A: NO, not normally, this happens with most new 16X DVD writers, on the NEC drive this is normally caused by the drives AOPC system recalibrating the optics and laser power as the burn progresses. This system is also used to grade media and determine if the burn should continue at a faster speed or slowed down to preserve burn quality”

But maybe the explanation given there is a bit difficult to understand for the general public

All you guys worried about this peculiar /apparent device buffer under-run observed while burning in these NEC writers, please STOP worrying :slight_smile: because it’s just the shadow of a fairy giving you periodically a gift :wink: testing quality of burning several places on the DVD disc (AOPC), so it will re-adjust laser power or slow-down depending on these inmediate / smart tests.

When burning a test disc with Nero, you will notice those ‘strange’ negative spikes in the middle (more or less) of each constant-velocity-zone.

I’m not an expert, just a curious reader, sometimes a stubnborn tester :wink: Corrections welcome and appreciated, if any.


#17

Like i have written down several times, my buffer goes down even when i burn the whole disc at 4x.


#18

read again slowly and carefully look for fairy or AOPC in THIS entire post :wink:

You should observe device buffer going down several times in this fantastic NEC writer :), despite the fact is a flat burn @ 4x speed

Cdfreaks example (though 16x CAV). You should observe similar down-spikes @4x CLV.

Those spikes are related to that device buffer going down, as far as I understand. corrections welcome from experts, if any :slight_smile:



#19

@yawn, i realy cant belive that this thread has been going for 2 months and nearly 20 posts and you still havent got the jist of AOPC. unless you post a screen shot of your buffer problem, i for one will ignore any further posts you make on this matter.

for us to help you you need to help your self.


#20

ok if you do a CREATE DISC in nero cd speed and it looks like this… it is because of AOPC

at each and every one of those dips the buffer empties while the drive calibrates. in my 2500 it drops a total of 2 times when it speed shifts to 6 and 8x

if you would have followed the links provided you would have seen much the same thing in the other threads.