Interesting failure mode of a Seagate FireCuda 2TB 7mm 2.5" SSHD


#1

A friend asked me for help replacing a failed hard disk in his laptop. It was a 15" HP laptop where HP cut corners by not having a removable flap, i.e. I had the laptop in bits to get to the hard disk underneath after removing countless screws and the obligatory snaps around the keyboard, touch panel, etc. :confounded:

Anyway, I installed his new hard disk, a Seagate FireCuda 2TB 7mm SSHD. I suggested getting this as he had over 700GB on the original hard disk.

After reinstalling Windows 10, I connected up the old hard disk with a USB hard disk dock. Windows could not access the old HDD, i.e. it kept giving device I/O errors and even when it did manage to mount a drive letter, it would dismount it a few minutes later. So I booted into Linux Mint that I have installed on a USB stick. As with past experience, Linux fares a lot better with failing hard disks. I started the copy process of the user profile folders to try recovering what I could.

When I checked a few hours later, I noticed the copy process had stalled. I tried checking what it copied and the file explorer kept hanging when I tried browsing the new hard disk, yet had no problem browsing the failing hard disk. I then tried booting into Windows 10 and it took at least 10 minutes to reach the desktop with a telltale clicking sound of a hard disk failure. I gave up waiting trying to shut down Windows, so I force powered off the laptop.

I went through the tedious of dismantling the laptop to remove the hard disk, popped this 2TB FireCuda into my USB dock and connected it to my desktop.

Once it mounted, I ran Crystal Disk Info and surprisingly did not show any issue. So I ran CrystalDiskMark. When I started the benchmark, its window stopped responding and this is how the disk activity appeared in Task Manager. The โ€˜Hโ€™ drive is this FireCuda SSHD:

It was writing about 1MB/s intermittently with a steady click-click-click sound from the hard disk. If I tried accessing the hard disk in Windows file explorer, it would hang. After about an hour, CrystalDiskMark finally completed the benchmark. I suspect the write figures are due to the cache on the drive, considering how tiny the 4K write figures are.

Finally, I checked CrystalDiskInfo once more. I really wish hard disk manufacturers would be honest with SMART reporting as this hard disk clearly is not healthy despite the SMART figures showing otherwise. :confused:

Anyway, itโ€™s now being shipped back. Iโ€™ve seen many hard disk failures in the past, but this is the first Iโ€™ve seen that severely affects write performance. I also tried wiping off the partition table (with Diskpart), reattaching it and creating a new partition just to rule out a file system issue, but it stayed a dead crawl.