Instruction for Optorite DD0203 bad flash recovery

OPTORITE DD0203 (aka SANYO CRD-BPDV2)

Optotrite’s window firmware flashing utility is prone to failure. You will cause the firmware flashing utility to crash if you accidently press the “ok” button twice. If the firmware flashing utility crashed while it’s updating the firmware, then the optorite drive will appear to be dead (no LED light, no motor spinning noises) even during a reboot. Using the well publicized mtkflash recovery technique will not let you re-flash the optorite drive.

After spending an hour fiddling with boot menu and mode selction pins, i figured out how to make the optorite DD0203 work again. Here is how I did the recovery, 1) copied dvflash.exe and the firmware bin file onto a dos bootdisk 2) move the factory-use-only pin from the right most position to the 2nd right most position. 3) make sure the ide mode selection pin is not on cable select. 4)reboot your computer with the bootdisk 5)start the dvflash utility by typing "dvflash .bin". ( denotes the firmware filename)
6) follow the onscreen instruction (dvflash will automatically detect which channel your optorite drive is on) 7)move the factory-use-only pin back to the original position 8) reboot your computer once the recovery is completed.

I think the recovery can be done regardless of the IDE channel and master or slave position your optorite drive is occupying. The aforementioned instruction should also work for the MSI 4X DVD Writer and Sanyo DVD Writer since they all use the same chipset.
However, you may want to try re-flashing the msi or the sanyo drives without moving the factory-use-only pin before using my method.

:slight_smile:

I too have a dead Optorite DD0203 after accidentally clicking OK twice. (This is less stupid than it seems, it’s finished flashing and the options are OK and Cancel, which would you press?) The difference with my flash failure is that I the machine won’t POST when the drive is plugged in…

When I reset, the computer gets as far as detecting IDE drives in the BIOS when it hangs. If I yank out the power cable, I can get it to boot to the floppy as suggested, but the flash program won’t detect it. I’ve even tried using another drive during boot and swapping it once it’s POSTed. Still no cigar. Any ideas? I’ve had the drive for a couple of months, so returning it is going to be tough!

I am having a very strange problem as well. I flashed mine and had the same thing happen.

Now, when I put a dvd disc of any kind in the drive, it hangs my system. I can only get it back online by resetting it and ejecting the dvd before post.

I tried the recovery flash stated above, but it didn’t do anything to fix the problem for me.

Any one else have better experiences?

I have the same problem (DD0203). A flash update process was not complete properly and my drive was dead. The drive was not recognized by system BIOS.

Following the yanon’s instructions (moving factory pin to 2nd right position) the system bios recognized it. Flash utility too. But again the update process failed.

And now this drive is no longer recognized by System BIOS, no matter which factory pin i set.

There’s something else to do or the drive is really dead?

Damn… after i bad flashed mine 2 weeks ago was trying to do as you did moving jumpers and booting in dos, i guess i never tried the “pin next door”, started from the other side and moved over…ohh well yestersday i rma’d and sent it out back to optorite, i marked the drive hoping i get mine back not somebody’s else’s:(

I’ve tried the suggested method on two machines… No success… Dvflash will not even recognize my drive when it scans the bus… I have the pin in the proper place… Is there anything I can do?

Just wanted to say thanks for posting this info. Needless to say, my drive died when I used the sucky winflash utility downloaded from Accesstek (Accesstek and Optorite are brand names for the same manufacturer). Ugh, I was so sad. :sad:

But then I came across your “experiment” and when I moved the factory pin and plugged the thing back in it came to life (yeah! Little yellow flicker, tray opened). Using cd firmware detect utility I could see it apparently had 2.5 but it was definitely messed up because when I tried to software eject (experiment) my whole system froze up. I then tried to use the dos utility from Accesstek and it told me that I had the wrong software for the drive and quit. :a I then decided to try the dos utility and driver that I found posted on the dangerous brothers site for the Optorite dd0203. Success! (finally)

I did this by creating a dos disk with this slick utility, then saving the flash utility and the .bin file on the same disk. I restarted the computer and used the command dosflash rpc1_250.bin at the a:/ prompt.

I moved the pin into it’s original position and reinstalled; I have burned a data disk but haven’t had time for anything else…but yeah! I thought I had made a paperweight.

Thanks again!

Where is located this pin? It’s inside the unit or in the back panel?
Could somebody indicate me where is?

Thanks :bow:

I believe the poster is speaking about the little black jumper plug(s) in the back on the outside of the DVD drive.