Install updated ASPI or not?

vbimport

#1

Hello people!
I have a Windows 98 and the default Win98 ASPI installed ( that came shipped with Win98, correct me if I'm wrong :wink: )
The problem is that "Should I install the latest 4.71 ASPI?"
I have no Adaptec controller and also I am getting a new Sony writer soon, I am wondering if their will be any side-affects on Win98 or my new burner ( soon )...
Should I install or no?
Thanks people! :bow:


#2

‘if it ain’t broke, don’t fix it’ like my buddy Lazza would say :wink:

The ASPI layer files are for communications between your hardware and some software apps (many of the newer ones don’t need it anymore).

Replacing the existing ASPI version with a new one usually does not improve anything performance wise; use the ASPICHEK utility to verify that the existing installation does not cause problems if you feel your burning experience is unsatisfactory and you have eleiminated all other obvious causes (mainly bad or incompatible media or firmware issues). If there are detected problems, first try reinstalling your exting ASPI files. If it says it is functionning properly and you still have problems, like loss of communication between burner and system under certain circumstances, then try the newer version, it may have fixed these issues.

Just seemed to be the logical approach to the situation, HTH!


#3

Thanks!
I’ll take your advice…
now dumping the driver in to the trash :slight_smile:


#4

just copy the nero aspi file (if you have it) in your systemmap

I only have problems with the new aspi files under XP since version 4.60


#5

Nice to see you here, Oz! :slight_smile:

I kind of agree with you on the ASPI thing. Personally, it never caused me any problems either. Good to check though.

I’m presently on a clean OS (Win98SE) install and I haven’t bothered to install any extra ASPI packages and I have no problems either.


#6

ASPI. I’m with you. Never had a problem. I’m running a dual boot Win98SE/Win2K Pro. I have 4.70 ASPI on both. No trouble to report.

I use EZ CD, Direct CD, Nero 5.5.8.2. & Clone CD 4 all work fine.
Oh, Smartripper 2.41 & various other DivX tools too.


#7

My understanding is that if your os is win 98, 98SE or ME, you don’t need aspi 4.70 or 4.71; AFAIK those versions are intended for win 2k and xp.


#8

Oz, I did. Nero has its own aspi and clonecd doesn’t use aspi at all. Obviously, your other proggies either have their own or else, like clone, don’t need it.

PS. I agree that the general to do about aspi is overrated.


#9

It has been a while since I have ripped a DVD, but I have Smartripper 2.31.
When I tried to run it, it told me I had no ASPI layer. I ran ForceASPI, and all is well. (Win98)
My burning programs does not complain, and neither does I.
Anyway, I guess Smartripper must have been updated, or can acess the drive in W2K?

Errr, my point here is just this:
I, at least, have no bad experiences from installing it. I even have done so several times, due to some formatting…:slight_smile:
If everything works, you do not want to install it.
If something does not work, …well, my advice would be to get hold of ForceASPI, install it, and if it does not help, uninstall it.
Just my 0.02$. :slight_smile: